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Welcome to QXmlEdit

View and Navigate XML Data in Unusual Modes

QXmlEdit ofers you the possibility to view, navigate and edit XML data as few other editors. It is 
like a Swiss army knife. It is multi platform and, more, it is Libre Software; that means that it gives 
to the user the freedom to adapt it to its needs and it comes with complete source code.

Information About QXmlEdit

QXmlEdit is an XML editor and its main features are:

• Hierarchical customizable view of XML elements.

• Fast XML hierarchy navigation.

• Handling of base 64 coded text and XML inserted as data.

• Powerful search.

• XML snippets.

• XML compare utility.

• XML Schema viewer.

• Visual compare of XML schema.

• Flex code generation from Balsamiq source.

• Session handling.

• XSL specialized mode.

• Split of big XML fles. 

• Data anonymizer.

Before You Begin

QXmlEdit is an XML editor. To use it with profciency you need to be accustomed with XML. It is a 
technical tool oriented toward software developers.

What You Will Learn

Following this manual you will learn to:

• Examine XML data in details.

• Applying diferent views to XML data to examining them under diferent points of view.

• Customize QXmlEdit to ease your work.

• Navigate and inspect XML data.

Finding Out More

On the QXmlEdit Internet site you will fnd the up to date documentation and tutorials. The site 
address is: http://qxmledit.org. The link for the source code is: 
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https://github.com/lbellonda/qxmledit.

To get help while using the program you can use the menu Help > Help on QXmlEdit.

What's New in This Version

New features: an improved XSD reporting engine.
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Overview of QXmlEdit User Interface

The user interface is very simple and consists of a main panel where all the functions of the 
program can be controlled.
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Operation with XML

This is a small abstract of the common operations grouped by purpose:

• Navigation:

◦ Go to parent element (menu Navigation, shortcut F12).

◦ Go to next sibling (Navigation, F10).

◦ Go to previous sibling (Navigation, F9).

• Data modifcation:

◦ Insert or append an element.

◦ Insert or append a comment.

◦ Insert or append a processing instruction.

◦ Change the position of a node.

◦ Paste a node as child or sibling.

◦ Copy or paste a set of attributes.

◦ Operation on containers:

▪ Insert a parent

▪ Insert a child container that enclose all the current children

▪ Remove the parent of a node.

◦ Transform a node into a comment and viceversa.

◦ Insert prolog and namespace declarations.

◦ Edit base 64 coded text blocks.

◦ Edit base 64 coded attributes.

◦ Transform fles into base 64 text blocks.

• View Data:

◦ Hide all the siblings of a node.

◦ Hide all the children of all the sibling of a node.

◦ Filter the visible attributes.

◦ Hide all the elements that have no children.

◦ Show the children count and the size of a node.

◦ Close all the siblings of a node.

For a complete description of each operation go to the specifc section of this document. Here you 
will fnd a small reminder of the commands.
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Startup

The frst time QXMLEdit is started, it asks the user if a simplifed user interface should be 
activated. Through a panel it is possible to access the main features but there are no restrictions 
about what QXMLEdit can perform. At any time, using the Preferences menu, the choice can be 
reverted.

If the choice is “guided user”, the following panel is open:
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From above panel the following operations can be started:

Item Description

New Open a new editor.

Open Load an XML fle.

Validate Validate XML using XSD.

Formatting Formatting and indentation options.

Vision View Options.

Editing Editing options.

Configure Open the main preferences panel.

Expert User Switch to “Expert User” mode.

Extract File Extract fragments from an XML.

View XSD View an XSD fle as a diagram.

Compare Compare XML fles.

Base 64 Open the Base64 operations panel.

View Data Map View XML fle  statistics.

Anonymize Anonymize a fle using previously created profles.

User Manual Open the user manual.

Editing Shortcuts Show the editing shortcuts.
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Main Functionality

Menus are divided in main functional groups; the most used commands are kept visible in main 
dialog as a button on the right.

The menus are described here:

Menu Functionality

File XML document creation and saving

Edit clipboard handling; fnd command and confguration options

Tasks common tasks, grouping other menu commands

Bookmarks all about bookmarks

XML XML tree manipulation (insertion, deletion, etc)

Special special XML operations

Navigation XML tree navigation

View view commands and options

Sessions Session related commands

Tools plugins and tools

Help help

Working with XML Files

The QXmlEdit goal is to view and edit small XML fles. It is not intended to handle data of hundred 
of megabytes, since it works completely in memory.

Opening Files

1. Open fles using the File > Open menu.

2. In the Open Files dialog choose the fle type you are looking for.

Opening Files in New or Same Window

This feature lets you override the settings by opening a fle in a new window, if open new fles in 
same window is selected as a global option. If the confgured behavior is to open fles using new 
windows, the option lets you reuse the current editor window.

• Use the menu File > Open in New Window if behavior is to open fles reusing same 
window.

• Use the menu File > Open in Same Window if behavior is to open fles using new 
windows.
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Using only One Window or One Window per File

This setting can be confgured in the preferences dialog.

• Menu Edit > Configure

• Select General tab

• Check “Open in new window” option.

Saving files

You can save the fle using this menu commands:

To save the fle with the same name:

• Save the fle using the File > Save menu.

To save the fle with another name

• Save the fle using the File > Save As... menu.

To save a copy of the fle with another name, but continue to work in the original fle:

• Open fles using the File > Save a Copy As... menu.

Note:  using this last option you make a copy of the fle as it is in its current state. The original 
fle is not modifed and the editor retains the current state.

Creating a File From Clipboard Contents

Sometimes you can create a new fle by pasting an XML text from the clipboard. For example you 
can cut a block from a database client or a PDF or HTML page.

Use the menu File > New From Clipboard.

Creating specialized files

Using the File > New Specialized item, you can create new documents of a particular kind.

• XSL-FO

• XML Schema

• XSLT

• Maven POM.xml

• SCXML

The documents are created with the predefned namespaces and declarations.

Creating Documents from Snippets

Using the File > New Specialized > New from Snippet item, you can create new documents 
from a previously saved snippet.

Reloading last saved version

Using the menu File > Reload the last saved version. The modifcations to the current fle will be 
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lost.

Exporting the XML

The following export methods are available from the File > Export menu:

• Export Element to File

• Copy all to the clipboard

• Export as Java/JavaScript

• Export as C/C++

Avoiding modifications

The document can be put in read only mode using the menu Edit > Read Only

Loading the Last Edited Files

Using the menu File > Recent Files you can load the last edited fles.

Working With Preferred Directories

Usually, working with fles, there are some directories that are accessed often. QXmlEdit gives 
you the possibility to remember these places and to quick recall them when opening fles.

To add the directory of the current open fle to the preferred ones:

• Use the menu File > Preferred Directories > Add Current Directory to Preferred Ones

To edit the directory list in a separate window:

• Use the menu File > Preferred Directories > Edit Preferred Directories...

A dialog will open
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To add a new link to a preferred directory

• Push the Add... button.

To remove a link to a directory

• Push the Remove button.

To confrm the directory list press OK.

To open a fle into a preferred directory:

Use the menu File > Preferred Directories, then select the directory.

Viewing Elements and Attributes

After having loaded XML data, there are many modes to view elements and attributes. The main 
view uses a tree representation, mapped on XML data, however you can highlight some data 
aspect:

To view one element attribute on a separate line (very readable if you are looking for attribute 
values):

• Select the menu View > Show One Attribute per Line
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To show the ordinal position of each child relative to their parent:
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• Select the menu View > Show Child Index

To show a more compact view:

• select the menu View > Compact View

To show the attribute length near to their name:

• Select the menu View > Show Attributes Length.

To show attribute contents using a fxed size font, to better discover the presence of spaces:

• Select the menu View > Show Attributes Length.

To show in a separate column the text length of the elements:

• Select the menu View > Show Text Length.

QXmlEdit user manual, page 17 of 141.



To show the number and size of the children of each element:

• Select the menu View > Show Element Size.

To show the text contained into elements as base 64 encoded:

• Select the menu View > Show Text as Base 64 Coded.

Note: this option can have an impact on visualization speed.

To expand all the closed branches of the XML tree:

• Select the menu View > Expand

To enlarge or reduce the size of the character used to display the data:

• Select the menu View > Zoom In or View > Zoom Out.

or

• Use the Control key while scrolling with the mouse wheel.

To view only the structural components of the XML (the elements that have other elements as 
children):

• Select the menu View > Hide All the Leaf Children

To undo the efect of the previous command:

• Select the menu View > Show All the Leaf Children.

To show or hide on the basis of individual node, frst select the node, then, to hide:

• Select the menu View > Hide Leaf Children.

To show:

• Select the menu View > Show Leaf Children.

Filtering Attributes

It is possible to flter the display of the attributes. A profle can show only a set of attributes or 
hide a given list of attributes. When an element has some hidden attributes, a flter icon appears.

It is possible to manage the attributes that can be shown or hidden in each element using the 
menu View > Filter attributes > Manage Profiles...

In the management section it is possible to create delete or apply profles.
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To apply a temporary profle, based on the current element:

1. Select an element.

2. Use the menu View > Filter attributes > Apply a Temporary Profile.
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It is possible to transform the temporary profle into a regular one using the menu Use the menu 
View > Filter attributes > Save the current Profile.
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Working with name spaces and prefixes

Namespaces and prefxes commands can be accessed from the XML > Namespaces menu item. 
Both ofer prefx manipulation, but only namespaces comamnds are aware of namespace 
concepts. Prefx related items do not know about namespaces at all, they simply manipulate 
prefxes.

Prefix operations

The operations that can be performed on prefxes are:

• Assign a prefx.

• Remove a prefx.

• Replace a prefx.

Assigning a prefix

This operation sets the same prefx to all the elements on which it is applied. No considerations 
about namespace declarations are made.

Panel:

Items:

Item Description

Prefix to set The prefx to apply

Apply to Elements involved.

Removing a prefix

The remove option removes the selected prefx from all the items, only from the selected item or 
from the selected item and all its descendants, from tags and attributes. Choosing a If there is a 
selection, the prefxes found recursively in the selection are shown in the prefxes combo. No 
attention is payed to the namespaces in this operation.
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Items:

Item Description

All prefixes Choose to remove all the prefxes.

Choose a prefix Removes a single prefx.

Apply to Elements involved.

Replacing a prefix

This operation replaces one or all the prefxes with another one.

Items:

Item Description

All prefixes Choose to replace all the prefxes.

Choose a prefix Replace a single prefx.

Replace with The prefx that will be inserted.

Apply to Elements involved.

Namespace operations

The operations that can be performed on namespaces are:

• Assign a namespace.

• Remove a namespace.

• Replace a namespace.

• Normalize a namespace.
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Assigning a namespace

This operation assigns a namespace to a tree or to all the document. The selected namespace will 
be declared if not existent.

Items:

Item Description

Namespace The namespace to set.

Prefix The prefx to set.

Apply to Elements involved.

Removing a namespace

Remove one or all the namepaces. The declarations of the removed namespace can be optionally 
removed.
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Items:

Item Description

All namespaces If chosen, all the namespaces will be removed.

Choose a namespace Select only one namespace to remove.

Remove declarations With this option even the namespace declaration will be removed.

Apply to Elements involved.

Replacing a namespace

This operation replaces a selected namespace with another one. All the namespace elements will 
be translated, even if declared with diferent prefxes. 

Items:

Item Description

Namespace to replace The namespace to be replaced.

Namespace The namespace that will be assigned.

Prefix Prefx of the new namespace.

Select Recalls the namespace selection panel.
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Normalizing a namespace

This operation sets the same prefx on all the elements and attributes belonging to a namespace. 
The prefxes of the namespace other than the selected one are lost and their declarations 
removed.

The normalization operation assumes that the XML is well formed and valid, so the chosen 
namespace must be legally declared. This said, it will not be declared anew on the children if the 
option “Declare namespace on root” is selected.

This option removes all the declaration from the inner of the selection tree and forces a 
declaration on root of the selection tree. If the apply zone is only a part of the tree, only this part 
will be checked. If there is no namespace declared, a declaration on root will be created if the 
option is enabled.

Using this option it is possible to manage a namespace in only a branch of the XML tree.

Panel:
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Items:

Item Description

Namespace The namespace to normalize.

Prefix The prefx to apply to normalized namespace.

Select Opens a namespace selection panel.

Apply to Elements involved.

Declare namespace on root The declaration of the namespace is moved to the root element 
only, any other inner declaration will be removed.
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Choosing an Editing Mode

Using the XML > XSLT Edit Mode menu item you can switch to XSLT edit mode. When loading a 
fle with xxslx extension or containing a reference to XSLT namespace a panel will open.
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1. To activate the XSLT mode simply answer xYesx or use the return key.

2. To have the mode always activated without answering the panel any more, select xAutox.

The settings can be also changed using the preferences.
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1. From the Edit menu choose xConfgurex, then xEdit modesx.

2. Set if the XSLT edit mode should automatically engage.

3. You can hide the panel if you do not care to enter this mode.
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Using XSLT Edit Mode

Specific display style

A specifc display style will be applied only to XSLT elements. The intermixed non XSLT elements 
will not be touched, to reveal the XSL structure at a glance.
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Specific edit panels

1- Double click an XSL element in the editor.

2- A special panel will open.

3- When you edit the xselectx attribute, the autocompletion function will list the relevant 
variables.

4- When invoking templates or parameters, you will see their names in the combo.

5- To return to the usual property panel use CTRL-double click.
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A specific context menu

A new context menu appears on the editor elements. The menu propose to you the most used 
XSL elements giving you the choice to append them to the current element as sibling, or to insert 
them

as a child.

The proposed elements are sync with the context, that is in a xcall-templatex, the only xwith-

parameterx element is proposed as a child.

Using names for auto-completion

When XSTL mode is acting, you can scan the target XML fle to extract names to be used with the 
auto-completion feature of the edit panel.

Use the menu XML > Target XML
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Navigate templates and functions

A XSL navigator for functions and templates will open automatically in the editor when choosing 
XSL edit mode. The navigator can be shown or hidden using the menu Navigation > Show XSL 
Navigator. A double click will lead you to the template or function defnition in the editor.
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Using SCXML Edit Mode

Specific display style

A specifc display style will be applied only to SCXML elements. The intermixed non SCXML 
elements will not be touched, to reveal the SCXML structure at a glance.

Specific edit panels

With SCXML edit mode enabled:

1- Double click an SCXML element in the editor.

2- A special panel will open.

3- When selecting a state name, a combo will reveal the list of states defned in the fle..

5- To use to the usual element edit panel use CTRL or ALT while double clicking.

If the SCXML edit mode is not enabled, the double click modifers are reversed.

Navigate states

A SCXML navigator for states will open automatically in the editor when choosing SCXML edit 
mode. The navigator can be shown or hidden using the menu Navigation > Show SCXML 
Navigator. A click will lead you to the state defnition in the editor, a double click will open the edit 
properties window.

The list of states can be fat or hierarchical.

QXmlEdit user manual, page 38 of 141.



QXmlEdit user manual, page 39 of 141.



XML Schema management
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Inserting Xml Schema References

It is possible insert references to an XML Schema set of fles. Using the menu XML > Schema 
Instance >  XML Schema References the “Insert Xml Schema References” dialog will appear.

In this dialog you can insert

• a schema reference for elements without namespace

• for each namespace, a schema reference

The references will be inserted in the root element using the xsi namespace defned as 
http://www.w3.org/2001/XMLSchema-instance namespace. If the namespace is already 
declared in the root element, it will be used, else the namespace declaration will be inserted. If the 
prefx xsi is already used, a new prefx will be created.

 Using the XSD Edit Mode

There is a facility for edit XML Schema documents in the editor a set of menu commands:

XML Schema > Insert No Namespace Schema Reference Attributes : insert a no namespace 
attribute for the target schema to complete.

XML Schema > Insert Schema Reference Attributes : insert a namespace attribute for the 
target schema to complete.

Editing or inserting a type, attribute or element

Using the XML Schema menu items it is possible to edit or insert XSD types. 
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Operations in the dialog:

Choosing the type

• Reference: will set a reference to a type.

• Simple: inner simple type.

• Complex: inner complex type.

When choosing a complex type, it is possible to choose the content type. 

If it is an update of existing data, the existent children that are not compatible with the selected 
type will be deleted, but the children that are compatible will be preserved.

Edit an annotation

The annotation of XSD objects can be edited using the menu:
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XML > XML Schema > Edit XSD Annotation

If the element has no annotation one annotation is automatically created and the edit panel is 
open. From this panel is it possible open the complete edit annotations panel where more than 
one annotation can be inserted for the given element. If the element has already more than one 
annotation item, the full annotation panel is open.

Single annotation panel

This panel confgures a single annotation item.
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The panel can show the inner contents of the annotation when containing XML mixed to text.
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Available options:

Command Functionality

Type Switch the type of the annotation item between documentation 
and appinfo.

Source Set the source of the item.

Language Valid only for documentation type.

Comment/text Edit feld for the annotation item

Comment/XML XML view of the annotation item. This view is read only.

Advanced When the panel opens and the parent element has no items or 
only one, this button opens the advanced edit panel.

Annotation list edit panel

This panel shows a list of annotation items. Form here the items can be created, edited and 
deleted.
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Available options:

Command Functionality

New Create a new item.

Modify Edit the selected item. This option can be triggered also by a 
double click on the list.

Delete Delete the selected item.

Move Up Move the item one position up in the list.

Move Down Move the item one position down in the list.
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Editing Enumeration or Facets

The factes can be edited selecting the restriction element ad using the menu item:

XML > XML Schema > Edit Enumeration or Facet

The panel list all the facets. The items can be reorder, edited and annotated. Not legal elements 
are discarded.

Edit facet panel

This panel edits a single facet item.
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Editing XML Schema Attributes

Inserting the Schema Instance “nil” Attribute

Select an element and use the menu “XML>Schema Instance>Insert “nil” Attribute”  to insert 
the Schema Instance (XSI) “nil” attribute. If the namespace “xsi” is not present, it will be inserted 
in the element, changing the prefx if the same prefx is already used; after that the attribute is 
inserted.

Removing the Schema Instance “nil” Attribute

Select an element containing the Schema Instance “nil” attribute and use the menu 
“XML>Schema Instance>Remove “nil” Attribute” to remove the XSI “nil” attribute. If the XSI 
namespace is declared in the elements and it is not used in the same element or its children, the 
namespace is removed too.

Inserting the Schema Instance “type” Attribute

Select an element and use the menu “XML>Schema Instance>Insert “type” Attribute” to insert 
the Schema Instance (XSI) “type” attribute. If the namespace “xsi” does not exist, it will be 
inserted in the element, changing the prefx if the same prefx is already used; after that the 
attribute is inserted. The type can be chosen by using a dialog.

Removing the Schema Instance “type” Attribute

Select an element containing the Schema Instance “nil” attribute and use the menu 
“XML>Schema Instance>Remove “type” Attribute” to remove the XSI “type” attribute. If the 
XSI namespace is declared in the elements and it is not used in the same element or its children, 
the namespace is removed too.
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Tasks

Tasks are operations than can be accomplished using diferent commands. They are a sort of 
macro, The following tasks are predefned:

Task Description

Adjust Display Detail Set the editor view options.

Adjust Display Detail

With this task the level of detail of the editor is set. You can choose between some predefned 
settings and have a preview of each one.

Options:

Command Description

Use Predefined Use the predefned settings.

Use (value) Use the style shown in the selected tab.
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Preferences

The preferences panel can be opened using the menu Edit > Configuration.

The panel allows the confguration of the following categories:

Information Description

General General options.

Style Management of display style in the editor.

Editor Colors The name says all.

Validation Option related to XML and XML Schema validation.

Sessions Management of sessions data.

Edit Modes Activation of special modes in the editor (e.g. XSLT).

XML XML management.

Here a detailed explanation of the options:
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General

Option Description

Show welcome page Shows the welcome page at program start up.

Enable experimental features for 
test purpose

Enables experimental feature in development editions.

Default font bold Use bold font weight for elements.

Override the font for elements 
display

Use a user chosen family in the editor.

Override the font for fixed 
spacing attributes 

Use a custom font when rendering attributes with mono spaced 
font.

Enable Logs Enable logging.

Automatically expand editor tree 
when loading data

Expands (open) the whole tree after loafng a new fle.

Autoscroll in the elements tree Enable autoscroll when dragging items

Open files in new window A new window is used each time a fle is loaded.

Limit attributes length The maximum length of the attributes lines in XML visualization.
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Style

This panel lets you choose the location for user defned styles fles.

Option Description

Use the program directory Use the installation folder

Use the standard Operating System 
location

Use the default location for data.

Use the following directory Use a user defned folder.
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Editor colors

This dialog is described in details in the Style section. You can customize the colors of the editor.
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Validation

Option Description

Enable automatic loading of XML Schema 
associated to file edited

Automatically loads referenced XML schema fles in the 
background at the XML fle loading.

Enable disk cache (maximum size: 1 Mega) Enable cache for XML schema fles to avoid unnecessary 
network trafc.

Embed fonts in PDF report Option to embed fonts in PDF report

Embed diagram image in HTML If the diagram image in HTML report should be inlined or 
generated as external fle.

Use Graphviz to generate diagrams in HTML Use GraphViz (not included in QXmlEdit) to generate the 
diagram image. This option is experimental

Override GraphViz path Custom path to dot executable.
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Sessions

Session options described in the Session section.
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Edit Modes

This panel for the options related to specialized edit modes.

Option Description

Automatically switch to XSLT edit 
mode when opening an XSLT file.

When loading a new fle, if it is recognized as a XSLT documents, 
XSLT edit mode is automatically enabled.

Show the "Switch to XSLT" panel 
when opening files.

When loading a new fle, if it is recognized as a XSLT documents, 
open the XSLT edit mode panel.

Use external Java engine with 
Saxon command line syntax

If you want to use an external XSLT Java engine having the same 
command line interface as Saxon, insert here the path of the jar.

Automatically switch to SCXML edit 
mode when opening a SCXML file.

When loading a new fle, if it is recognized as a SCXML 
documents, SCXML edit mode is automatically enabled.

Show the "Switch to SCXML" panel 
when opening files.

When loading a new fle, if it is recognized as a SCXML 
documents, open the SCXML edit mode panel.
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XML

XML management options

Option Description

Automatically insert prolog with 
encoding

When creating new fles, insert XML prolog with optional 
encoding specifcation.

Automatically update metadata as 
processing instruction if found 
when saving data

Enable the update of QXmlEdit specifc metadata in the fle 
when saving.

Automatically insert formatting 
metadata process instruction

When creating a new XML document insert a processing 
instruction that holds formatting settings (indentation, ...)

XML indentation on save Enable or disable XML indentation when saving. A value of 0 still 
saves on element per row. You have to disable it explicitly if you 
want only one output text line.

Save using stream instead of DOM Enabled by default. Allow a fner control on input and output. 
DTD declarations are not handled if this option is unchecked.

Sort alphabetically the attributes On saving the attributes will be sorted alphabetically on their 
name.

Attributes line length It limits the start column of the attributes. If a limit is set, if the 
attribute start at a column that is greater than the distance from 
the tag end than the limit, a new line is started. 

Limit attribute length to X 
columns

Limits the length of the attribute zone when saving the fle.

Process formatting metadata When reading a document, if formatting metadata are fouund, 
they will be applied.
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Customization

Choosing a Display Style

QXmlEdit can use a diferent display style, the font used, its dimensions and the color, to 
represent diferent XML structures. The style description can be created by the user and applied 
on demand. QXmlEdit comes with some predefned styles.

The style can display the value of some attribute near to the element tag to highlight the element 
type.

To apply a style:

• In the main window, click the styles popup ( ), then choose the desired style. 

To remove a style:

• In the main window, click the styles popup ( ), then choose the ”== No Style ==“ item

The style fles location can be confgured using the menu item Edit > Configure.

In the appendix there is the complete style reference.

An example of style applied to an XML Schema fle is represented in the following screenshot:
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The style can be used to highlight the elements.

The Style can be based on rules, in the appendix there is the full detail. 

Editing Elements

Basically you can use the tree view to insert child nodes or append nodes as brothers of the 
current one. There is a separate input panel for each node type you can manipulate: elements, 
comments, processing instructions.

To insert an element as a child of some other node:

• Select the XML > Add a Child Element menu.

or

• Click the button Add Child... on the main window.

To append a node as brother of the current selection:

• Select the XML > Append a Brother Element menu.

or

• Click the button Append... on the main window.

To work with attributes:
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• open the element edit panel and start editing

To insert a processing instruction as a child of some other node:

• select the XML > Add Processing Instruction as a Child menu

To append a processing instruction as a brother of some other node:

• select the XML > Add Processing Instruction as  Brother menu

To remove a node of any type (element, attribute, comment, processing instruction):

• click the button Delete on the main view

Navigating Elements

There are some shortcuts to move from one element to another one using the relationship 
between the two. These shortcut are handful especially when the data tree is very tall, and avoid 
you the necessity to continually scroll the window while examining data.

To rise from an element to its parent:

• select the element, then press F11

To jump to the next element at the same level of the current one:

• select the element, then press F10

To jump to the previous element at the same level of the current one:

• select the element, then press F9

To close all the children of an element and all the children of their brothers (it gives you a compact 
view of the tree level in one operation):

• select the element, then press F12

Editing Elements and Attributes

To edit the selected object:

• double click on the selected element

or

• press the Edit... button in the main window

When editing elements a panel will open. In the panel the current element path is shown; it is 
possible to manage namespaces by recalling a library of user defned data. It is possible to manage 
base 64 coded attributes.
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In the panel you can insert the following information:

Name Information

Tag The tag of the element

Text Nodes You can insert or remove text nodes as element children

Attributes You can edit the element attributes

To insert a text node:

• press the + button in the text nodes section

To insert a CDATA text node:

• press the + button in the text nodes section then activate the CDATA check box on the text 
nodes table

To modify text node content:

• Select the text node, then press the Mod... button. A panel will open.
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Note: you cannot edit child element nodes in this panel, only text nodes.
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To insert a base 64 coded text:

• Insert the text, then press To Base 64 button, then save the text.

To modify a base 64 coded text:

• Press the From Base 64 button, the text will be decoded, modify the text, then press To 
Base 64 button, then save the text.

To view the text on more lines even it is a single line:

• Activate the wrap text check box.

To load a binary fle as base 64 coded text:

• Press the Load from file... button, then browse to the fle in the fle dialog.

To save current base 64 coded text into a binary fle, decoding the values:

• Press the Save to file... button.

Deleting siblings

The menu XML>Siblings lets you

• Delete the siblings before the selected element.

• Delete the siblings after the selected element.

• Delete all the siblings of the selected element.

Copying Selected Text Into the Clipboard

The selection can be always copied using usual shortcut keys or the Edit menu items, but when 
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selecting an element there is the possibility to copy only the element or the attribute name or 
value using the copy button located in main window:
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to copy the selected element tag:

• click the Copy Element Tag item

to copy the selected element content:

• click the Copy Element Text item

For each attribute of the selected element:

to copy the attribute name:

• click the Copy Attribute Name item

to copy the selected attribute value:

• click the Copy Attribute Value item

Namespaces

In the edit element window it is possible to recall the namespaces management dialog.
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In this dialog it is possible insert namespace references recalling the namespace selection dialog.

namespace. The user defned namespaces are managed in a separate dialog, stored permanently 
and are available to successive sessions of QXmlEdit.
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Using the Bookmarks

You can mark the elements with bookmarks for easy retrieval and navigation.

To set a bookmark:

• select an element, then use the menu Bookmarks > Toggle Bookmark (CTRL-F2)

To remove a bookmark:

• navigate to the bookmark, then use the menu Bookmarks > Toggle Bookmark (CTRL-F2)

To remove all the bookmarks:

• use the menu Bookmarks > Remove All Bookmarks

To move to the next bookmark:

• Press F2

or

• use the menu Bookmarks > Go to Next Bookmark

To move to the previous bookmark:
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• Press Shift-F2

or

• use the menu Bookmarks > Go to Previous Bookmark

QXmlEdit user manual, page 74 of 141.



Viewing and editing info and DTD

Basic information about the fle can be shown using the menu Edit > Info

The information is relative to:

• Encoding.

• XML Schema references embedded into the fle.

• Declared name spaces.

• DTD.

• File information.

Here an “Info” panel:

Please note that some namespace prefx can be used in more than one place with diferent 
references.

The “role” column will list well known namespaces.

The DTD of the document can be edited in this panel if the fle is not read only. The manually 
edited DTD is not checked against syntax errors.
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Working with Base64 Coded Content

Sometimes the data of an element are text nodes or binary data base 64 coded. QXmlEdit can 
display decoded base 64 coded text near to the literal content in the main window, and permit you 
to edit directly the content.

To edit directly the base 64 coded text of an element:

1. select the element, then right click to make the context menu appear and select Edit Inner 
base 64 Text. 

2. Write directly the text into the edit box of the panel that appears. 

The text will be automatically encoded and decoded as needed.

Working With Inner XML Content

Sometimes the data of an element is an XML payload registered as text, or a base 64 coded XML. 
QXmlEdit can edit directly both the types of contents.

To edit directly the XML data stored as payload of an element:

1. select the element, then right click to make the context menu appear and select Edit Inner 
XML. 

2. Another QXmlEdit Window will appear; you can use it to edit the inner XML. 

The XML will be automatically encoded and decoded as needed.

To edit directly a base 64 coded XML used as element payload:

1. select the element, then right click to make the context menu appear and select Edit Inner 
XML Base 64 Coded. 

2. Another QXmlEdit Window will appear; you can use it to edit the inner XML. 

The XML will be automatically encoded and decoded as needed.

Inserting an XML prolog on document creation

You can insert an XML prolog XML using the menu XML > Insert prolog. You can insert 
automatically a prolog on document creation using an option in the confguration panel. In the 
panel you can also select the encoding to be used.

Formatting a document

QXmlEdit can use a processing instruction to store and retrieve formatting settings for 
indentation, attributes display and so on.

If the processing of the instruction is enabled, the settings are read and applied at the next saving. 
If some formatting options is changed and the instruction exists in data, the instruction is 
automatically updated before saving.

The instruction processing can be enabled in preferences, XML section.

To insert a formatting processing instruction use the menu item Edit>Formatting>Add 
Formatting Info. To remove it us the same menu, and the Remove Formatting Info item.
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To enable or disable the management for a single document, use the formatting panel with the 
toolbar or the menu item Formatting>Formatting…

The preferences panel has an option to automatically insert the instruction at each document 
creation.

The processing instruction is transparent to XML management, however should you want to avoid 
it, you can disable it in preferences panel.

Formatting Presets

In the menu Edit>Formatting there are some common (hopefully) presets. The name of the items 
gives a clue about its settings.

Validating an XML Document

An XML Schema validation option is available, but it uses the Qt XML validation facility, that is 
rather limited at the moment. The validation is made by default using schema references 
contained in the XML document, if any. You can use an external XML Schema fle; after this 
assignment the validation is performed using the assigned fle until an explicit command to use 
the document references is given.

If an external schema fle is used, its path is visible In the tool tip of the toolbar “Validate” 
command.

To validate using the last assigned schema:

• select the menu XML > Validate

To validate a document using self referenced XSD, if any:

• select the menu XML > Validate Using Document References

To use a diferent an XML Schema fle:

• select the menu XML > Validate Using New Schema File

NB: the validation option is available only if compiling at least with the Qt 4.4. It uses the Qt 
XML validation facility, that is rather limited at the moment.

Counting Children Elements and Measuring Their Size

It is possible to display the sum of the number of elements children and the element total size, 
calculated on the canonical element form ( i. e. counting stating and ending tags ). The size 
calculated is only an approximation of the real value, given that there are many modes to write the 
same XML data.

To activate the option:

• select the menu View > Show Element Size

Finding Text

It is possible to execute searches in the editor. To open the search panel:
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• use the Edit > Find menu

or

• press Control+F
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In the panel you can do the following operations:

To start a search:

• insert the text in the edit box and press Enter key or press the Find button

To limit the search to a particular kind of XML components, use the Search In option box:

• All the types of components

• Element tags only

• Attribute names only

• Attribute values only

• Text nodes

• Base 64 coded text

The elements that match the search rules will be highlighted, but you can act on the display in the 
following manners:

Name of the Option Information

close unrelated close all the branches that does not contain any occurrence of the search text. 

selection to bookmarks adds all occurrences found to the bookmarks collection. 

match exact value executes the search of the exact value of text (opposed to regard the text as a 
substring) 
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case sensitive the search will be case sensitive

find all mark all the occurrences of the search pattern with a background pattern to 
ease the reading, elsewhere the search will stop to frst match. 

only in children the search can be limited only to children of the selected item or to the whole 
tree. 

scope can limit the search to a set of elements or attributes. This feld can contain a 
path in XPath like syntax. For example to search a value in the “id” elements 
children of “resource”, the feld must contains “resource/id”. If the search has 
to be performed only on “name” attribute of the “window” element, write 
“window/@name”. To include any elements between “window” and “widget” 
tags, simply omit it as in “window//widget” 

XPath Activates the XPath syntax (see below for details). If unchecked the text 
entered in the search box is used as pure text. 

The number of matches is reported in a box at the bottom of the search panel. 

It is possible to fnd the next occurrence starting the search from the selected item. You can use 
the command buttons in the panel or activate it using the following command:

• use the Edit > Find Next menu

or

• Use the key F3

Search results

The matching items are highlighted and, in combination with other options, non matching items 
are closed.
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XPath syntax

In the panel you can do the following operations:

To start a search:

• select the “XPath” check box

• insert the text in the edit box using XPath syntax and press Enter key or press the Find 
button

A small note will indicate the XPath mode activation.

If “Only in Children” check box is selected the root of the search is the current element, if not the 
search starts at the document root.

Some of the options available to the text search are hidden because their operation can be carried 
on using XQuery and XPath.

The elements that match the search rules will be highlighted, but you can act on the display in the 
following manners:
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Name of the Option Information

close unrelated closes all the branches that does not contain any occurrence of the search text. 

selection to bookmarks adds all occurrences found to the bookmarks collection. 

only in children the search can be limited only to children of the selected item or to the whole 
tree. 

scope can limit the search to a set of elements or attributes. This feld can contain a 
path in XPath like syntax. For example to search a value in the “id” elements 
children of “resource”, the feld must contains “resource/id”. If the search has 
to be performed only on “name” attribute of the “window” element, write 
“window/@name”. To include any elements between “window” and “widget” 
tags, simply omit it as in “window//widget” 

The number of matches is reported in a box at the bottom of the search panel. 

Search results

The matching items are highlighted and, in combination with other options, non matching items 
are closed.

The following screen shot shows a search using XPath:

Browsing the search results

You can open a search results panel using the button “Open panel” in the fnd panel.

The new panel will show only the search results, giving the possibility to browse directly the 
XPath queries elements or the text search results.
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Replacing text

Replace uses the search feature to fnd text that can match and replace it all at once or one at time. 
Replace is triggered by the menu Edit > Replace.

Replace panel

The following commands are available:

Command Behavior

Replace All Replaces all the occurrences of the search pattern.

Replace and find next If there is a selection, a replacement is applied if there is a match; then the next 
element that matches is selected. If no selection was existing, the next match is 
selected.

Replace and find previous If there is a selection, a replacement is applied if there is a match; then the 
previous element that matches is selected. If no selection was existing, the 
previous match is selected.

Skip and find next If there is a selection  then the next element that matches is selected. If no 
selection was existing, the next match is selected.

Skip and find previous If there is a selection  then the next element that matches is selected. If no 
selection was existing, the previous match is selected.

Note: replace operation cannot use XQuery search.

Comparing Files

The purpose of the comparison as implemented is to give a compact view of changes, comparing 
the current editor content with another fle. The sense of the comparison is to show what 
transformations are needed to the chosen fle to become the current loaded one.

To compare a fle against the current:

1. select the menu File > Compare with...

2. choose a fle

In the panel that opens you have the following information:

• The current fle in XML format with elements and attributes that are diferent between the 
fles with highlighted colors (Synthetic View).

• A structure comparison side by side of the two fles (Analytical view).

• The list of the diferences with the path of elements (Diference list).

The following options can be set:
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Option Meaning

Compare text Compare even the text nodes

Compare comments Take into account the comments

Denormalize EOL In CDATA nodes do not transform the CR LF sequences into LF as stated 
by specs.

In the panel that opens you have the following options:

• Compare only elements or comments and mixed content too.

• Copy the comparison result to the clipboard.

• Retry the comparison, after changing some option.

To start a comparison, load a recent fle from the relative combo box or select another one using 
the browse button.

User interface

Analytical view
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Diferences list
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Anonymizing data

The menu Special > Anonymize recalls a dialog to anonymize the data contained in attributes and 
text of the XML.

This feature can be useful if the XML fle should be sent to technical staf for debugging purposes 
avoiding the disclosure of personal information.

Using this feature the text and the attributes can be altered using a fxed character or using a 
diferent letter for each input character by preserving the case of the original letters.

The original data structure is preserved replacing only letters and digits with altered text, 
preserving the case of the letters and the reserved XML attributes. The tags and attribute names 
are not changed.

Data and business rules

Often the fles contain not only personal information, but also data for business rules. Modifying 
all the contained text or attributes will end in a useless fle transporting no information at all.

To avoid that result, manipulating the parameters that belong to the business rules, two features 
can be used:

• A flter to avoid the anonymization of values consisting of less than 4 characters (the 
length of many codes).

• The use of exceptions.

The exceptions can be bound to any element, attribute or text node and force the subject to be 
anonymized or not; if anonymized, a user defned value can be used to replace the original one.

The exceptions can be hierarchical and extended to the children of the subject. It is possible to 
isolate data from business rules from personal data. When applying more expressions, the more 
specifc wins; for example if an element has been forced to be anonymized with children, and one 
of its children has another exception of reverse meaning, the child exception is applied.

Each time an exception is modifed, the anonymization operation results are shown in a preview 
pane. The original values can be seen in the tooltips of the elements of the preview.

Since creating rules and exceptions is a time expensive process, it is possible to save them using a 
profle and recall them later in other anonymization processes.
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Options
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The options are:

• All text: all the text will be changed.

• Text with more than 3 letters or digit: only the text that is composed by more than 3 letters 
or digits will be changed. This to skip codes that usually have a limited length.

The check box “fxed pattern” determines how the text is transformed.

• If checked: letters are replaced by 'x' and numbers by '1'.

• If unchecked: the letters and the numbers are replaced by a succession of letters or 
numbers in alphabetical order.

The exceptions can be entered selecting the element and using the contextual menu.
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Information in the panel:

Name Information

Profile Name Name of the profle (read only)

Options Options to anonymize data:
• anonymize all the text
• anonymize only the text with more than 3 letters or numbers

As an option it is possible to use a fxed pattern to replace the text.

Preview It shows the fnal result of the operation on the current data

Add Exception You can add exceptions when an element is selected in the preview.

Exceptions The list of the exceptions

Save Profile Saves the current profle data. If the profle has not been created, a creation 
panel will appear.

Edit Profile Edits the profle data.

Profiles Manages the profles.

Import Import a list of exception in CSV format (see below for details)

Export Export the exception list to the clipboard in CSV format

To insert an exception:

1. Select an element in the preview pane

2. Use one of the buttons in the “Add exception” row

To remove an exception:

1. Select an exception in the exception list

2. Press “Delete” in the exception group.

To save the exception list in a profle:

• Press “Save profile”
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If the profle has not be created, a profle creation panel will appear.

To mange profles:

• press “Profiles...”

A list of profles, grouped by tags will appear. Selecting a profle and exiting with “Ok” will load 
the profle in the caller dialog. It is possible also creating and deleting profles.

Configuring the anonymization

The colors of anonymized items can be confgured using the “Editor Colors” panel.
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Format of the CSV for importing and exporting the exceptions

The CSV felds used to exchange the exception list are:

1. The XPath of the exception.

2. The inclusion criteria as integer:

I. 0: exclude (default)

II. 1: exclude with children

III. 2: include

IV. 3: include with children

3. Type of data mask used:

I. Use default.

II. Use a fxed value.

4. A string value if the fxed value replacement is chosen.

5. A numeric fag for processing namespaces.

I. 0: do not process namespaces

II. 1: process namespaces
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Anonymizing a file

When a profle has been created in the interactive anonymized dialog the profle can be used to 
process a fle without loading it into the editor.

To activate the function use the menu Tools > Anonymize File...

In the anonymize panel you have the following options:

Name Option

Source file Name of the source fle to anonymize. Use the “Browse...” button to 
select it

Profile The name of the anonymizing profle. Use the “Change...” button to 
select it among the previuosly saved profles.

Anonymized file Name of the anonymized fle. Use the “Browse...” button to select it.
Note that this function will overwrite the fle.

At the end of the operation the destination folder can be opened by the panel.
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Filling data

It is possible to insert a progressive number or alphabetic sequence selecting an element and 
triggering the menu “Tools > Fill Serie...”. A dialog box will allow to choose the attribute name 
that will contain the progression index.

This is the dialog and below each option is explained:

Options:

Name Information

Attribute Name Name of the attribute that will contain the progression index. If the 
attribute does no exists in the element, it will be created.

Start number The index of the series fll. For the alphabetic enumeration '0' is equivalent 
to 'A'.

Format The format of the index. The possible predefned formats are:
Unpadded number (1,2,3)
Padded number ( 01, 02, 03)
Padded alpha (AA, AB, AC)
Unpadded Alpha (A, B, C)

Overwrite existing values This option allow the modifcation of an existing attribute. Without this 
authorization, the existing attributes are left untouched.

Insert values at the end of existing 
data

If the attribute for the index is existing and overwrite is enabled, the index 
will be written before or after the current data.

Replace existing value Replaces an existing value of the attribute.

Separator This separator is used when inserting the index into existing data.

Apply to the children too. Apply recursively the index. Each series restarts from 0.
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Cloning Elements

Cloning or replicating elements in the editor using an existing sample is activated by using the 
menu Tools > Clone Elements in the 0.9.2 version. Any element can be used as a sample except 
the root one.

The only options available to this feature is if to clone only the selected element or even its 
children recursively, the number of cloned objects and the use of a counter.

The counter that can be insert in an attribute, existing or created while cloning, is the same that 
can  be recalled by the “Fill Serie” dialog,

This picture shows the result of the clone operation with the insert of an index using the “id” 
attribute:
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Working with Snippets

Snippets are pre-confgured XML fragments that can be categorized and inserted in the main XML 
text. A snippet example can be a resource reference in a J2EE component.

To create a snippet:

select an XML element, then:

• select Transform in Snippet from the context menu

or

• select the XML > Transform in Snippet menu

To insert a snippet in the XML you are editing:

select an XML element that will be the father of the snippet, then:

select the menu XML > Insert Snippet.

in the panel that will appear chose the snippet category from the left, then choose the snippet to 
insert.
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To edit the snippets and their categories:

1. Select the menu Edit > Configure Snippets

2. In the panel that will open, insert, modify or delete a snippet at time.

To assign snippets values:

In the edit snippet panel you can supply the following informations:

Name Information

Name The name of the snippet

Description The description that will be shown when choosing a 
snippet

Tags Set of comma separated values that will be used as 
snippet categories. A snippet can have more than one 
category
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Executing XSL style sheet
You have three options:

• Executing a XSLT using the current editor content as source.

• Use the menu Special > XSLT > Execute XSLT using this as source.

• Executing a XSLT using the current editor content as Style Sheet.

• Use the menu Special > XSLT > Execute XSLT using this as source.

• Using a panel to specify the source, the style sheet and the output.

• Use the menu Tools > XSL Executor.

XSLT Execution panel

Using the menu Tools > XSL Executor brings a panel from which you can specify all the details of 
the XSL execution.
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In this panel you can specify:

• The source XML.

• The XSL template.

• The output.

When selecting the XSL template, the parameters, if any, are shown in the list.

If the internal engine has been selected as the XSL engine, you can choose the editors as source, if 
the external engine has been confgured, only fles are allowed.

Note: the support to XSL-T 2.0 in Qt is currently not complete.

You can use SAXON or another Java jar with same command line syntax (not part of QXmlEdit) 
if you confgure it in preferences.
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Metadata

Introduction

The metadata records carry information about the data in which it is located without modify the 
data itself. QXmlEdit supports descriptive metadata implementing it using an XML processing 
instruction whose target is “qxmledit”. 

Metadata types

There are two types of metadata: updatable and static. 

Updatable Metadata

This kind of metadata carries information about the current state of the document and it can be 
automatically updated at each document modifcation if the relative option is enabled. The data 
that can be automatically updated consists of: document creation user and date and the document 
revision. 

Static metadata

The values contain semantic information and cannot be automatically updated without explicit 
user intervention. Some data are predefned, others can be inserted by the user when needed. 

Metadata implementation

The metadata lives on the root level of the XML document. Each metadata record consists of a 
Processing Instruction composed by pseudo attributes. The frst attribute is always “type”and 
denotes the metadata role. The updatable metadata is composed by pseudo attributes that live all 
together in a single “info” type. Other metadata uses a single processing instruction having the 
attribute “value” for the real data. No entities will be resolved in a metadata pseudo-attribute 
except the characters “double quote”, “single quote”, “greater than” and “minor than”, that are 
escaped using usual XML entities notation. 

Operation

Creating a document

The updatable metadata record is inserted manually via menu command. The editable ones are 
inserted using a command that insert the updatables ones too. 

Reading a document

No metadata is automatically inserted on read. 
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Saving a document

When saving, if the option is active, the updatable data are modifed. If the metadata record does 
not exist in the XML document, it will be inserted if the user gives permission. If only partial 
compiled metadata exists, QXmlEdit will complete it. Other unknown metadata information in the 
same processing instruction will be preserved for future compatibility. If no creation data exists, 
the data will be taken from the fle data if available, else they will be created anew. 

Editing metadata

The metadata can be inserted in an XML document using a menu command or by using a dialog. 
The user defned metadata can be handled using the dialog user interface. Malformed data 
inserted by hand will be overwritten. 

Metadata summary

Updatable Metadata

Name Value 

creationUser The login name of the user 

creationDate The date of the creation 

updateUser The login name of the user 

updateDate The date of the modifcation 

revision A progressive value incremented at each 
writing operation

Static Metadata

The values have no special meaning respect to the user defned metadata, however they can be 
presented to the user in a confguration dialog. 

Predefned data: 

Name Value 

project 

name 

copyrigh
t 

domain  

version 

Editing metadata

Using the menu Edit > Edit Metadata you can open the metadata edit panel. Only updatable 
metadata whose check box is selected will be written into the document.
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Working With XML Schema Files (XSD)
When the fle in editing declares itself as a XML Schema (XSD) through the root element and its 
namespace, the button View as XSD in the main window is enabled. This button leads to a 
window that display a graphic view of the fle contents.

Alternatively you can display the current XSD fle in this manner:

1. Load the XSD fle as a normal XML fle.

2. Use the menu Tools > Plugins > XsdPlugin

A window will open with the graphical representation of the data:

The symbols denote:

• E: element

• T: type

• A: attribute
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The icons in the elements represent:

Visualization Types

The visualization modes are two:

• regular: allows to view all the schema entities (low level view)

• outline: allows to view the resulting structure hiding details like restrictions and extensions

The selection of the view mode is done using the “Ouline” button.

Changing the background color and pattern.

In the tools button there is the menu command to open the diagram background inspector. The 
settings are immediately applied and saved.

To open the inspector:

Tools button > Configure aspect...

Exporting XSD Graphical view

In the window there are buttons that permit to export the view as PDF, HTML or SVG fle. The 
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reports can be:

• physical: the children of the entities that refer to other entities are expanded inline,

• logical: (default) the references to other objects are kept.

Command Description

HTML Report Open a panel where a report of the XSD diagram is shown.

Save as HTML A HTML report of the XSD, with the diagram image, is saved to a fle.

Save as PDF A PDF report of the XSD, with the diagram image, is saved to a fle.

Export as SVG A SVG image of diagram is exported.

The preferences panel in the “Validation” tab has some option to  customize the report 
generation.
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Working With Big XML Files

QXmlEdit is targeted to fles with dimensions not too big (< 100 MB). If you need to explore fles 
very big fles, you can enter “Explore Mode” where only the element structure is loaded, without 
data and attributes. In this mode, denoted by this icon in the status bar:  . You cannot edit the 
XML document, but you can search in it as usual.

To activate Explore Mode:

• Select the menu File > Explore Structure...

To exit from Explore Mode:

• Load another XML fle or start a new document.

Searching in Files and counting elements

It is possible to search in external fles the occurrences of a given pattern using a fast parser or 
group and count elements.

The occurrence count will simply count how many of the elements stated in the search pattern 
exist in the fle. The grouping show the aggregation occurrences of the elements.

Let's do an example; if the input XML fle is like that:

have 1 group composed of one 'a' element (the root one), one group of 'b' elements (the children 
of a ) and two groups of 'c' elements: one composed by one item (indicated by the green color), 
and the other one composed by two items (red color).

To search in fles:

• Select the menu Tools > Search in Files...

The search window will open:
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In this window you can insert the following informations:

Information Description

Pattern to search The pattern as XPath (elements only) for example: /a/b/c

File Path Path of the fle to search into.

Grouping The scan operation will calculate element groups too.

Start Starts the search operation.

The icons in the result grid have these meanings:
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Split a XML file

There is the possibility to split a XML fle in smaller fragments and/or to examine the fragments 
directly in the editor. This feature is handy mainly to explore very big fles that does not even ft in 
memory.

When starting, the program will open a welcome dialog leading to the most common operations. 
Choose “Split a file”. If you choose to hide the dialog next time the program restart and change 
your mind, you can reactivate it in the confguration panel. You can access this feature also from 
the menu Tools.

Decide if you want to extract information or browse it

If you want only navigate the data without creating any fle, do not check 'Extract Documents'. 
Even if you don't extract the XML fragments into smaller fle, QXmlEdit scans the fle and records 
the information for an interactive review.

Choose the file and how to fragment it

Browse to the fle to examine, the insert the XPath that identifes a fragment. Insert a string of the 
form /ROOT/DATA and so on.
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Limit the extracted fragments number

Selecting a range permits to extract only a small subset of the original fle. You are not obliged to 
waste space on your disk if you want only a single fragment.

Decide the output folder and the naming

Enter the location where write the extracted fragments and decide if you want to create a folder 
each N fles. Decide also how to name the fles and the folders. The combo boxes have some 
predefned values to ease the task, like a timestamp, or a progressive counter.

Go and examine data

After the start of the operation, in the the main window a navigation box appears. The fragments 
found in the input fle are accessible directly with a random access using the information collected 
in the previous phases. If you choose to split the fle in fragments, you can examine them in the 
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extraction directory.

Information in this panel:

Information Description

Extract documents (or scan the file and browse 
the single documents)

If selected the fragments found in the input fle will be 
written to fles as XML documents, one per fragment

Speed up the processing. No information will be 
shown in the user interface.

If selected, the extraction process will be faster, but after 
the extraction, it will not possible to browse the input fle 
fragments in real time using the user interface.
Use it if you need the output fles only.

Source file path The path of the input fle

Split documents using this path The XPath used to fnd the XML fragments in the input 
fle. The path must be entered using a syntax like this: 
/root/element/element

Split using the depth Use the depth of the element as criterion. Root element 
has depth one. Note: the elements will be extracted 
independently from their tag.

Extract all the documents If selected causes the extraction of all the documents 
found in the input fle.

Extract a range If selected, only the documents that fall in the specifed 
range will be extracted.

Extract in the following directory The destination directory for the fragments.
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Information Description

Make subfolders With this option the extracted fles are created in a 
subdirectory when their number exceeds the confgured 
threshold. Use it when the input fle contains thousand of 
fragments that will make impossible the browse of the 
destination directory if all the fles are in a single place.

Subfolder name pattern The naming to assign to the subdirectories created in the 
extraction process.
You can use a predefned token that will be expanded at 
run time or any other thing you like.

File name pattern The naming to assign to the fles created in the extraction 
process. The fles will have a '.xml' sufx automatically 
apposed.
You can use a predefned token that will be expanded at 
run time or any other thing you like.

Token that can be used in the name pattern section:

Information Description Example Output

%counter% The counter of the object created. This is an 
unique number that can be used to identify the 
object

1

"%date%" The current date in the YYYY_MM_DD format 2011_10_07

"%time%" The current time in HH_MM_SS_millis format 10_43_30_560

"%timestamp%" The current date and time in a numeric format 123456789

"%space%" A blank space used a separator
Since 0.6 version.

“ ”

Flex Code Generation From Balsamiq Source

There is a plugin to generate Flex code from Balsamiq mockup program source. You can choose a 
set of source fles that will be transformed to a Flex application in the output directory.

Only a subset of Balsamiq controls are supported, controls not supported are converted to 
mx:Label

List of supported controls:

• Button

• Label

• LinkBar

• DataGrid

• List

• TabBar

• Vrule

• Hrule

• TextInput

• ComboBox
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• TextArea

• Paragraph

• CheckBox

• RadioButton

• Tree

Life With Sessions

Sessions are information about a set of fles and access dates, related to a work or an activity than 
can be recalled if needed. A fle can be shared among diferent sessions, with diferent accesses. 
The sessions can automatically collect information of the fles that the program access. Only one 
session can be active at time and there is no need to have a session active for QXmlEdit to work. 

A session can be active (collecting information), paused or closed.

When sessions are active, there is the possibility to view the most used or recent fles or folders in 
a list in the main view. 

In the main menu the following commands are available:

Command Information

New Creates a new session. The current one, if existing, is closed.

Pause Pauses the current session when active. Paused sessions does not collect information.

Resume Resumes a paused session.

Close Closes the current session. No session is active, then.

Details Opens a dialog with information on the current session.

Manage Opens a dialog where have information about all the sessions.
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The session user interface

The session panel can be shown or hidden using the toolbar button or the command in the View 
menu.

The following lists are shown:

• Recent: the most recent fles accessed in the session. Double clicking a fle opens it in the 
editor.

• Most used: the most used fles of the session. Double clicking a fle opens it in the editor.

• Most recent folders:  the most recently used folders containing session related fles. 
Double clicking a folder entry shows the open fle dialog on that folder.

Sessions 
Management Dialog

In this dialog you can view the sessions list. From here you can activate a session or manage 
sessions, creating, deleting or editing them. When a session is selected, its accesses and fles are 
shown in the lower half of the dialog. The list of fles can be copied in the clipboard. Double 
clicking on a fle loads it in the editor. 

The following commands are available:

Command Information

Activate Activates the selected session, closing automatically the current one, if any.

New Creates a new session.

Edit Opens the session detail dialog of the currently selected session.

Delete Delete the currently selected session.

Edit file Loads in the editor the fle selected in the lower pane.

QXmlEdit user manual, page 121 of 141.

Clicking on the files 
opens them in the editor

Clicking on the folder, 
opens it in the open file dialog

Show or hide 
the browser

Session data 
browser



Export file data Put in the clipboard the path of the fles.

Session Properties

In this dialog you can set the session properties and examine its accesses to fles. The name and 
the description of a session can be changed and saved.

You can set or change the session name and description. The list of fles can be copied in the 
clipboard. Double clicking on a fle loads it in the editor. 

Managing sessions data

Sessions data are stored in the user data folder as indicated by the operating system using a sqlite 
database fle. To reduce sessions data fle dimensions use the confguration dialog. The cleaning 
procedure operates as follows:
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• Completely erase the data.

• Erase sessions data on date criteria.

The following table explains in detail the options:

Option Operation

Delete all sessions data Completely erase the sessions data.

Delete data older than... Delete the data older than the specifed date. The data are deleted as follows:
- all the accesses to a fle registration older than the specifed date.
- all the sessions that have last access date older than the specifed date and 
have no access data.
If the delete files information is selected, the fles information without 
access data are deleted. The fle themselves are not altered, the operation is 
done only on session registration inside QXmlEdit.

Sessions configuration

The session confguration panel allows to enable or disable session handling. There is the 
possibility to clean session data as explained in details in the paragraph “Managing sessions data”.

Viewing data

Use the Visualization feature to graphically visualize the composition or the structure of an XML 
fle. The fle can be view as a map; only the summary data are loaded in the program main 
memory, so the consumed memory is of the order of magnitude of the data itself.

The data that can be shown are:

1. Size: size of the elements, attributes and text nodes.

2. Elements: number of children elements.

3. Attributes: number of attributes.

4. Structure: the data can be split on their depth from the root.

5. Payload: the size of the text nodes children of the elements.

The data values can be cumulative or relative. The cumulative measuring shows the sum of the 
quantity associated with a given element and all its children. This kind of measurement gives an 
idea of how the hierarchy is structured. The non cumulative measurement spots what elements 
have the most relevant values.
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The data relevance is underlined using a color map, shown in the dialog itself.
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User Interface

To access to the Visualization use:

1. The welcome dialog.

2. The Tools > View Data menu.

The operation sequence is as follows:

1. Load a fle using the Load file... button.

2. Choose the measurement type from the View as combo box.

3. Select the Cumulative values if you want to display cumulative values.

4. The data are now show.

5. Select the zoom level.

6. Explore data hovering with the mouse on the interest points, a tool tip will appear.

7. Use the context menu (right mouse button) to export data.

Checking the “Analyze relations“ button will give access to the relations explorer  dialog.
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3D Visualization

If QXmlEdit is compiled with 3D support, a 3D view can be enabled using “3D” check box.

The available options are:

Command Information

Grid Show a grid in the back walls.

Points Show only points, do not draw surfaces.

Measurement types

The following measurement types are available:

Size

The size is the size in bytes of the element, its attributes and its text nodes. The cumulative 
measurement is the sum of the size of the element and all its children. The root element in the 
cumulative mode has the maximum size of all the tree.

To activate the size measurement select Size in the View As combo box.

Note: the calculated size can difer from the physical fle because when the data are loaded, 
the formatting is discarded.

Payload size

The payload size is the size in bytes of the text nodes children of an element. The cumulative 
measurement is the sum of the payload size of the element and all its children. The root element 
in the cumulative mode has the maximum size of all the tree.
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To activate the size measurement select Payload in the View As combo box.

Attributes count

The attributes counting is the number of the attributes of each element. The cumulative 
measurement is the sum of the number of the attributes of the element and all its children. The 
root element in the cumulative mode has the maximum total of all the tree.

To activate the attributes count measurement select Attributes in the View As combo box.

Children Elements count

The children element counting is the number of the children of each element. The cumulative 
measurement is the sum of the number of the children of the element and all its children. The root 
element in the cumulative mode has the maximum total of all the tree.

To activate the elements count measurement select Elements in the View As combo box.

Structure

The structure view shows how the elements are divided in blocks using the depth from the root 
information independently from the element tag. It shows the relative width of each element at a 
given level. There is no cumulative option.

To activate the structure measurement select Structure in the View As combo box.

To change the depth level, use Slice At Level combo box.

Commands available in the contextual menu of the map

The map exposes the following features in the contextual menu or with mouse hovering.

Command Information

Copy Data to Clipboard Copies the current measurement data, relative to the portion of the visible map to 
the clipboard. The data consist of an header and the values ordered by row.

Extract this fragment Opens the extraction dialog with depth and fragment numbers information 
relative to the current point.

Copy Path to the Clipboard Inserts into the clipboard the current element XML path.

Show current element 
information

Implemented as a tool tip that appears hovering with the mouse on a point of the 
map.

Visualize Relationship

The relations panel shows in graphical form and using a table, the relationship between the nodes.

Graphic view: show the elements existing in the fle and their relationships. The elements that 
are in relation father-child are connected by a line.

The elements are disposed on the canvas in random position at each invocation. The nodes are 
subject to a repulsive force and tend to be distribute evenly in the view. 
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Data view: show a table of nodes and the number and the type of connected elements.

Options:

Panel Option Description

Force Force The value of the repulsive force between the nodes.

Force Radius The efective radius of the force.

Spring Length The length of the spring.

Reset Reset the position of the nodes.

Zoom Zoom in Execute a zoom in

Zoom Zoom 1:1 Restore the view to the default size.

Zoom Zoom out Executes a zoom out

The relation panel can be accessed in the following modes:

• To show the data relative to the fle loaded in the editor: View->View Relations...

• To show the data relative to a fle: Tools->Relations...

• To show the data in the map view: check “Analyze relations”, load a fle then “View 
relations”
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Attributes summary

In the same panel in the “Attributes View” tab a detail of the attributes is shown. The allowed 
options are:

Option Description

Load Whitelist Load a whitelist of attributes XPATH.

Load Blacklist Load a blacklist of attributes XPATH.

Reset Lists Clear whitelist and blacklist.

The behavior is as follows:

• if there is no whitelist and no blacklist all the attributes are included in the same summary,

• if there is a whitelist only, the attributes in the whitelist are grouped together and the 
remaining form another group,

• if there is a blacklist only, the attributes non in the blacklist are grouped,

• if there is a blacklist and a whitelist, the attributes in the whitelist form a group, then all the 
other attributes non in the blacklist are added to the group.

Base 64 Explorer

This dialog permits to encode and decode text from and to base 64 coding, using one of the 
common character encodings.

To access Base 64 Explorer:

Menu > Tools > Base 64 Tools...

• To encode text in base 64:

◦ Write text into the “text” panel. The base 64 coding will appear in the base 64 panel.

• To decode from base 64:

◦ Choose an encoding using the “encoding” combo box.

◦ Write or paste the base 64 coded text in the “Base 64” panel. The text will 
automatically appear using the selected encoding.

Encoding tools

This dialog will permit to see how the text is transformed from unicode to diferent encodings.

To access the dialog:

Menu > Tools > Encoding Tools...

Explore how a string will be coded in a specific encoding

To explore how a string will be coded in different encodings:

1. Select the tab “String Explorer”.
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2. Write the text into the Source Text box.

The encoded text will be displayed in the grid, character by character along its Unicode 
value.

To add an encoding to the grid:

• Select an encoding in the encoding combo box, then trigger add button.

To remove an encoding:
• Select the encoding row, then press Remove button.

Explore how binary values are recognized by different encoding

You can insert numeric values and examine how they are interpreted by diferent encoding.

To access this feature:

• Select the “Character Explorer” tab.
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Insert the numeric values in the input box, using the prefx “0x” for hexadecimal numbers, “0” for 
octal.

To add or remove encodings, use the “String Explorer” tab.

Use “Sequence” button to insert a sequence of 128-255 characters; if you press the Control key 
with the “Sequence” button, the characters from range 32-127 will be inserted.

Explore how a string will be translated when written in some encoding 
and read in another one

Select the Chains Explorer tab, select an encoding (up to three are available), then write the 
string into source text box.
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The grid will show the string transformation up to three steps.
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Get information about a character
 Select the Character Info tab, select a character using one of the methods:

• Literal character typed in a box.

• Unicode code point written in decimal or hexadecimal.

• A value of a given encoding.

You can change the character display using the “Change Font” button.
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Code Pages explorer
Using the menu “Tools” > “Code Pages” you can open the code page explorer where you can 
examine the code pages supported by QXmlEdit.

The possible operations are:

Change the encoding using the “Encoding” combo box.

Search a character using:

• The literal value.

• The Unicode code point.

The search result will be highlighted in the table and reported in a box.

Option for display of the characters:

Show the UTF-8 encoding.

Show the Unicode name of the character.

Show the value of the character.
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Visually Comparing XML Schema files
The compare operation is started loading a XML Schema fle, then selecting the menu operation. 
After the compare a window will open, showing the elements with diferent colors depending on 
their state. The comparison can be done taking into account the annotations or not. Even the 
single items of restriction enumerators values are shown.

To start the compare operation:

Menu > File > Compare XSD...

Options available: exchange source and reference and compare annotations or not.
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Binary files viewer
Using the menu Tools > Binary files viewer you can view the raw data of a fle. The data can be 
decoded in text using one of the supported encoding, but  each row of 16 bites is decoded 
separately. The input fle is divided in pages to not overloading the memory. In this panel you can:

• View the raw data using a text encoding.

• Search text using the selected encoding .

• Go to an ofset into the fle.
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Command Line arguments
QXmlEdit can be started with the following arguments:

Option Operation

 -vis <fle> Opens the data visualization panel

 -anonymize <inputfle> <profle> <outputfle> Anonymizes a fle and exit

-xsl [-saxon] -xsl=<xslFile> -output=<outputfle>

  {-p<name>=<value>}* <inputfle>

Executes XSL transformation and exit.

Parameters can be supplied using the ‘-p’ 
options.

any other argument is used as a fle to open.
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Appendix

Note on “Single Application” Mode

The single application mode is enabled by default, but can be disabled using an option in the 
Options panel.

It consists in opening a local server when starting, After that, if a command line argument is used 
by the shell (e.g. the “Open With” in Windows Exlporer), the arguments are sent to the existing 
instance via the local socket.

Style file format

This section describes the structure of a style fle.

A style fle is an XML fle with the following structure:

Root Tag:

Tag name Attributes Child elements

style: • “name” style name as shown in the 
user interface

• “description”: a description
• “namespace”: an optional namespace

• “keywords”
• “styles”
• “ids”

Element “styles”

This element is simply a collection of “style” elements plus one optional “default” that will be 
used as default style, if existing.

Element “default”

It contains one “style” element.

Element “style”

Tag name Attributes Child elements

style • “id” unique identifer of the style. It is 
a string

• “color”:  hexadecimal representation 
of a color used to paint the text. 
Example: “FF0000”

• “backColor”: optional, the 
background color in hexadecimal 
format with optional alpha at the end.
Example: FF0000 or FF000080

• “family”: font family if diferent from 
default.

• “size”: font size if diferent from 
default.

• “bold” set to 'true' or a numeric value 
diferent from zero to force bold style 
on font
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• “italic”: same of bold, but for italic 
style

The only mandatory attribute is id, the others 
are activated if set.

Element “keywords”

This element is simply a collection of “keyword” and “rule” elements

Element “keyword”

A keyword, with associated style. Each element tag in the data fle that is enrolled in this section 
will be printed with the indicated style

Tag name Attributes Child elements

keyword • “keyword” the name of the element 
to mark

• “idStyle”:  the identifer of the 
associated style

Element “ruleSet”

Contains a set of “rule” and “ruleSet” using implicit AND connector

Tag name attributes Child elements

ruleSet • “connector” the connector of the 
children
◦ and (default)
◦ or

• “idStyle”: for a top level rule identify 
the style to be used

“rule”, “ruleSet”

Element “rule” (inner)

Tag name attributes Child elements

rule • “entity”: denotes and attribute or an 
element, default: attribute
◦ attribute
◦ element

• “name”: if attribute, the name of the 
attribute or element

• “op”: denotes the comparison 
operator
◦ EQ: equals
◦ NE: not equals
◦ EX: value exists
◦ NX: value non existent
◦ GT: greater than
◦ LT: less than
◦ GE: greater or equal
◦ LE: less or equal

none
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◦ SS: substring  (string only)
◦ ST: starts with (string only)

• “type”: type of comparison, optional, 
default: string
◦ s: string
◦ n: number
◦ p: position

• “value”: the comparison value. If 
position, the value should be:
◦ numeric
◦ frst (literal)
◦ last (literal)

• “case”: if the comparisons take the 
case of the strings into account, 
default: true
◦ true: case sensitive
◦ false: not case sensitive

Element “ids”

This element is simply a collection of “id” elements

Element “id”

This element contains the name of attributes whose content will be printed  next to element tag

Tag name attributes Child elements

id • “id” name of the attribute that is 
considered as an identifer.

• “alpha”:  if true, force the enclosing of 
the value between quotes.

This is a complete sample style fle:

<?xml version="1.0" encoding="UTF-8"?>
<!-- this is a sample QXmlEdit style file -->
<style name="Log" description="log test style">

<keywords>
 <keyword keyword="resource" idStyle="1"/>
 <ruleSet idStyle="2">
    <ruleSet connector="and">
        <rule entity="element" op="eq" type="s" value="event"/>
        <rule entity="attribute" name="level" op="eq" type="s" value="fatal" case="false" />
    </ruleSet>
 </ruleSet>
 <ruleSet idStyle="3">
    <ruleSet connector="or">
        <rule name="level" op="eq" type="s" value="ERROR" />
        <ruleSet connector="and">
            <rule entity="attribute" name="level" op="eq" type="s" value="INFO" case="true" />
            <rule name="pri" op="gt" type="n" value="12"/>
        </ruleSet>
    </ruleSet>
 </ruleSet>
 <ruleSet idStyle="4">
    <rule name="level" op="eq" value="WARNING" case="true" />
 </ruleSet>
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 <ruleSet idStyle="5">
    <rule name="level" op="eq" type="s" value="INFO" case="true" />
 </ruleSet>
</keywords>

<styles>
 <style id="1" color="2080FF" />
 <!-- fatal -->
 <style id="2" color="FF0000" size="12" family="Arial" bold="true" italic="false" icon=":E:" />
 <!-- error -->
 <style id="3" color="FF4080" size="10" family="Arial" bold="true" italic="false" icon=":E:"/>
 <!-- warning -->
 <style id="4" color="C0C080" size="10" family="Arial" bold="false" italic="false" icon=":W:"/>
 <!-- info -->
 <style id="5" color="000000" size="8" family="Arial" bold="false" italic="true" icon=":I:"/>
 <default>
    <style id="default" color="C0C0C0" size="8" family="Arial" bold="false" italic="true"/>
 </default>
</styles>

<ids>
 <id id="name" alpha="true"/>
 <id id="id" alpha=""/>
</ids>

</style>

Installation of new styles

Given that styles are so simple, they can be created by the user with a simple text editor. Styles 
are searched in a directory confgured via 'Configure...' menu.
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