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1  XEphem -- the Interactive Ephemeris

Thank you for using XEphem.

XEphem is an interactive astronomical ephemeris program. XEphem provides a rich set of 
accurate astrometric calculations and attractive graphical and image displays in an easy-to-use 
GUI framework. XEphem includes extensive on-line context-sensitive help, examples, and bubble 
tips on all controls.

1.1  Summary of Capabilities

XEphem ...

is a scientific-grade interactive astronomical ephemeris package;

computes heliocentric, geocentric and topocentric information for all objects;

has built-in support for all planets; the moons of Mars, Jupiter, Saturn, Uranus and Earth; 
central meridian longitude of Mars and Jupiter; Saturn’s rings; and Jupiter’s Great Red 
Spot.

allows user-defined objects including stars, deepsky objects, asteroids, comets and Earth 
satellites.

allows user-defined objects including stars, deepsky objects, asteroids, comets and Earth 
satellites. 

    
offers many large databases including Tycho, Hipparcos, GSC, USNO.

    displays data in configurable tabular formats in conjunction with several interactive 
graphical views; 

    graphically displays a 24 hour period showing when any selected objects are up;

displays 3-D stereo views of the Solar System that are particularly well suited for 
visualizing comet trajectories;

quickly finds all close pairs of objects in the sky;

   sorts and prints all catalogs with very flexible criteria for creating custom observing lists;

    can create plots of any pairs of all data fields throughout the program;

    downloads AAVSO light curves directly online;

    downloads current asteroid and comets lists from Lowell and MPC;

    downloads timely Earth satellite orbital TLE parameters;

    downloads Digitized Sky Survey FITS files from STScI or ESO;
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    displays seti@home client progress and plots position being processed on Sky View 
map;

    provides a handy spreadsheet for converting among equatorial, ecliptic, horizontal and 
galactic coordinates;

    includes a compiler for entering and solving user-written functions using any data fields;

    serves as the control point for GOTO telescopes in real-time such as Meade LX200;

    displays FITS files and DSS images overlaid with properly registered database symbols 
and other graphical information;

    performs automatic star pattern matching to solve for accurate World Coordinate System 
on any image;

    performs 1-click 2D Gaussian relative and absolute photometry;

    lets you define and save any number of Eyepieces to use in sky maps;

    displays your own local horizon profile;

    can store sets of Sky View options for easy playback later;

    uses high quality Postscript for all printing.

XEphem can compute information on demand or time can be set to increment automatically. In 
this way a series of computations and movies can be generated.
Plot and listing files of selected field values may be generated as the program runs.  The plot files 
are full precision floating point values in ASCII intended for export to other plotting programs or 
XEphem includes its own quick-look plotting facilities. The listing files are tables formatted for 
more general human reading.

Quantitative information available about each object includes:

    RA and Dec,
    local azimuth and altitude,
    distance from sun and earth,
    light travel times,
    heliocentric coordinates,
    galactic coordinates,
    ecliptic coordinates,
    solar elongation,
    angular size,
    visual magnitude,
    illumination percentage,
    local rise and set times and azimuths,
    local transit times and altitude,
    length of time up,
    constellation,
    angular separations between all combinations of objects.

Local observing circumstance information includes
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    UTC and local date and time,
    local sidereal time,
    times astronomical twilight and length of night,
    local temperature and pressure (for refraction),
    elevation above sea level (for parallax),
    a monthly calendar.

RA/Dec calculations may be topocentric or geocentric, and apparent or astrometric. When the 
Equinox is set to a fixed date the values are astrometric, that is, corrected only for precession and 
light travel time. When the Equinox is set for EOD (Equinox of Date) the values are apparent and 
are also corrected for nutation, aberration and relativistic deflection. Topocentric values are 
further corrected for parallax, augmentation and refraction.

XEphem can read databases of objects (§13  ). The objects may be fixed; specified via 
heliocentric elliptical, hyperbolic or parabolic orbital elements to accommodate solar system 
objects such as asteroids or comets; or specified via geocentric elliptical orbital elements to 
accommodate Earth satellites. These are then available as candidate values for the user defined 
objects and all of them can be displayed in the sky map subject to type and magnitude filters.  
The format of the database file is described in the Help for the DB window.

1.2  UNIX Installation

To install from the CDROM you just basically mount it and run the install script. You must be root 
to perform the installation because several files are placed in system directories. Also, check the 
README for any last minute instructions.

Accessing the CDROM drive is the first step. For example, on Red Hat Linux the following is 
typical:

$ su

Password: ********

# mount /mnt/cdrom

# /mnt/cdrom/install

...

Some systems use just /cdrom.

Once you can access the CDROM run the install script:

# /mnt/cdrom/install

  ...

In rare cases your system may have been configured to prevent execution of programs directly 
from the CDROM. If this happens the above will complain immediately and exit. The solution is to 
copy the script to some place on the hard drive and run it from there. For example:

# cp /mnt/cdrom/install /tmp

# chmod u+x /tmp/install

# /tmp/install /mnt/cdrom

  ...

Note that in this scenario you should run install with one argument: the full path to the 
CDROM.
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You will now be asked a short series of questions. As appropriate,  each question may be 
followed by the possible responses in parentheses and a default in square brackets that is used if 
you just type Enter. For example:

Proceed to install XEphem Version 3.4? (y/n) [y] 

The possible responses are to type y or n followed by Enter; Enter alone will be the same as y.

Follows is some commentary on the various questions asked by the install script in the order in 
which they appear.

1) You are asked to confirm you really do want to install XEphem and, if so, are asked to 
agree to its licensing terms. Answering n to either of these will end the installation with no 
change to your system.

2) You are asked to specify several directories. In most cases the defaults offered should 
work fine. However, in deference to local customs, the installation allows you to change 
them if desired. Basically if you do not know the significance of a directory, take the 
default.

Application defaults: a very small file will be created here so xephem can know your 
choice for the Base Installation directory (see next).

Base installation: this will contain all the supporting files needed by xephem at runtime, 
including all the catalogs. This must have at least 200MB free for a basic installation, or 
800MB if you choose to also install the USNO catalog (described shortly). All files in this 
directory are used read-only by XEphem and can be shared among all users.

If you have installed XEphem before and you elect to use the same Base directory, some 
files will be added and many files will be overwritten. The install script makes no attempt 
to clean out deprecated files or preserve files that are being updated. It is recommended 
that you keep any special work you may have done in this directory then remove it, letting 
the install script create a fresh directory.

Manual page: the directory where the XEphem manual page will be placed. It is written 
for chapter 1X.

Executables: the directory where the xephem program itself will be placed, and a few 
other supporting programs.

Private: each user of XEphem can have a directory for their private files. An initial 
sample is set up in this directory.

3) The Base Installation directory requires about 200MB. If there is not that much on the 
specified directory the script will now exit.

4) Next you must indicate your operating system and architecture. If you chose one from 
those listed the proper executable files will be copied to the Executables directory. If you 
elect to not specify, all supporting files will be copied but you will not have the xephem 
program itself. In this case, some hints on how to proceed are in the README on the 
CDROM.

5) Next you will be asked if you want to load the USNO SA2.0 catalog. This requires an 
additional 600MB in the Base Installation directory. You are not asked if this directory 
does not contain this much room. You may not want this catalog, even if you have room. 
It is a list of about 55 million stars specially chosen to be roughly evenly spaced on a grid 
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around the entire sky for use as astrometric reference points. The stars were chosen for 
their proximity to this grid, not for their magnitude. Indeed, most bright stars are not in this 
catalog at all, but it does contain some stars down to as dim as 20th magnitude. The 
result is that the catalog is very useful if you want to perform careful positional 
measurements on images but is otherwise not interesting for general use because it does 
not  look at all like the real sky.

That’s all the questions. Now the real work begins. As the script proceeds it creates a list of all 
files created on your system during installation in the file /tmp/XEphem-3.4.log. The basic 
activities are as follows:

create a default resource file in Application Defaults.
create an initial empty Private directory.
create a file .xephemrc in your home directory pointing to your Private directory.
copy the appropriate binaries to the Executables directory.
copy the man page to the Manual page directory.
copy all the files needed to the Base Installation directory. This will take most of the install
    time and a running progress percentage will help you judge when it will finish.
if the USNO catalog was chosen, a background process is now started to decompress it.
create the fifos needed for telescope control.

If all goes well, when the install script completes, you may run XEphem.

1.2.1  Launching XEphem
XEphem supports the following command line arguments: 

  -env N=V  : set alternate env Name=Value
  -help     : print this message then exit
  -install {yes|no|guess} : whether to install a private colormap
  -prfb     : print all fallback resources then exit
  -resfile f : load alternate resource file, f

When XEphem is launched it looks for a file named .xephemrc in the $HOME directory. This file 
is optional. If it exists, it should contain a line with the following form:

    XEphem.PrivateDir: ~/.xephem

The directory named on the right is where XEphem will create and use per-user, or "Private" files. 
A leading "~" in the file name can be used to refer to $HOME, your login directory. The example 
above causes the Private directory to be .xephem in the users $HOME directory. If .xephemrc 
does not exist or does not contain this line the default Private directory is ~/XEphem. The private 
directory will be created if it does not already exist.

XEphem then also searches for another directory. This one can be shared among all XEphem 
users on a system. Files in this directory are never modified by XEphem. They include databases 
of objects, supporting images and other files. This directory is specified in a resource file named 
"XEphem", itself located within the Private directory (see above). It should contain a line with the 
following form:

    XEphem.ShareDir: /usr/local/xephem

The directory named on the right is where XEphem will look for all "Shared" files. A leading "~" in 
the file name can be used to refer to $HOME.
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Next XEphem sets the initial values of most options and settings from other entries in the 
resource file. Settings which do not appear will use their internal default values.

1.3  Windows Installation

Executive summary:

1. run setup.exe, taking all default values

2. reboot

3. double-click the new XEphem shortcut on the desktop

Long version:

XEphem must be installed by the Administrator (or a user account in the Administrators group). 
After installation, if desired, it is possible to allow multiple users to run XEphem so they each have 
their own separate workspaces while sharing the large support files and databases. Details of 
sharing are be described in §1.3.3  .

Insert the CDROM and your computer should start the installation program automatically. If it 
does not, run the setup.exe program by clicking Start → Run, then type

d:\setup.exe

Change the letter "d" to whichever device Windows considers your CDROM drive.

The installation takes a while because of all the data being copied. It also behaves a little unusual 
compared to most Windows programs. One reason for the complexity is that really three 
programs are being installed. XEphem is written for UNIX. In order to run on Windows it requires 
a porting layer. We have chosen the outstanding MKS Toolkit for Enterprise Developers (see 
http://www.mkssoftware.com). Also required is an X Windows Server. We have chosen the MI/X 
server from Microimages (see http://www.microimages.com). If you already happen to have an X 
Windows server on your system there is a small chance of a conflict. To reduce this further, 
XEphem and MI/X are set to use display :1. This can be changed to display N  for XEphem by 
editing the Target Property of the desktop and Start shortcuts to -display :N, and for MI/X by 
changing the Network Port number preference to 6000+N. If all this means nothing to you, 
consider yourself lucky.

The installation will insure you select a disk with the required amount of free space. After 
installing the MI/X server you will get an instance of Explorer showing the files it installed which 
you can just dismiss. The final step is to reboot.  When your computer comes back up, you will 
find a new shortcut for XEphem on your desktop and in the Start menu under Programs → Clear 
Sky Institute Inc.

1.3.1  Starting XEphem the First Time

Start XEphem by double-clicking on the XEphem desktop shortcut. You will see an Authorization 
dialog. Ignore what it says about buying a license from Microimages. That was already included 
in your XEphem purchase. For now you can just click on Ignore. However, within 15 days you 
must obtain a valid authorization code from us. There is no charge for this code but you do have 
to send us an email to get it. To obtain your code, send the machine ID exactly as it appears as 
the only thing in the body of an email and send to:

xewinregister@clearskyinstitute.com.
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The Subject of the email will be ignored. You will receive a reply back to the address from which 
your ID was sent containing an Authorization Code before your gratis period expires. The 
machine ID depends on your hardware and the code will only work on that one computer system. 
Once you enter a valid code, you will no longer see this dialog.

After clicking through the Authorization window you will see a large black window, a small 
Workspace Overview window (explained shortly), then after a short while XEphem’s Main 
window. If you took more than a few moments to ponder the Authorization window then XEphem 
probably gave up waiting and you will just have a black window forever. If so, just close the 
workspace (click on the × in the upper right like you would close any Windows app) and start 
XEphem again, this time clicking Ignore right way. See the rest of this manual for using XEphem. 

The Overview window allows you to control the MI/X workspace that is, in effect, larger than your 
screen and completely dedicated to XEphem’s windows. You will find this very handy because 
XEphem has many windows which you may want open at the same time and this gives a handy 
way to manage them all.

The Overview window represents the entire workspace in miniature. The red box represents the 
portion of the workspace currently visible. You can move this visible space around by clicking 
inside the red box and dragging it around or by using the scroll bars on the right and bottom 
edges of the screen. Also in the Overview window is one little gray rectangle representing each 
XEphem window that is currently open on the workspace. When you first start XEphem, only the 
Main window is up so you see one such rectangle. To move this rectangle around on the 
workspace, as well as the real XEphem window which it represents, press Shift then click on the 
rectangle and drag it around. The Overview window itself may also be moved in the usual manner 
by clicking in its title bar and dragging it around. Note that it always remains in the same place 
relative to the screen, not the workspace. You can learn even more about the Overview window 
by clicking on the ? in its upper right corner.

The workspace and all its XEphem contents appears as one entry on the Windows Taskbar. The 
taskbar will read MicroImages X Server but you can think of it as the XEphem workspace. You 
will not see the individual XEphem windows on the Windows taskbar. The entire XEphem 
workspace may be minimized by clicking on the usual symbol in the upper right corner of the 
workspace.

In the upper right of each XEphem window is a small  × which will close that window within the 
MI/X workspace. When the main XEphem window is closed, the entire workspace is also closed. 
To resize a window, click on the edge and drag as desired.

With a bit of practice, this is actually all quite useful and expedient. Please give it a little time.

1.3.2  File Structure

In this section we describe the disk file structure that has been created for XEphem. This 
information is not necessary for typical operation so you may skip this for now and come back 
some day if you are curious.
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If XEphem is installed in the default location, the following directory structure is created:

c:\Program Files\Clear Sky Institute Inc\

nutc\

bin\

auxil\

catalogs\

fifos\

fits\

XEphem\

XEphem contains files specific to each user such as preferences, plots and lists. Initially it 
contains one file, XEphem, a file containing a few default values different from those built 
within the program. If a change is made and saved as a new Preference setting, it is recorded 
in this file.

Nutc contains all files that can be shared among all users. Some of these are described 
below.

bin contains the binary executable files for XEphem itself and some auxiliary command line 
tools such as the driver for using XEphem with LX200-compatable telescopes and programs 
for updating the asteroid databases. The installation process adds this directory to global 
PATH. Later in the XEphem documentation where it refers to the tools directory it really 
means bin in the Windows version.

auxil contains supporting files such as planetary images, observing sites, help text and 
certain ephemeris data.

catalogs contains object databases in XEphem’s .edb, .xe2 and .gch formats. The Hubble 
Guide Star catalog is in catalogs\gsc and the USNO SA2.0, if installed, is in catalogs\usno. 
If USNO was not installed initialled just copy it here later when you decided you want to use 
it.

fifos is used for communication between XEphem and the LX200 driver.

fits can be used to store image files in FITS format.

1.3.3  Multiple Users

The shortcut installed on the Windows desktop and in the Start menu under Clear Sky Institute 
define the paths to the Nutc and XEphem directories for the current user. If your installation is to 
support multiple user accounts, they should all point to the same Nutc directory but to individual 
XEphem directories. To see how these are set up, right-click on the desktop shortcut for XEphem 
and select the Properties menu entry. The two fields of interest are Target and Start in.

Target  specifies the full path to the xephem.exe executable, followed by an argument which 
specifies the full path to the private directory to be used by one user. It is this second argument 
that should be made unique for each user. For example:

"c:\program files\clear sky institute inc\nutc\bin\xephem.exe" -env "HOME=c:\program 
files\clear sky institute inc"

Start in specifies the full path to the shared directory which can be used by all users. XEphem 
does not change the files in or below this directory. For example:
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"c:\program files\clear sky institute inc\nutc"

The icon for XEphem is

c:\program files\clear sky institute inc\nutc\bin\xephem.ico

1.3.4  File naming
File names in XEphem will appear somewhat different than they normally do under Windows. 
Drive letters are changed from x: to /x=/ and backslashes are changed to forward slashes. So for 
example, the following file name in normal Windows:

c:\program files\clear sky institute inc\nutc\auxil

will appear as follows inside XEphem:

/c=/program files/clear sky institute inc/nutc/auxil

This only refers to places where XEphem displays a file name. In most cases throughout XEphem 
where you are asked to enter a path name, you may use either naming strategy.

1.3.5  Printing
XEphem performs all printing using high quality Postscript format but printers typically found on 
Windows computers do not directly support this format. We could have included a nice 
commercial Postscript printing package on the XEphem distribution and passed the licensing cost 
on to you. Instead, we noted that same package can be downloaded off the Internet at no charge 
for personal use. So you save money by performing the installation yourself as follows:

1. Go to http://www.ghostscript.com. Look for and go to the link at wisc.edu. 
Download the latest release of AFTL Ghostscript (not GNU Ghostscript). You do not need 
ghostview, just ghostscript. As of this writing the latest version is 7.00 located at 
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/AFPL/gs700/gs700w32.exe. This is known to 
work well with XEphem.

2. Install ghostscript according to its instructions. Basically just run the .exe. Be sure the 
option to Install fonts is checked. Note the installation directory. For the purposes of this 
discussion we assume you install at c:\gs.

3. Bring up any XEphem Print dialog. For example, from the Main window click Views → 
Sky View then click Control → Print. Check the Print command and make sure it 
appears exactly as follows (case is significant):

/c=/gs/gs7.00/bin/gswin32c.exe  -sDEVICE=mswinpr2

 If the version has changed from 7.00 or if you installed ghostscript some place other than 
c:\gs then change this part of the command accordingly. If the Print Command is 
already correct, you are finished. If you had to edit it, there is one more step:

4. Back in the XEphem Main window, click Preferences → Save and click on the Save 
button at the bottom. This will make the change to the Print Command permanent for this 
user.

Now when you Print from XEphem, ghostscript creates a normal Windows print job which you 
manage like any other. We find this print window is sometimes buried beneath the XEphem 
workspace, so you may have to find it on the Windows Taskbar and bring it to the front before 
you can use it.
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1.3.6  Uninstallation

To completely remove XEphem and all its supporting components click on Start → Settings → 
Control Panel. Then double-click on and open Add/Remove Programs. Remove the following 
programs in order:

MKS Platform components 7.x

Microimages X Server

XEphem

If you have installed ghostscript for printing, then also remove these two programs:

AFPL Ghostscript 7.00

AFPL Ghostscript Fonts

During these uninstalls, a few files will not be successfully removed for various reasons. This is 
normal. After running each uninstall as above, use Windows Explorer to remove the directory in 
which XEphem was originally installed; the default was "c:\program files\clear sky 
institute inc". Similarly, remove the X server directory, the default for which was 
"c:\program files\microimages". This will catch these few stray files and XEphem and 
its helpers will be completely gone.

1.4  Apple Mac OS X Installation
Details arrived too late to be including in the first printing. Please see the appendix.

1.4.1  LX200
Apple computers usually have USB ports, not serial ports. To operate an LX200 with its serial 
port we suggest the USB-Serial adaptors made by Keyspan (see http://www.keyspan.com). You 
will need an adaptor, such as the model USA-18x (one port) or USA-28x (two ports), and their 
driver software for Mac OS X. Only one serial port is necessary for the LX200 but an extra might 
be handy for other things. Follow Keyspan’s installation directions.

After a successful installion, the serial devices will be available in /dev, for example 
/dev/cu.KeyUSA28X9131. The exact name for your LX200 connection will vary depending on 
your USB configuration. Whatever it is, inform XEphem as follows:

1. From the Main XEphem window open Views -> Sky View -> Telescope -> Configure

2. Edit the field Serial Device so it contains your appropriate name.

3. Now again from Main, open Preferences -> Save and click on Save.

That’s it. The chapter on LX200 now applies (see §16  ).

1.5  Operation

XEphem starts by showing the Main window with each parameter set to its default value. The 
parameters on the Main window are primarily devoted to describing the location and time for 
which all other data in XEphem are computed. You can change this time manually and press 
Update, and all other windows throughout XEphem will be recomputed. Or you can start a loop 
that steps time each step automatically by an amount you specify.

There are three fields that control this looping behavior.

    Step is the amount of time to add each step or after one Update
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    N Steps is the number of steps to run in a loop
    Pause is the amount of real seconds to pause between steps.

When looping is in effect, the bottom button on the Main window says "Stop". When the number 
of steps goes to 0 or the "Stop" button is selected, the looping stops and the button label changes 
back to "Update".

A common mode is to have XEphem automatically stay in sync with the computer clock. This can 
be done as follows:

    set Step to "RT Clock"
    set N Steps to a large number, say, 1000000
    set Pause to the desired update time, say, 10 seconds
    click "Now" under the calendar
    click Update to start running
   
This is so common in fact the handy shortcut button to the right of the "Looping" title labeled 
"Now" performs exactly these steps. The value set for Pause will be used unless it is 0 in which 
case XEphem sets it to 10 seconds.

Speaking of shortcuts, the -1 and +1 buttons to the left of the Looping label each subtract or add 
to time by one Step, regardless of the setting for N Steps. The value of N is updated accordingly. 
These two actions can also be performed from the keyboard by typing Control-b ("backward") and 
Control-f ("forward").

Note that when looping with Pause set to 0, most numeric field data are not drawn in order to 
speed up the display. These values are always updated internally, however. and may safely be 
used for plotting, solving or listing. This is true even if the window that displays the information is 
closed.

Most fields on the Main window may be changed by clicking them. A prompt window with a brief 
explanation of the field will appear. A new value may be typed into the text field provided. If "Ok" 
is clicked the new value will be used; if "Cancel" is clicked the field will be left unchanged. In 
either case, the prompt window goes away. Some of the windows have an extra button which 
offers a handy way to enter frequently used values for the field.

If you change a field on the Main window that would invalidate any of the other fields in any 
XEphem window the message NEW CIRCUMSTANCES flashes near the top of the Main 
window. This will continue until the next Update occurs. If you change any field that causes new 
circumstances, the "Step" value is not added to the current time before the next loop.

Some graphical views have a push button marked Movie Demo. This is a convenient way to start 
and stop a sample movie sequence. If XEphem is currently idle then pushing the button will set 
the Main window Step to a value that will yield a pleasing motion effect and start looping with a 
very large number of steps. If XEphem is already looping then pushing the button will cause it to 
stop and set Main window N Steps to 1. The Main window Stop control can also stop the looping 
in the usual way.

1.6  Triad Formats
XEphem uses many values that get entered in some variation of the form A/B/C, such as date, 
time, longitude and step size. XEphem calls this a "triad"

Times and RA are entered and displayed in h:m:s format. If you pick such a time field to change 
it, any of the h, m, and s components that are not specified are left unchanged from their current 
value.  For example, 0:5:0 set hours to 0, minutes to 5, seconds to 0, whereas :5 sets minutes to 
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5 but leaves hours and seconds unchanged.  A negative time is indicated by a minus sign (-) 
anywhere before the first digit.

Dates are entered and displayed in any one of month/day/year, year/month/day or 
day/month/year form. A Preference selection on the Main menubar, and controlled by the 
XEphem resource DateFormat, selects which form is currently being used.

As with time, components omitted when entering a new date retain the current value.  For 
example, if the current date is 10/20/1988 and you type 20/30 the new date will become 
20/30/1988. If you then type //2000 the new date will become 20/30/2000. Note you must type the 
full year since the program is accurate over several centuries either side of 1900.

If you change the date, the time (i.e., partial day) will not change.

Negative years indicate BC dates. For example, Jan 1, 1 BC is given as 1/1/-1.  There is no year 
0.

Two other ways to set the date are supported for compatibility with some published comet 
ephemerides.  You may enter the day portion as a floating point number. When you set the day 
this way, the time will also change to correspond to the fractional portion of the day. For example, 
noon on Jan 2, 1995, may be entered as 1/2.5/1995.

You may also enter a date as a decimal year, as in 1990.12345. Also, when the date format 
preference is set to M/D/Y or D/M/Y the decimal point may be omitted if the value is not a 
reasonable month or date value, respectively. Decimal years are useful in interpreting plot files 
that include a date field, since date fields are stored in plot files as decimal years. Any input that 
includes exactly one decimal point is assumed to be a decimal year. 

Other parameters such as declination, azimuth, altitude, longitude, latitude and "Step" are 
entered and displayed in d:m:s format and also fall into the general triad format. The same rules 
apply to these with respect to only having to set the portions that are being changed and the 
typing conveniences. 

For typing convenience, the slash (/) and colon (:) used in any field may also be entered as a 
hyphen (-), semicolon (;) or comma (,). (Yes, "1-1--1" works for 1 BC.)
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2  Main Window

This describes the features of the 
Main XEphem window.

Across the top is a menu bar to 
allow selecting the principle 
functions of XEphem. Each 
window opened from the menu bar 
has its own Help. Only a few 
specific entries will be mentioned 
here.

Help -> on Context turns the 
cursor into a Question Mark. 
Roaming the cursor over any 
control in XEphem will show its 
bubble help tip. Press the left 
mouse button to end this behavior 
and resume normal operation.

Help -> Search... allows you to 
search the entire Help database 
for keywords. Each matching entry 
will be displayed highlighted in 
context, and the search may be 
easily repeated to look for 
additional occurrences.

Below the main menu bar is the XEphem logo image. Beneath that is a status line that contains a 
short description of what XEphem is doing at the moment with regards to its looping behavior 
(see Help -> on Operation).

Below the status line is room for the NEW CIRCUMSTANCES message. When you change any 
field on the Main window that could invalidate any of the other fields or views throughout XEphem 
this message flashes until at least one screen Update occurs to get everything up to date again.

See Help -> on Operation (§1.5  ) for more information on changing the fields in the Main window 
and controlling XEphem’s run time behavior. See the Help -> on Triad formats (§1.6  ) for more 
information on date, time and coordinate formats.

Follows is a description of each of the display fields in the Main window.

Local

 [Site name] See below.

 Latitude Local geocentric latitude, positive degrees north of equator. Changing this will 
disable automatic computation of Daylight Savings Time.
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 Longitude Local longitude, positive degrees west of Greenwich meridian. Changing this will 
disable automatic computation of Daylight Savings Time. A sensible Timezone is 
created based on one hour for each 15 degrees from 0.

 Elevation Local elevation of the ground above sea level, in feet or meters. (see 
implementation notes). Used in topocentric parallax correction.

 Temperature Local surface air temperature, in degrees F. Used in refraction correction.

 Atm Pressure Local surface air pressure, in inches of mercury. Used in refraction correction.

 Equinox When set to a year, this is the desired epoch to which the RA/Dec fields are 
precessed, referred to as the astrometric place. When this is set to EOD, all 
RA/Dec values are precessed to the current XEphem time, and corrected for 
nutation, aberration and deflection, referred to as the apparent place. 

Time

 UTC Date The UTC date. UTC is "Coordinated Universal Time", the basis, after adjusting 
for time zones, for the official "civil" time people set their clocks to.  Every year or 
so it is adjusted via a "leap second" so it stays within 0.9 seconds of "UT1", which 
varies continuously with the slight irregularities of the rotational motion of the 
Earth.

 UTC Time The UTC time.

 Julian The current Julian date, to about 1-second accuracy.

 Sidereal The apparent sidereal time for the current time and location.

 TZ Name The local time zone name.  The name may be fixed to any short mnemonic. 
Setting this manually turns off automatic computation of Daylight Savings Time. 
When auto DST is on, a small clock is shown at the top right of the Time section.

TZ Offset Hours local time is behind UTC, i.e., positive west or negative east of Greenwich. 
Setting this manually turns off automatic computation of Daylight Savings Time.

 Local Date The local date. This is UTC minus the value of TZ Offset.

 Local Time The local time. This is UTC minus the value of TZ Offset.

 Delta T TT-UT1. Number of seconds by which Terrestrial Time (aka Ephemeris Time 
prior to 1982) leads UT1.  TT is generally of interest when calculating the 
positions of solar system objects because it is a continuous time scale unaffected 
by the Earth’s rotational vagaries.  The term "Terrestrial" means it is adjusted for 
the relativistic effects of gravity and the Earth’s revolution around the Sun.  UT1 
or UTC is of interest when relating those positions to the horizon to produce 
altitudes and azimuths.  The value may be computed automatically based on the 
current time or entered manually (in which case it will not change). The algorithm 
uses values tabulated in the Astronomical Almanac for years 1620.0 through 
1998.0, and is accurate to within a few seconds over that interval. Dates prior are 
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from Stephenson and Morrison or K. M. Borkowski, with an estimated error of 15 
minutes at 1500 B.C. A linear extrapolation formula predicts future values.

Night

 Sun Dip The number of degrees the Sun is below the horizon that we wish to call twilight. 
Common definitions include: Civil = Sun 6 degrees down (headlights barely show 
on pavement), Nautical = Sun is 12 degrees down (sky and ocean merge), 
Astronomical = Sun is 18 degrees down (dark as it gets). The Sun Dip setting 
applies to the following fields:

 Dawn Local or UTC time when the Sun center is "Sun dip" degrees below the horizon 
before sunrise today.

 Dusk Local or UTC time when the Sun center is "Sun dip" degrees below the horizon 
after sunset today.

Length Length of astronomical night, i.e., Dawn - Dusk.  If this and the display for Dawn 
and Dusk are shown as "-----", it means the Sun is either always below or always 
above "Sun dip" degrees below the horizon on this particular day. N.B. These 
three fields always apply to the local current day.  Difficulties arise when these 
events occur within 4 minutes of local "midnight" with respect to the time zone 
defined by TZ Offset. In particular, if these fields are not behaving as you would 
expect, check that the TZ Offset is set commensurate with the current Longitude.

 LST@0 Local Sidereal Time at next local Midnight, as per the time zone. 

Looping (see also §1.5  )

  -1 +1 These are shortcuts to go backwards or forwards by one Step. Can also be 
performed by typing Control-b and Control-f.

 Now           Clicking this button will synchronize XEphem to the computer clock and 
commence Updating every Pause seconds. If Pause is 0 when this is started, it 
will be set to 10 seconds. This is really just a shortcut to clicking Now under the 
calendar; setting Step to RT Clock; N Steps to something large and then clicking 
Update.

 Step          The amount of time UTC (and its derivatives) is incremented each loop. 

 N Steps       The number of times the display will be updated (time advanced by Step each 
step) automatically.

 Pause         Number of seconds to pause between screen updates. This is used mainly to set 
up for free-running unattended operation. Pausing is not done when plotting or 
solving is active. When looping, time is maintained at a whole multiple of pause 
length.

Site name:

Above the Latitude field is an button which can display the current site name. Pressing this button 
will bring up a list of cities and observatories. The list is from the file named "xephem.sit" in the 
shared directory. Click on one entry in the list then press Set to set the Name, Latitude, 
Longitude, Elevation and Time Zone fields in the Main window. The same may also be done in 
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one step my double-clicking on a site name in the list. If Set is pressed and the text field does not 
exactly match any entry in the list, the Name field in the Main Window is simply set the string 
without effecting the other fields. The text field may also contain a search pattern. Type Enter or 
activate the Search button to scroll the list to the next item which contains the text, ignoring case, 
punctuation and spaces.

Calendar:

The calendar on the right of the Main window is based on local time or UTC, depending upon the 
Time Zone preference. Selecting a date button will set the date. Buttons before the first of the 
month and after the last of the month work as expected, that is, they also imply a change in 
month or year as necessary. The month and year buttons pop up selections that allow these to be 
changed as well. At the bottom are buttons to set the time and date to the computer clock, or 
move backwards or forwards by one day or week. Except for Now, using the calendar does not 
change the current time (just the date). New and Full Moons are marked on the day on which 
they occur in the selected time zone.

2.1  File menu

The "File" pulldown contains a few miscellaneous controls.

    System log...

 displays a scrolled list of informational messages. XEphem may beep whenever 
a new message is added, depending on the "Log Bell" preference; see below. 
Messages appearing immediately in attention boxes are also logged here for 
reference.

    Network setup...

            displays a window offering choices for how XEphem accesses the Internet 
(§2.1.1  ).

    External file...

            drives XEphem from a file containing times and latitude/longitude locations. See 
its own help for details (§2.1.2  ). 

    Progress Meter...

            displays a simple bar graph of XEphem progress. The accuracy and usefulness 
of the display are highly problematic at this time.

    Forward 1 Step

causes Time to be changed by one Step value. This action can also be 
performed when the cursor is over any XEphem window by typing Control-f. 
Invoking this command also stops looping if it is running. 

    Backward 1 Step

causes Time to be changed by the negative of one Step value. This action can 
also be performed when the cursor is over any XEphem window by typing 
Control-b. Invoking this command also stops looping if it is running.  

    Update

performs the same action as the Update button across the bottom of the Main 
window. This can also be performed by typing Control-u in any XEphem window.     
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    Quit...

exits XEphem. If any resources have been modified and Preferences -> 
Confirmations is On, a reminder will first appear and allow you to bring up the 
Save window if desired. This can also be performed by typing Control-d in any 
XEphem window.

2.1.1  Network setup

This window allows you to define a proxy or SOCKS server to use for the various XEphem 
features that utilize the Internet. One of the following three choices must be enabled for Internet 
access to be available.

    Direct connect:

        This choice just means to use the direct DNS/IP TCP/IP sockets as necessary. 
Use this one unless you are behind a firewall.

    via Proxy:

        This choice attempts to access the Internet via a Proxy. Type the port address 
and the host name of the proxy in the field provided.

    via SOCKS:

        This choice attempts to access the Internet via a version 4 SOCKS server. Type 
the port address and the host name of the server in the field provided. These 
values can be initialized using the environment variables SOCKS_PORT and 
SOCKS_NS.

2.1.2  External Time/Loc

XEphem can read a file (or fifo) containing sets of time, latitude and longitude values and 
automatically install these values sequentially unattended. Enter the name of the file in the 
window and press OK. To pause between updates, set the desired delay in the Pause field of the 
Main window. All features of XEphem, such as plotting and listing, are available while this feature 
is running (§12  ). 
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The format of each line of the file is as follows: 

        JD Lat Long

    where
JD = Julian Date

          Lat = Latitude, radians, +north
          Long = Longitude, radians, +west

The fields are separated by one or more blanks or tabs. All lines not having exactly three floating 
point values are ignored and may be used for comments, etc. 

2.2  View menu

The "View" pulldown brings up any of the several XEphem specialized displays. Each has its own 
Help so please refer to them for additional information on a particular function.

2.3  Tools menu

The "Tools" pulldown brings up windows allowing full control of the following functions:

        plotting data,
        listing data,
        equation solving,
        finding close pairs,
        seeing the night at a glance,
        retrieving AAVSO light curves
        monitoring your local SETI@home client
        typing in and converting between coordinate systems.

Each tool has its own Help so please refer to them for complete information on a particular tool.

2.4  Data menu

The "Data" pulldown brings up windows which pertain to managing the objects in memory.

    Load/Delete...

adds and deletes catalogs of objects to and from memory. The window also 
displays overall statistics of the number of each type of object in memory.

    Download Internet files...

provides a convenient means to update XEphem databases from the Net. The 
window comes preconfigured to get timely asteroid, comet and Earth satellite 
catalogs.

    Search memory, ObjX,Y,Z...

selects any given object in memory and views or modifies all of its defining 
parameters. Also can be used to center the Sky View over any object and to 
define the user-defined objects, ObjX, Y and Z.
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    Configure Field stars...

sets up how and whether to read several very large databases of faint stars 
which XEphem refers to as "field stars," including the Hubble GSC, USNO, 
Hipparcos, Tycho and PPM catalogs.

2.5  Preferences menu

The "Preferences" pulldown lists the available preferences that may be changed at run time. 
Whenever any are changed, all effected fields are immediately recalculated and redisplayed 
throughout XEphem. The preference include:

    Equatorial: Topocentric, Geocentric

            controls whether the RA and Dec values displayed throughout XEphem are for 
the current local surface location (topocentric) or from the center of the Earth. 
(Alt/Az values are, of course, always topocentric.)

    Precision: Hi, Low

            controls how much precision is shown for most angles. This is a change in 
display format only and does NOT imply a change in accuracy.

    Log Bell: On, Off

            whether to ring the bell each time a new message is added to the System Log 
window. The System Log window is accessible via the File menu in the Main 
menu bar.

    Prompt Prefill: Yes, No

            whether prompt strings from the Main window and Search windows are filled with 
the current value or blanked out. This is also handy to allow copy/paste of these 
values.

    Units: English, Metric

            whether local topocentric circumstances are given in English or Metric units of 
measure.

    Time zone: UTC, Local

            whether the time stamp below each major view, the rise/transit/set times in the 
Data Table window and the dawn/dusk times and the calendar in the Main 
window refer to UTC or local time.

    Show help tips: Yes, No

whether additional help is available immediately for all selectable buttons and 
controls using small brief windows near the control.
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    Confirmations: Yes, No

 whether operations which basically can not be undone or which might have 
irreversible consequences will be preceded with a confirmation window. 
Examples include exiting XEphem or overwriting an existing file.

     Start week on: Saturday, Sunday, Monday

 sets the day on which weeks begin in the Main calendar.

    Date formats: M/D/Y, Y/M/D, D/M/Y

 whether dates are shown and entered in month/day/year, year/month/day or 
day/month/year format.

    Fonts...

 displays a window to experiment with fonts while you watch. See its own help for 
details, §2.5.2  .

    Colors...

 displays a window to experiment with colors while you watch. See its own help 
for details, §2.5.3  .

    Save...

 displays a window which shows how the current functional settings differ from 
their defaults and allows them to be saved. See its own help for details, §2.5.1  .
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2.5.1  Save

This window displays all of the options, settings and controls throughout XEphem which may be 
saved and reinstated next time the program is started. These are collectively referred to as 
"Resources" and in fact are saved using the standard X Windows resource database mechanism. 
XEphem uses many resources, so they are separated into categories in this window for easier 
management. Each category may be expanded or collapsed using the + and - control toggles to 
show each individual resource, if desired.

Resources have been divided into two classes. Most resources are deemed suitably interesting 
that they can be automatically Saved whenever they change. These are called Major resources. 
Other resources are considered Minor in nature, meaning the user is likely to change them 
frequently while operating the program and saving them at any one particular setting is not 
especially compelling.  These are basically window size and position, scale settings which only 
effect viewing angle and all of the Sky View Filter and Option settings. This distinction is of course 
rather arbitrary however so please take care when changing and saving resources so just the 
ones you want are saved.

In the expanded view, each resource and its value are shown exactly as it would appear in the 
disk file if Saved. Those resources which differ from the last time they were Saved, or since 
XEphem was started if no Save has yet occurred, are marked with a bullet. A toggle next to each 
resource allows individual selection over whether the resource will be written to disk on the next 
Save.

After each Refresh, Major resources which are found to be out of date are marked with a bold 
bullet and automatically selected to be Saved if the Autoselect option on top is active. Minor 
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resources are marked with a hollow bullet mark and are never selected for Saving by default. If at 
least one Major resource is out of date in a category, a bold bullet is placed next to the category 
heading; otherwise if at least one Minor resource is out of date a hollow bullet is used.

Whether or not any resource is in fact Saved may always be independently set as desired using 
its toggle. The discussion above refers only to whether the toggle for each resource is set 
automatically after each Refresh.

A key is provided at the top to remind you to what the two styles of bullets refer, along with a 
count of the total resources that are out of date in each
class.

Note that the information in this window does NOT automatically track changes in resources as 
XEphem is used. You must use Refresh (see below) to update the status here when desired. In 
particular, the values which are Saved are what they were the last time Refresh was performed, 
not what they actually are at the moment Save is activated.

If the Autosave option is both on (located in the upper left) all Major resources that are out of date 
and selected when XEphem is Quit will automatically be Saved without first being asked to 
confirm using this window.

The controls along the bottom behave as follows:

    Save

        Each resource with its toggle button depressed is written to the per-user resource file 
named at the top. If the file already exists, it will first be copied to XEphem.bak in the 
same directory. If a resource already exists in the file it will be edited in-place, otherwise 
a new entry is added at the bottom. Other lines in the file are left unchanged.

        After using Save, all resources will be considered up to date, even if they were not 
selected to be written to the resource file.

        N.B. The values saved are as they appear in this window, which may be different from 
their current value if they have changed since the last Refresh.

    Refresh

        Updates the changed and save status of each resource in this window. Each Major 
resource found to be out of date is selected to be saved by default. This refresh action 
also happens automatically after a Save is performed and just before the automatic 
Saving if AutoSave is on when quitting.

    Close

        Closes the Save window. 

    Help

        Shows this information. 
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2.5.2  Save Fonts

This window lets you 
inspect and change 
many of the fonts 
used by XEphem.

The top scrolled list 
shows all fonts 
currently installed on 
your system. Selecting 
one will copy the 
name to the Font 
pattern field and show 
a sample. You can 
select with the mouse, 
or by browsing with 
the Up and Down 
keyboard arrow keys.

Below that is a list of 
the fonts recently used 
in this window for 
convenient reuse if 
required. Browsing 
operates the same 
way.

The Font pattern is a field in which a Font name may be entered, including the splat character (*) 
to serve as a wild card if desired. Press Enter or the Search button in the Control menu to find 
and display a sample of the next matching font, if any. The font named here also applies to the 
menus of context controls, described next.

The center menus in the menu bar across the top provide ways of referring to several font 
contexts. The four toggle buttons just below the menu bar determines what happens when one of 
these context menu buttons is clicked, as follows:

    Get current:

When this toggle is active, clicking a context menu button will cause the name of 
the current font for that context to be displayed in the pattern field and history list.

    Get default:

 When this toggle is active, clicking a context menu button will cause the name of 
the last saved default font for that context to be displayed in the pattern field and 
history list.

    Set:

When this toggle is active, clicking a context menu button will cause the font 
named in the pattern field of this window to be applied to that context throughout 
XEphem.
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    Restore default:

When this toggle is active, clicking a context menu button will cause its last saved 
font value to be reinstated through XEphem.

Fonts that have been changed from their default values are tagged in the Preferences->Save 
window (after you do a Refresh). This allows you to Save the new font choice permanently. If you 
do not Save it, the change only effects  XEphem until you exit.

There are a few situations scattered around within XEphem for which changing fonts at runtime 
from this window does not work perfectly. For example, changing to a smaller font does not shrink 
some windows as much as you might expect. Such anomalies are known challenges and do not 
indicate serious problems. After Saving the fonts and restarting XEphem, all will work again as 
expected. 

2.5.3  Save Colors

This window lets you inspect and change many of the colors used by XEphem.

The top four toggle buttons determines what happens when an entry in a color context menu is 
clicked. The effects are as follows: 

    Get current:

When this toggle is active, clicking a color context menu button will cause the 
current color for that context to be displayed in the color patch in the lower right 
corner of this window.

    Get default:

When this toggle is active, clicking a color context menu button will cause the last 
saved default color for that context to be displayed in the color patch in the lower 
right corner of this window.

    Set:
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When this toggle is active, clicking a color context menu button will cause the 
color currently being displayed in the color patch of this window to be applied to 
that context throughout in XEphem. 

    Restore default:

 When this toggle is active, clicking a color context menu button will cause its last 
saved color to be reinstated.         

Above the color patch are three sliding scales that allow you to define a color using either 
Red/Green/Blue or Hue/Saturation/Value, depending on the toggle. Hue is the pure spectral 
color, where 0 is red, 33 is green, 66 is blue and 100 is back to red.  Saturation is the amount of 
color purity, where lower values mix in more white. Value is like brightness, where 0 is totally 
black.

The text field at lower left allows you to type a color using one of the standard descriptive names, 
such as "steel blue", or in hex RGB notation, for example #ff0000 for pure red, #00ff00 for pure 
green #0000ff for pure blue. After typing the desired value, press Enter to set the scales and see 
the color in the patch. This field is also set automatically when the scales are used to set a color, 
during Grabbing (see next), and when a color context is retrieved.  

In the Control menu is a toggle button for Night vision. This changes the XEphem background to 
black, and uses the Night vision color for all text. Clicking this back off will restore the previous 
colors. Note that when Night vision is on, you may not change the colors it effects. This is to 
eliminate confusion with regards to wheter or not they are new in the Save window.

In the Control menu is a button labeled Grab. It may be used to capture any color on the screen. 
Press this button and the cursor will change to a crosshair. Move the cursor around on the screen 
and the color of the pixel under the crosshair will be displayed; press Button1 to capture the color 
and resume normal cursor operation.

The history list in the lower left stores each color name that is used from the name field, making it 
easier to reuse a color. Selecting a name will copy it to the name field and show it in the color 
patch. You can select history entries with the mouse, or by browsing with the Up and Down 
keyboard arrow keys.

When a color context is changed, it also changes the corresponding resource. In the 
Preferences->Save window you will notice that the resource becomes marked as Modified (after 
you do a Refresh). This allows you Save the new color choice permanently. If you do not Save it, 
the change only effects XEphem until you exit. 

2.6  Sites dialog
This window allows you to load, 
search and select one of a 
collection of predefined sites.

The scrolled list at the top lists 
the complete set of currently 
defined sites. Clicking on one 
will copy it to the Set text field. 
Double clicking on one will also 
install it to the Main window, as 
will clicking on Set or typing 
Enter over the select text field.



Main Window

Page 2-14 Version 3.5.2

To search for a particular site, either scroll through the list or enter any part of the site designation 
in the Search text field. Clicking on Search or typing Enter in the search text field will scroll the list 
to the next site that contains the search text, ignoring case and blanks.

A new file of site definitions may be installed at any time. Type in the name of the file test field 
then type Enter or click on File to read in the file. Or click on Browse and use the File Selection 
Dialog to locate the desired site file. Pressing Ok in the FSB or double clicking on a file name will 
load the new file and close the FSB window.

File format:

XEphem stores sites in the file xephem.sit. Each line in the file consists of 5 fields, each 
separated by a semicolon (;), as follows:

    Name ; Latitude ; Longitude ; Elevation ; Timezone

where:

    Name is the City, State, Country or other designation, up to 40 characters.

    Latitude is DD MM SS, followed by an N or S to indicate north or south
    of the equator. Each portion is separated by a blank.

    Longitude is in DDD MM SS, followed by an E or W to indicate east or west
    of the prime meridian in Greenwich, England. Each portion is separated by
    a blank.

    Elevation is in meters. If you do not know your elevation, put "-1.0".

    Timezone indicates the offset from GMT and savings time information. The
    format matches that of the POSIX standard fully described in the manual
    page for the tzset(3) function. The format is basically summarized as:

      std offset dst [offset],start[/time],end[/time]

Here are a few examples:

Munich, Germany    ; 48 14 0 N ;  11 57  0 E ;  523 ; MET-1METDST,M3.5.0,M10.5.0
New York, New York ; 40 45 6 N ;  73 59 39 W ; 16.8 ; EST5EDT
Sydney, Australia  ; 33 52 0 S ; 151 12  0 E ;  7.6 ; EST-10EST,M10.5.0,M3.5.0

Lines in the file which do not conform to this structure are ignored.

2.7  Examples

Follows are some example goals and worked solutions to practice using some of the XEphem 
features.

2.7.1  Sky tonight

This example will take us through a session which explores the sky tonight at midnight. Of 
course, you can do this for any night by setting the desired date first on the Main window.

    Set time to midnight tonight:

        Main->Local Time->Midnight Tonight
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        Main->Update

    Display the available database files:

        Main->Data->Load and Delete...

    Load up several database files, as desired, by double-clicking in the
    list at at the bottom:

         Data Base->YBS.edb           // Yale Bright Star catalog
         Data Base->Messier.edb      // Messier catalog
         Data Base->NGC.edb          // RNGC objects (all but Messier)
         Data Base->SAC.edb           // even more deep-sky objects
         Data Base->asteroids.edb    // many asteroids

    Bring up the sky view:

        Main->View->Sky View...

    Explore around using mouse pointing and/or by sliding field-of-view and
    pointing controls as desired.

    Save the objects in the Sky View in a file:

        Sky View->Control->List...

    Make a printed copy:

        Sky View->Control->Print...

    Now let’s focus in on some close encounters. Let’s switch to RA and Dec
    coordinates, tighten up the field and increase the limiting magnitude so
    we can see fainter things:

        Sky View->Control->Options->Coord:RA-Dec
        Sky View->FOV->  slide to 2.0
        Sky View->Control->Filter...
          Sol Sys Lim Mag ->  slide to 14
          Stars Lim Mag ->  slide to 14
          Deep Sky Sys Lim Mag ->  slide to 14
          Ok

    You’ll probably want to use the Topocentric preference from the Main window:

        Main->Preferences->Equatorial->Topocentric

    Open the Close objects window, build a list of all moving objects within,
    say, 1 degree of each other:

        Main->Tools->Find close pairs ...
            Close->Max sep->    enter 1.0
            Close->Mag limit->  enter, say, 13
            Close->Options->Omit fixed pairs    // if not already on
            Close->Control->Go                         // might take a moment..

    Now scroll through your set and find something that looks good. For
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    example, tonight I happened to find asteroid 702 Alauda passing within 16
    arc minutes of the bright open cluster NGC 6416. Double click on the
    row and the Sky View will swing around and show it to you. You might want
    to tweak up the field-of-view a bit.

    If you’ve chosen an asteroid, let’s plot its motion over several hours. Put
    the mouse near the asteroid, click button 3, pull down to "Create Trail..."
    and let go. You’ll get a trail setup window:

        Trail->1 Hour
        Trail->First+Mid+Last
        Trail->Number of intervals:  enter 24
        Trail->Ok

    If you get a wild array of lines, be sure Sky View->Control->
    Options->RA-Dec is set.  You may click on any of the tick marks with
    mouse button 3 to get the circumstances of the asteroid at the
    various times along the trail. You can change the trail parameters
    by using "Change Trail..." and proceeding as before.

    With luck, you’ll have a pretty appulse to watch.

2.7.2  Solar eclipse path

This example displays the location of totality on the Earth for the solar
eclipse of July 11, 1991.

    for convenience, use UTC for all time displays:
        Main->Preferences->Time zone->UTC

    set time to 17:25:00
        Main->UTC Time
            enter 17:25:00 then Ok (or just Enter).
            note you may use almost any punctuation character instead of ":"
                and you need not give leading zeros. for example: "17;25;0".

    set date to 11 July 1991:
        Main->UTC Date
            enter 7/11/1991
            note this should be entered according to the current date format
                preference. for example, after
                    Main->Preferences->Date formats->Y/M/D
                you would enter the same date as "1991/7/11".

    commit to new date and time:
        Main->Update            (note NEW CIRCUMSTANCES stops flashing)

    display the Earth:
        Main->View->Earth...

    A black cross should appear a little southwest of Hawaii. That is the
        current center of totality.

    display the subearth point of the Moon, i.e., the point on the Earth’s
        surface at which the Moon is directly over head:
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        Set Moon as current object:

            Control->Objects...

        Click on Display and Label.

    One may now easily read off the local altitude of the Moon by comparing
        with the circles of 0, 30, 60 and 90 degree altitudes. More precise
        values for altitude, and azimuth, may be obtained for any location
        using the right mouse button.

    change Main location to Mauna Kea Observatory:
        move cursor near southeast edge of Hawaii, hunt around clicking right
            button until the popup says Mauna Kea, slide down and let go over
            "Point"
        Earth->Control->Set Main
            the white Plus on the Earth should move over Mauna Kea and the
            central longitude should shift to approximately 155 degrees west.
            Note the Latitude and Longitude in the Main view are also updated.

    Zoom the view to show the sky from Hawaii:
        Main->View->Sky View...
            Sky View->FOV->1    (move left scale up until it says about 1.0)
            Sky View->Locate->Sun
            move cursor over the center of the Sun, select right button, pull
                down and let go over "Track"
            make sure Sky View->Control->Options->Alt-Az is selected
                (or Main->Preferences-> Equatorial->Topocentric is set)
                to get a topocentric point of view.

    set up a movie showing the path of totality for the next two hours:
        Main->N Steps-> enter "24", then Enter
        Main->Step->0:05:00
        Main->Pause->1
        Main->Update

2.7.3  Sky trail

This example will use the Sky View to display a trail of the appulse between
asteroid 121 Hermione and NGC 7293 which occurs about July 28, 1995. We also
demonstrate displaying stars from the Hubble GSC catalog in the sky background
This example is taken from Sky and Tel, July 1995, page 72.

    for convenience, use UTC for all time displays:
        Main->Preferences->Time zone->UTC

    set time to 00:00 using shortcut:
        Main->UTC Time:->00:00:00

    set date to 24 July 1995 using the interactive calendar:
        Main->(Year)->1996
        Main->(Year)->1995
        Main->(Month)->July
        Main->24
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    commit to new date and time:
        Main->Update            // note NEW CIRCUMSTANCES stops flashing

    read in asteroid and NGC databases:
        Main->Data->Load/Delete ...
            in lower right corner, double-click on "asteroids.edb"
                (or could have single-clicked and then pushed Append)
            similarly, double click on "NGC.edb" (scrolling a bit if necessary)
            Control->Close

    select 121 Hermione to be Object X:
       Main->Data->Search memory, ObjX,Y,Z...
        in the upper center, click on ObjX
        in the lower right, type "hermi" then Enter in the Search text field
            (this finds 121 Hermione in memory and stages it to become ObjX)
            (you may also browse by scrolling through the list at right and
             selecting the candidate object’s button).
        load this into Object X and dismiss the window:
            Ok

    display asteroid trail on sky view:
        Main->View->Sky View...
            Locate->121 Hermione
            set Field of View to about 1.5 degrees using scale on left
            Control->Filter..
                set "Sol Sys Lim Mag" to 16 using scale
                Ok
            place cursor over the central dot (Hermione!) and press button 3:
                Create Trail...
                    Orientation: Left
                    Interval: 1 Day
                    Label: Every 2
                    Format: Date

       Font: Small
                    Number of tick marks: slide to 8
                    Ok
            center the trail by placing cursor near dot for 7/28/95 and press
            button 3, then scroll down and release on:
                Center

    add nearby Hubble Guide Star Catalog entries:

        If you have not already done so, set up the source for the GSC stars:
            Sky View->Control->Field Stars...

        Enable viewing Field Stars and load an initial set:
            Sky View->Control->Options->Field Stars

        The GSC stars will now be read in and displayed.

    if desired, overlay with a coordinate grid:
        Sky View->Control->Options->Grid
        (making the Sky View wider will allow room for more grid labels)
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As another example, investigate the appulse between M21 and 241 Germania near
July 15, 1995. Use ObjY for the asteroid so you can leave ObjX as Hermione.
If you have your Sky & Tel handy, this is also described on the same page as
the above reference. From the picture in that article, you can see that the
elements shipped with XEphem for 241 Germania no longer quite match the epoch
of the image, and the Saguaro Astro Club entry for M21 is slightly too far
south and east. This emphasizes an important note: XEphem is only as good as
its databases.

2.7.4  Displaying images

This example will go through displaying an image in the Sky View. The image may be either a 
FITS file on your local disk, or may be retrieved via the Internet.

    Bring up the Sky View display:

        Main->View->Sky View...

    Bring up the Image control window:

        Sky View->Image->Load and Save...

To display a FITS file, use the file selection window at the bottom to browse your local file system. 
When the you have found the file, select it in the list and press the Open button. The image will 
be displayed in the Sky View.

Note: In order to be displayable by XEphem, the FITS file must be in 16 bit image format (BITPIX 
16).
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Or, to retrieve a Digitized Sky Survey image, use the Sky View scales to center the view on the 
desired sky location, set the field of view scale as desired, select either of the buttons at the top 
labeled STScI or the ESO the click Get. For these to work you must have a live Internet 
connection.

STScI is located in Maryland, USA. ESO is in Germany. They both provide identical service so 
use whichever gives you better network performance. The maximum size of an image retrieved in 
this manner is currently restricted to 30 arcminutes.

Once an image is displayed by either method, all Sky View features are available. So, you may 
add a grid overlay, load and display field stars, track the coordinates with the cursor, etc etc, as 
with any Sky View. Investigate the various Controls from the menubar of the Sky View to see 
what all is available. For example, if your image has WCS or DSS coordinates, to display field 
stars over the image: 
        
Set up a source for the field stars (if not already set up):

            Sky View->Control->Field Stars

                (follow the directions in the Help)

Turn on the following options (if not already on):

            Sky View->Options...

                Auto mag
                Field Stars

Next explore the image processing capabilities:

            Sky View->Images->Processing tools...

The image will remain in the Sky View until the direction is changed. If you loaded a DSS image, 
you may want to save it to your local disk for easier access next time.

2.7.5  Sunrise plot

In this example, we will plot the times of local dawn, sunrise, sunset, and
dusk over the course of 2001.

    Set the date to Jan 1 2001:
        Main->Local Date-> 1/1/2001
            you might have to enter this differently depending on your current
                Date Formats preference.

            you could also set the date by using the interactive calendar at
            the right: select the current month, slide and release over January.
            then push the "1" date on the calendar.

     Show times in local timezone:
        Main->Preferences->Time zone->Local

    Set the time to local midnight:
        Main->Local Time-> select 00:00:00 shortcut
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    commit to the new date and time:
        Main->Update            (note NEW CIRCUMSTANCES stops flashing)

    bring up the data table:
        Main->View->Data Table...

        (if the RisTm and SetTm columns and the Sun row are not visible, use
        the Setup option to enable at these columns and rows.)

    bring up the plot control window:
        Main->Tools->Plot...

    define a plot with four independent traces with local date on their X axis:
        Plot->Select fields
            (note how all labels which can be used for plotting now look and
            operate like buttons. as you press them, they form the definition
            of what will be saved for plotting; watch the X and Y columns of
            the Plot window be filled in as you define the variables to plot).

        Main->Local Date
        Main->Dawn

        Main->Local Date
        Data->Sun.RisTm

        Main->Local Date
        Data->Sun.SetTm

        Main->Local Date
        Main->Dusk

        Plot->Select fields     (turns buttons back to labels)

        When you are finished, the lower portion of the Plot window should look
        like this:

            Tag         X          Y
            A           LD        Dawn
            B           LD      Sun.RisTm
            C           LD       Sun.SetTm
            D           LD        Dusk

        If you make a mistake, you must start over (Undo is on my list :-)

        If you wish, you may edit the Tags to more accurately denote their
        meaning, such as D, R, S and d. Case is significant, but you only get
        one character.

    Set up Main to generate data every other day for 182 steps, i.e., span about
    one year:

        Main->N Steps->182
        Main->Step-> enter 2d, then select Ok (or type Enter)

    Give the plot a title in the text field provided:
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        Type: Local Sun Dawn/Rise/Set/Dusk time for 2001

    Define a file to contain the plot values:

        Plot-> enter a file name in the text field, such as sun2001.plt

    Start capturing XEphem plot data to the plot file:

        Plot->Create plot file

    Let XEphem run:

        Main->Update

        Note that as it runs, XEphem does not update many values and they are
        made to look unusual. This is for speed. It only does this if
        Main->Pause is set to 0. If Pause is anything greater than 0, all
        values are drawn. In any case, internal values are always updated; it’s
        just the display that is eliminated for a little more efficiency.

        Also, things will go fastest if the Data Table is only showing what
        is necessary, such as turning off all but the Sun row in this case..

    When it stops, display the year of plot data:

        Plot->Show plot file

    Note how the "Plot->Create plot file" option is automatically disabled. Also note the spring and
    fall discontinuities in the plot if you observe Daylight Savings time in your time zone.

    Change the X axis label to be a little easier to relate to:

        Plot->View->Show X-Axis as Dates

Here is an example for Chicago:

2.7.6  Ring crossing

This example will demonstrate the programmable equation solving feature by
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solving for the time when the Earth crosses the ring plane of Saturn.

Generally when using the solving feature of XEphem, a plot of the function
should be made first to investigate the general behavior of the function over
time and to form an initial estimate of the solution. Hence, our first step is
to make a plot of ring plane angle throughout 1995.

    Use UTC for all time displays:

        Main->Preferences->Time zone->UTC

    Set the date to Jan 1 1995:

        Main->Local Date-> 1/1/1995
            You might have to enter this differently depending on your current
                Date Formats preference.

            You could also set the date by using the interactive calendar at
            the right: select the current month, slide and release over January.
            then push the "1" date on the calendar. Do the same sort of thing
            to set the year.

    Set the time to UTC midnight:

        Main->UTC Time->00:00:00

    Bring up the Saturn diagram and supporting information views:

        Main->View->Saturn...
            Saturn->View->More info..

    Bring up the plot control window:

        Main->Tools->Plot

    Select one function to plot, UTC Date vs. Earth ring tilt:

        Plot->Select fields     // turn on
            Main->UTC Date
            Saturn info->From Earth
        Plot->Select fields     // turn off

    Specify plot file name and give it a title:

        Plot->File name: rings.plt
        Plot->Title: Saturn Earth Ring Tilt for 1995

    Enable plot file capture:

        Plot->Create plot file

    Accumulate 180 steps, each 2 days:

        Main->N Steps           enter "180" then Enter
        Main->Step                enter "2d" then Enter
        Main->Update            // runs through 180 steps, rather subdued. it
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                                           // runs faster if you close the Saturn view.

    Display plot file,

        Plot->Show plot file
        Plot file->View->Show X-Axis as Dates

    There are evidently two crossings (i.e., where the tilt angle is 0), one in late May and one in
    early August. Lets solve for the one in August:

        Main->December->August
        Main->Update                            // to engage NEW CIRCUMSTANCES

    Open the Solve control window, set up to solve for when the Earth ring
    tilt goes to zero:

        Main->Tools->Solve...
            Solve->Enable field buttons // turn on
                Saturn info->From Earth
            Solve->Enable field buttons // turn off
            Solve->Compile
            Solve->Find 0
            Solve->Solving is Active
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    And go:

        Main->N Steps->1000000
        Main->Update

    The looping stops at Aug 10, 1995, at about 19:24 UT. The August 1995 Sky and Tel, page 72, 
says it occurs at about 21h +- 2.

2.7.7  Lunar occultation

This example was taken from the lunar occultation of Spica (Alpha Vir) which
occurred January 23, 1995, UTC, as reported in Sky and Telescope, January 1995.

    If the YBS.edb database is not already loaded, load it now so that Spica
    is loaded in the XEphem database:

        Main->Data->Load/Delete...
            YBS.edb
            Append
            Control->Close

    Set UTC Zone preferences:

        Main->Preferences->Time zone->UTC

    Set the Topocentric Equatorial preference:

        Main->Preferences->Equatorial->Topocentric

    Set Equinox to EOD (occultations must always be computed using EOD):

        Main-Equinox

        select EOD

    Set up the date and time to Jan 23, 1995, 11:45:00 UT, using the calendar
        and the "UTC Time:" selections in the Main window.

    Set the Step size to one minute (0:1:0) using the Step selection in the
        Main window.

    Set the location to Chicago, using the Site selections in the Main window:

        Main-><Site>
            type "chicago" into the Search field,
            type Enter,
            type Set
            select Close

            or

            scroll down to "Chicago, Illinois" and double-click on it.
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        Main->Update

    Display the Moon:

        Main->View->Moon..

    Make sure the true Sky background option is enabled:

        Moon->View->Sky background

    Spica is just behind the dark western limb, ready to emerge. To see it,
    press Main->Update to advance the time by 1 minute. Spica appears at 11:47
    and near the craters depicted in the schematic on page 83.

    An analytical method is to use the Main->Tools->Solve method to find the
    time when the following equation evaluates to zero:

        "Spica.Moon"-"Moon.Size"/7200

    Set the Desired Accuracy to 0:0:1 and one finds the occultation occurs at 11:46:10 UTC.

2.7.8  International Space Station

This example will show how to display the ground track for the International Space Station in the 
Earth View, find when it will next be visible in your location, and display its path through the sky 
overhead in the Sky View.

    First be sure XEphem has a working connection to the Internet

click Main->Network Setup
click on the appropriate choice

    Get fresh elements from the web:

bring up Main -> Data -> Download Internet files
Type "ISS" in the Search field and turn on the toggle
click "Get" next to the entry for stations.txt
click Assign to "ObjX"

    Show the current position of the ISS in the Earth view:

bring up Main -> View -> Earth, then Control -> Objects
click the left menu button at the top, slide down to ISS and release.

    Create a ground track for the next few hours:

click the Trail button in the column used for ISS.
slide Number of tick marks to about 50
select Orientation->Up, Font->Small
click Apply

    For fun, show in "mission control" format:

click Earth->View->Cylindrical
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    Set your location:

click on the button below "Location" in the Main window
scroll through the list and click on a city near you
click Set
click Close
in Main, click Update at the bottom

    To get a quick idea of all times when IIS is visible at your location:

click on Main -> Tools -> Night at a glance

    the dotted light near the bottom shows all times when IIS is
    visible between noon today and noon tomorrow.

    To see the next time ISS will rise in your location:

click Main -> View -> Data table

The next rise time is in the RisTm column. If this column is not visible:

    bring up Control -> Setup
    toggle Rise/Set -> RisTm so it is On
    click Apply

The highest it will get on this pass is in the TrnAlt column. If this
column is not visible:

    bring up Control -> Setup
    toggle Rise/Set -> TrnAlt so it is On
    click Apply

    Note the RisTm (from above) and set the the Date and Time in the Main
    window to about 30 seconds or so later. Be sure to use UTC or Local
    depending on Main -> Preferences -> Time zone.

    Show the path overhead in the Sky View:

check that Main -> Preferences -> Equatorial is set to Topocentric
click Main -> View -> Sky View...
check that Sky View -> Control -> Options -> Orientation set to Alt-Az
slide the FOV to a full 180 degrees
click Sky View -> Locate -> ISS to mark the ISS on the sky map
move the mouse over the ISS, press the right mouse button, slide down
    and release over Create trail...
select Interval/Custom and type in one minute as 0:01
also set these options for starters:
    Orientation/Up
    Format/H:M
    Font/Small
    Label/Every 2
    Start/Whole interval
slide Number of tick marks to about 10
click Apply
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3  Data Table

This is a table of information about each planet, the Sun, Moon, and any three user defined 
objects, ObjX, Y and Z. Each data item occupies one column in the table and each object 
occupies one row.

The Control pulldown menu contains the following options:

    Setup ...

        This button brings up a configure window to specify the table rows and columns as desired.

    List ...

        This button allows the current data table to be saved in a text file.

When any columns related to rising or setting are active a box at the bottom will indicate whether 
the times refer to the center or the upper limb of the object. Similarly, when either the RA or Dec 
columns are active or any of the separation columns are active a box will be present to indicate 
whether the separation is from a geocentric or topocentric point of view. The box will also indicate 
the precession epoch. See the help for the "Setup" window for more information about these 
modes.

Any of the information in this table may be plotted (§12.1  ), listed (§12.2  ) or used in a solver 
algorithm (§12.3  ). See the help for these control functions for more details.

See the help for the "Setup" window for a description of each column. 

3.1  Setup window
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This window lets you configure which rows and columns will be in the Data Table.  When this 
window first comes up it will be set to indicate the state of the Data Table. You may then 
manipulate the toggle buttons as desired. To actually change the Data Table to a new 
configuration select the Apply button.  Ok does the same thing but also closes this window. 
Close just closes this window without making any permanent changes. In addition to 
manipulating each item individually, each columns includes handy shortcut controls at the top to 
make changes to column as a whole.

The first column of this window selects which rows will be present in the Data Table. The planets 
and the Sun and Moon are always in this column. If user defined objects ObjX, Y or Z are defined 
then they will also be present and controllable from this column. See the help for the "Set 
ObjXYZ" window for more information about user defined objects (§13.3  ).

Entries in the remaining three columns in this window control which columns will be present in the 
Data Table. They are grouped into three categories for convenience.

Column two controls miscellaneous basic information. The descriptions of each entry are as 
follows:

 Cns name of the constellation in which the object appears. 

 RA Right ascension: if Main Equinox is set to EOD this is the apparent place, 
otherwise it is the astrometric (mean) place. If Main Preference Equatorial is 
Topocentric, it is further corrected for parallax. 

 HA geocentric or topocentric hour angle of object, computed as LST-RA precessed 
to EOD. Positive angles are west of the meridian. 

 GHA Greenwish Hour Angle, hour angle of object when at 0° longitude.

 Dec Declination: if Main Equinox is set to EOD this is the apparent place, otherwise it 
is the astrometric (mean) place. If Main Preference Equatorial is Topocentric, it is 
further corrected for parallax. 

 Az topocentric degrees eastward of true north for object.

 Alt          topocentric degrees up from a horizontal plane that is Elevation feet above sea 
level. Corrected for refraction. 

 Zenith        topocentric Zenith distance, degrees; corrected for refraction. 

 Air           Number of relative air masses through which light from the object passes to the 
topocentric observer. Computed by the method of Hardie, clamped to a max at 3 
degrees altitude. 

 Spect Basic spectral classification, if appropriate.

 Size angular size of object, in arc seconds. If not otherwise given, estimated for 
objects in heliocentric orbits from the absolute magnitude parameter H and by 
assuming an albedo of 0.10, for which H is 18 for an object of 1.06 km diameter 
at 1.0 AU. 

 VMag visual magnitude of object. 
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 Phase percent of visible surface in sun light. 

 Elong spherical angular separation between the Sun and given object, calculated from 
the their geocentric ecliptic coordinates. Note this is not just the difference in 
ecliptic longitude, as is sometimes used. The sign is positive for an evening 
object or negative for a morning object. Thus, this field is not generally useful in 
searching for eclipses because of the discontinuous sign change which occurs at 
conjunction. For that, use the individual Separations fields.

 HeLat         true heliocentric latitude, in degrees.  For the Moon this is the geocentric latitude. 

 HeLong        true heliocentric longitude, in degrees.  Earth’s is displayed on the Sun’s line.  
For the Moon this is the geocentric longitude. 

 GLat          galactic latitude, in degrees. 

 GLong         galactic longitude, in degrees. 

 EcLat          ecliptic latitude, in degrees. 

 EcLong         ecliptic longitude, in degrees. 

 EaDst         true distance from Earth center to object center, in AU, except distance to the 
Moon is in miles or km depending on the Units preference. 

 EaLght        time for light to travel from Earth to object. Format is hh:mm for all solar system 
objects, except the Moon is in decimal seconds. 

 SnDst         true distance from Sun center to object center, in AU. 

 SnLght        time for light to travel from Sun to object. Format is hh:mm. 

 Uranom Volume and Page number of object’s location in the original Uranometria, 
published by Willmann-Bell, Inc.       

 Uran2k Volume and Page number of object’s location in the new Uranometria 2000 
edition.   

 MillSA Volume and Page number of object’s location in the Millenium Star Atlas, 
published by Sky Publishing Corp.

 
Column three controls information related to rising, transitting, and setting. These are computed 
based on a refraction model that uses the actual atmospheric and topocentric circumstances 
displayed on the Main window. A text entry field is available in which you may specify a number 
of decimal degrees the local horizon is above horizontal to account for local effects. 

The "Limb" option means that the rise and set circumstances are based on the location of the 
upper limb of the object. "Center" means that the circumstances are based on the location of the 
center of the object. 

Follows is a description of the Data Table columns controlled by the third Data Selection column:
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 RisTm
 RisAz    The local or UTC time and azimuth when the upper limb (or center) of the object 

rises TODAY. See note below for Earth satellites. 

 TrnTm
 TrnAlt   For all but Earth satellites, this is the local or UTC time and altitude when the 

object crosses the meridian TODAY, i.e., when its azimuth is true south or, if no 
precession, when the local sidereal time equals the object’s right ascension. If 
the object is an Earth satellite, this is the time and highest altitude the satellite 
ever reaches above the local horizon (at whatever azimuth).

 SetTm
 SetAz    The local or UTC time and azimuth when the upper limb (or center) of the object 

sets TODAY. See note below for Earth satellites.

 HrsUp    The number of hours the object is up TODAY, that is, the difference between the 
set and rise times. See note below for Earth satellites.

Note for time zones:

Rise and set circumstances are all computed in local time. If the Time zone preference 
(from the Main menubar) is set to UTC then the times are converted to UTC. Thus, when 
reference is made to TODAY it means the current local date, not UTC date. 

Note for Earth satellites:

    Due to their generally rapid motions Earth satellites often have many rising and setting 
events per day. For this reason, the rise and set time for satellites are not restrained to be 
during the current local day. Rather, for satellites, XEphem displays the very next rising 
and setting events that occur strictly later than the current time on the Main window, 
provided they occur within 24 hours. This means that if the rise or set time displayed is 
earlier than the current local time on the Main window, it actually refers to the next day. 
This doesn’t happen for the other objects because their times are restricted to events that 
happen just today. Similarly, we can only compute the HrsUp column if the set time is 
strictly later than the rise time.

    The upshot of all this is that the best way to really understand the visibility of a satellite in 
your area is by graphing its altitude over the desired time interval.

Various "odd ball" rising, transit and setting conditions are accounted for and marked when they 
occur as in the following table. Note that in the case of Earth satellites, "TODAY" really means 
within the next 24 hours.

 NoRise up some time but never rises, as such, TODAY.
 NoSet up some time but never sets, as such, TODAY.
 NoTran up some time but doesn’t transit, as such, TODAY.
 CirPol object is circumpolar (never goes below horizon) TODAY.
 NvrUp object is never above the horizon TODAY.

The last column in the Data Table setup window controls for which objects angular separation is 
computed.  Each entry in the Data Table will be the angular separations between each pair of 
objects, in degrees.

The vantage point for the Separation values depends on the Equatorial preference in the Main 
window. "Geocentric" ignores local conditions and gives the separation as seen from Earth 
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center. "Topocentric" uses the local conditions known to XEphem. The choice is particularly 
critical for lunar occultations and Earth satellites, of course, but the effect can be significant for 
the planets as well. Geocentric separations between objects and the Sun will match the 
magnitude of the elongation given in the Data Table window.

When ObjX, Y or Z are defined, these will appear in the last column and separations between 
them and the other objects (in column 1) may be selected for display.

Note:

Solving over a period that will include the rise or set times of either object is generally 
better performed from the geocentric viewpoint.  The refraction effect of the topocentric 
viewpoint causes many arc minutes of rapid whiplash displacement as the objects rise 
and set that overlays the smooth celestial motion of the objects.  This rapid position 
variation can confuse the solver algorithms that expect fairly smooth functions.



Moon View

Version 3.5.2 Page 4-1

4  Moon view

This is an image of the Moon, shaded to indicate phase. It may be flipped and scaled as desired 
and many Lunar features may be labeled, including most spacecraft landing sites. During a Lunar 
eclipse, the edges of the umbra and penumbra regions are drawn as solid and dashed lines, 
respectively.

The coordinate system on the Moon is such that latitude increases towards the north and 
longitude increases towards the east. When facing the Moon with the unaided eye, lunar east is 
towards the right. The lunar image in XEphem is oriented with the polar axis vertical on the 
screen. Letters are placed at each edge of the image to show nominal celestial directions.

If at least three colors can be allocated the image is rendered with at most 30 shades of gray; if 
only two colors can be allocated it is dithered into a black and white image.

The Moon nods and rocks slightly as it moves through the sky. This motion is called libration. A 
dot is placed on the circumference of the image to indicate the limb position that is currently tilted 
most towards Earth due to libration. The angular position of the dot is placed accurately but the 
image rendering is not adjusted for libration effects. Thus, the surface features over which the dot 
and the terminator appear in the image are only approximate. See the Help for "More info..." 
under View for more information on libration.

4.1  Mouse functions

   Left button:

        Activating the left mouse button while over the lunar image will display a small magnified 
2x view of the lunar surface under the cursor. The magnified image will track the cursor 
as it is moved around the image. The latitude, longitude and solar altitude of the location 
are displayed in the "More info..." window. See Help for View for more information about 
this window.
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    Right button:

        Activating the right mouse button while over the lunar image will bring up a popup menu. 
If the location is near an item in the lunar features database, the name of the feature, its 
type, diameter in miles or km (depending on Preferences->Units), location and solar 
altitude at its center are displayed in the window. A toggle button will also be present 
which controls whether the label for the feature will be persistent, that is, shown 
regardless of whether View->Features is activated. Persistency is automatically reset if 
the Scale is changed. If the location is not near a feature, then only location and solar 
altitude are displayed in the window. The algorithm chooses the smallest and closest 
feature about which to report.

        Activating the right mouse button while not over the lunar image but near a sky 
background object will bring up a popup menu containing the name and magnitude of the 
object. One of the following two options will also be available:

        Assign ->
            To ObjX
            To ObjY
            To ObjZ

        This cascade allows you to assign the given object to become ObjX, Y or Z, as desired 
(§13.3  ). This will also cause all other views which are currently making use of this object 
to be updated and the object will be added to and selected by the Data table. Also, since 
this makes the object one of the User-Defined objects it will now appear directly in the 
Sky View->Locate pulldown menu.

        Show in Data Table:

        This option is only offered when the object chosen under the cursor is a planet, the Sun 
or the Moon. Selecting this option forces the object to be enabled in the Data Table.

The two features may be activated together if desired by first pressing the left button then the 
right button. This is helpful when trying to locate a particular feature in the magnified view. Try to 
always release the right button to dismiss the popup before releasing the left button. If you 
release the left button before the right button, the magnifying glass will remain on the image. If 
you run into this, you can activate the glass again and mop up the remains of the old glass.

4.2  Control menu

    Print...

   This selection allows printing the current Moon view or saving it to a file.

    Field Stars...

        This selection activates the Field Star setup window. For more information about this 
facility, see the Help for the Field Star window itself.(§13.4  )

    Set Earthshine...

        This brings up a window containing a scale which allows you to set how bright the 
Earthshine is in the Moon image. The value ranges from 0, black, to 10, full sun light. Full 
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sun light is useful when you would like to peruse the Lunar surface but would rather not 
change the XEphem date to a full Moon.

        This value depends on the gamma of your display. A fine discussion of display gamma 
and a test image with which you can determine the gamma value of your own display 
may be found at the URL: 

            
http://www.cs.cmu.edu/afs/cs.cmu.edu/user/rwb/www/gamma.html

    Movie Demo:

        This sets up an automatic display movie of the Moon. This is done by setting the N Steps 
entry in the Main window to a large value; setting the Step to two hours if Sky background 
is Off or to one minute if it is On; and starting XEphem looping. The movie can be 
stopped by selecting this option again or by selecting Stop from the Main window.

    Close:

        This closes the main Moon display and, if open, the More info window. The image is 
never updated while it is closed. However, for convenience, if any of the fields in the 
More Info window are being used for listing, plotting or solving, the continue to be 
updated even when the window is closed. 

4.3  Views menu
    Spacecraft:

        If set and the Scale is at 6, then all spacecraft landing sites are marked and labeled on 
the image. If the Scale is less than 6, then only the Apollo sites are marked.

    Features:

        This sets whether additional (non-spacecraft) Lunar features are labeled on the image. 
More features are labeled at larger scales. Even at the largest scale, all of the features 
are not labeled. However, all features are searched at all scales when using the 
right-mouse click to interrogate a location.

    Sky background:

        This sets whether to show objects within the current field of view that are in the XEphem 
database memory or available from the Field Star facility. The size and symbol used for 
the object matches that of the Sky view when set for a minimum magnitude of 12. While 
this option is on, XEphem will continue to retrieve field stars as required.

    Use real image:

        This sets whether to render the Moon using a real image, or just a simple schematic 
drawing of the sun lit and earth lit portions. The latter option is primarily just for simpler 
printing. Even while this option is on, the magnifying glass will still show the real image, 
and the lunar features database is still accessible via the right mouse button.

    {Pen}Umbra:

        This sets whether to show circles at the edges of the umbra and penumbra during a 
Lunar eclipse.
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    Flip T/B:

        This sets whether the image is flipped top-to-bottom.

    Flip L/R:

        This sets whether the image is flipped left-to-right.

    Grid:

        This sets whether a coordinate grid is drawn over the image. Each line is spaced at an 
interval of 15 degrees.

        Also, the current subearth location is marked with an X; the subsolar point is marked with 
a small open circle; and the anti-subsolar point is marked with a small filled circle.  

4.3.1  More info dialog
This brings up a separate window with additional information.

The top portion of the window reports the location of the cursor as it is moved over the image, if 
the left button is pressed. It also shows the altitude of the Sun and the times when the Sun will 
next rise and set at that location. The times are in accord with the Time zone Preference in the 
Main window.

The lower portion of the window shows the lunar longitude of sunrise, the lunar latitude of the 
subsolar point, and libration information.

The longitude of the subsolar point is at +90 from the sunrise longitude, and the longitude of the 
anti-subsolar point is at -90. The libration in longitude is positive towards lunar east; latitude is 
positive towards lunar north. The Limb angle is zero at lunar north and increases towards lunar 
west. The Tilt is the number of degrees the Moon is tilted towards Earth around an axis defined 
by the librations in latitude and longitude. The limb location that is titled most towards Earth is 
indicated on the image by a small dot.

Any of the values in the lower portion may be used for plotting, listing and solving in the usual 
way as described in the Help entries for these Control options. The values are always current 
when used in this way, even if the main Moon view is closed. For faster looping, close the main 
Moon display to prevent it from being redrawn each time.
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4.4  Scale menu

This pulldown menu presents a list of factors by which the lunar image may be scaled.  The 
image is presented in a scrolled window for panning if it is larger than the overall window.
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5  Earth view

This view displays a schematic of the Earth with 
continent outlines. The projection may be spherical or 
"Mission Control" style. The controls available from the 
menu bar across the top control the view, additional 
information and the ability to overlay the ground 
positions of up to three objects. The scales along the 
bottom and right edges display, and may be used to 
control, the center location.

Any of basic Planets, Sun and Moon as well as ObjX, 
Y or Z from the XEphem database may be displayed 
on the map. The surface location of an object is 
marked with a bulls eye. The concentric circles 
indicate the locus of points at which the object appears 
to be 0, 30, and 60 degrees above the local horizon. 
When the Earth view is first displayed, the ObjX,Y,Z 
objects will automatically be preselected and the view 

centered on ObjX, if they are defined. After that, you are free to change things as desired. Note 
that these can be preset directly at startup by using .edb database files containing exactly one 
object each; see Data -> Load -> Help -> on Control for more information(§13.1  ).

The location defined in the Main window is marked on the map with a plus (+).

If a solar eclipse is occurring on the Earth a small X will mark the location of central totality. Try 
July 11, 1991 around 18:00 UT or May 10, 1994 around 16:00 UT.

All computations for Earth satellites are based on the NORAD SGP4/SDP4 code. This code 
produces the exact same output as their test collection. This means, however, that it is not 
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integrated particularly tightly with the rest of XEphem. For example, its computations use a 
different model for Earth flattening and for refraction. These and other differences can lead to 
modest inconsistencies.

5.1  Mouse functions

As long as the cursor is over the Earth, the four corners of the View will display the following 
information about the position beneath the cursor:

        Upper left: Latitude
 Upper right: Longitude
        Lower left: Local Mean Time
        Lower right: Local Sidereal Time

    Middle button:

       If View->Live dragging is On then while the middle button is depressed and located over 
the Earth map, the cursor is changed to a fleur pattern. Moving the mouse left and right is 
like moving the scale at the bottom; moving it up and down is like moving scale at the 
right. This provides a simple method to pan the display.

    Right button:

       If the right mouse button is depressed while over the Earth, a popup menu appears with 
information related to the location under the cursor as follows:

            If the location is near a Site, information is presented with respect to the exact 
location of that site, otherwise it is with respect to the latitude and longitude of the 
location under the cursor.

            If the location is near the current or a trailed location of one of the displayed 
objects, information is presented with respect to the location under the cursor and 
for that object at the time of the trail mark.

        In either case, there will also be a button labeled Point that, if activated, will center the 
orientation on the selected location. 

5.2  Control menu

    Print...

        This selection allows printing the current Earth view or saving it as a Postscript file.

    Objects...

        This brings up a window to control which of the User Defined Objects, OBJX, Y, Z, are 
displayed. See its own Help for full details. 

    Set Main:

        This sets the Latitude and Longitude of the Main window to that of the current position of 
the Earth view. This also causes all other information and views to be updated to reflect 
the new location.
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    Set From Main:

        This sets the Earth view position to that of the Main window.

    Movie Demo:

        This sets up an automatic display movie of the Earth. This is done by setting the N Steps 
entry in the Main window to a large value; setting the Step to 5 minutes; and starting 
XEphem looping. The movie can be stopped by selecting this option again or by selecting 
Stop from the Main window.

    Close:

        This causes both the Earth view and the extra statistics window to be closed. 

5.2.1  Objects dialog

This window allows you to display up to three objects on the Earth view simultaneously, with 
optional ground tracks.

There are three columns, one for each object. Click on an Option menu then slide and release 
over the desired object. The list will always contain the major Planets, Sun and Moon, as well as 
the three User Defined Objects, known as ObjX, Y, Z, if they are defined (see Main -> Data -> 
ObjXYZ for more information, §13.3  ).

Several controls and information values are available for each object as follows:

    Display:

        This controls whether the selected object is shown at all. If it is visible, the object is drawn 
with a bulls eye pattern. Each circle of the bulls eye indicates the locus of points where 
the object appears in the sky 0, 30, 60 and 90 degrees from the zenith.

    Label:

        This controls whether the name of the object is drawn above it current location.
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    Trail:

        This control will bring up a window to define a ground track of the given object as it 
travels along its orbit. Each trail time is drawn connected with a solid line with each point 
indicated with a small mark. The time stamps shown with the trail, if any, are always in 
UTC.

        Once a trail is defined, this toggle just turns the trail On or Off on the display. It will not 
bring up the Trail window again unless the trail gets deleted.

        The trail will be deleted if the object is changed, or an Update occurs from the Main 
window while this toggle is Off. Creating a new trail will also delete the old one.

        See the Help from the trail setup window itself for more details on how it operates.

    Center:

        As long as this toggle is On, the given object will remain centered in the display (to the 
extent possible). Only one object may be in control at a time. When all of these toggles 
are Off, the Earth view will remain fixed unless changed manually (via the Scales on the 
edges, setting from Main, or using the Mouse controls). This toggle is automatically 
turned off if any of these manual methods are used.

    Popup obj:

        This toggle selects the object to which the Button-3 popup’s Alt/Az info refers, as seen 
from the current Main menu position.

    SubLat:
    SubLong:

        The latitude and longitude of the ray connecting the object with the center of the Earth. 
These values are shown for all types of objects.

The following data are only available for Earth satellites:

    Alt:

        Height above sea level.

    Range:

        Distance from the Main location to the given satellite.

    Range Rate:

        The rate of change of the Range distance, with positive moving towards the Main 
location.

    Sun lit:

        1 if the given satellite is currently in sun light, else 0 if it is eclipsed.
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    Age:

        The difference between the current XEphem Main time and the epoch of the TLE orbital 
elements, in days. The larger this value, the more the satellite location will be in error. 
Errors depend on drag, maneuvers and initial state vector quality.

Each of these values may be used for plotting, solving and listing in the usual way (see the help 
items for these features). While looping with Pause set to 0, only the graphical display is updated 
(though numeric information is always updated internally each step).

If a User Defined object is set elsewhere in XEphem and an unused column is available it will 
automatically be selected and Center will be activated as a convenience.

5.3  View menu

    Cylindrical
    Spherical
    Weather map

        These radio buttons select from several possible Earth projections.

        Cylindrical: Displays the entire Earth surface projected onto a cylinder. Primary 
advantage is the entire surface is visible at once. Particularly good for plotting satellite 
ground tracks. Major disadvantage is distortion near the poles.

        Spherical: Displays the Earth as it would really appear from space. The primary 
advantage is the sense of reality and lack of distortion.

        Weather map: Displays a global montage of satellite cloud imagery, ice, sea and land 
temperatures, courtesy Space Science and Engineering Center at the University of 
Wisconsin. The image is a gif file retrieved from 
http://www.ssec.wisc.edu/data/comp/latest_cmoll.gif. It is updated once 
every six hours. All other graphical features of the Earth view remain available as 
overlays to this image. Primary advantage is ease in determining whether weather will 
effect visibility of a satellite pass. If you have trouble accessing the image directly from 
XEphem, the program will also use the file /tmp/latest_cmoll.gif if it exists.

        The preferred width-to-height ratio for the cylindrical projection is 3.14:1. This ratio is 
enforced each time this projection is selected by changing the width and maintaining the 
current window height, subject to remaining fully on screen. Similarly, the spherical 
projection resizes to become a square by setting the  width equal to the height. The 
weather map forces itself to become 640x480 pixels. After any projection is selected, the 
window size may be directly manipulated manually from then on as desired.

    Reload map

        This button is only present when the Weather map projection is enabled. Pressing it will 
cause a fresh weather map to be retrieved.

  

    Grid:

        This toggles showing grids lines every 15 degrees in latitude and longitude.
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    Sites:

        This toggles whether a tiny square will be drawn at each location found in the currently 
loaded Sites file.

    Sunlight:

        This toggles whether the portion of the Earth’s surface currently in sun light is highlighted 
in some fashion. When using the Weather map projection, the map is darkened where 
the Sun is currently down, and only cloud cover and continent outlines are shown.

    Live dragging:

        This toggles whether the display graphics are updated immediately as the sliders are 
moved, or whether graphics are only drawn after the sliders are released. Also, if this 
option is on, moving the mouse while holding down the middle button will cause the 
display to rotate about the pole when moved left-and-right or about a horizontal line 
centered on the window when moved up-and-down. If your system is sufficiently fast, the 
effect in quite dramatic. 
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6  Mars view

This window displays an image of Mars as it currently appears from Earth center. The resolution 
is 2/3 degree per pixel. The orientation is always parallel to the Martian rotation axis. The NSEW 
markings are directions on the celestial sphere.

6.1  Mouse functions

Left Button:

    If the View->More Info window is open, then moving the mouse around over the image 
while holding the left button will display the Martian latitude and longitude under the 
cursor location.

    A magnifying glass also appears attached to the cursor.

Right Button:

    Pressing the right button while over the planet will present a popup menu. Sliding down 
and releasing on the Point button in the popup will reposition the view so the current 
location is centered. This will also disable the shadow and the subearth marker until the 
next Update from the Main window. If over a feature, the popup will also contain its name, 
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type, diameter (or largest dimension) and location. If not over a feature, the cursor 
location is shown.

6.2  Control menu

    Print...

        This selection allows printing the current Mars view or saving it as a Postscript file  (§14  
).

    Close

        This selection will remove the Mars view from the screen. If it is open it will also remove 
the More Info window. 

6.3  View menu
    Flip T/B

        This sets whether the image is flipped top-to-bottom.

    Flip L/R

        This sets whether the image is flipped left-to-right.

    Grid

        This sets whether a coordinate grid is drawn over the image. Each line is spaced at an 
interval of 15 degrees. Also, unless the image has been repositioned by hand, an X 
marks the center of the image, that is, the subearth location.

    Features...

        

This brings up a separate window containing categories of surface features. Buttons 
across the bottom allow turning all features on, off or toggling. Apply puts the choices 
into effect, as will Ok which also closes the window.
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    More info...

        This brings up a separate window with additional Mars information and control 
capabilities. Please see the help from that window for more information.

    Moon view...

        This brings up a separate window which depicts the two Martian moons. Please see the 
help from that window for more information. 

6.3.1  More info dialog

The top portion of this window reports the location of the cursor as it is moved over the image, if 
the left button is pressed.

The lower portion of this window shows the Martian latitude and longitude which currently face 
the Earth. These values are computed each time an Update is performed from the Main Menu.

Also provided is a scale by which you may set the size of your local seeing disk. The image will 
be blurred to roughly simulate the resolution under those conditions. The computing time will 
increase with larger seeing values.

For browsing purposes, the values may be changed as desired. Adjust any or all scales, then 
press Apply to put the changes into effect. Forcing changes in this way will also temporarily 
disable the shadow. At the time of the next Update, the correct current values and the shadow will 
be reinstated. The Apply button is made insensitive if the scale values are correct for the current 
time; the button becomes sensitive only when the scales have been moved manually.

The values in the lower portion may be used for plotting, listing and solving in the usual way as 
described in the Help entries for these Control options from the Main window. The values are 
always current when used in this way, even if the main Mars view is closed. For faster looping, 
close the main Mars display to prevent it from being redrawn each time.

6.3.2  Moon info dialog
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This is a schematic view of Mars and its moons at the indicated date and time. In addition, 
background sky objects may also be displayed.

The scale at the left controls relative magnification.

The scale at the right controls the dimmest magnitude which will be displayed. Mars is always 
displayed. The values range from 20 at the top and 0 at the bottom. Objects dimmer than the 
value specified are not shown.

Nominal celestial directions are indicated at the top and right edges.

Moons are displayed only if they are geometrically visible. Use the top view to see whether they 
are also in sun light. 

6.3.2.1  Mouse functions

The mouse may be used to identify any object in the Mars view. Position the cursor near the 
object of interest and select the right mouse button. A popup menu will appear with the objects 
name, current location and magnitude.

6.3.2.2  Control menu

    Field Stars...

        This selection activates the Field Star setup window. For more information about this 
facility, see the Help for the Field Star window itself.

    Telescope command:

        This option causes the location of Mars to be sent to a fifo. The intent is for the fifo to be 
connected to a telescope control process.

        This mechanism is the same as that provided by the Telescope facility within the Sky 
view. Please refer to its help for more details in §10.6  .

    Movie Demo:
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        This option will set up the Main window time step controls for a 15 minute step size and 
start a loop which dramatically displays the motions of the moons as they orbit Mars. This 
selection automatically disables the View->Sky Background selection to insure 
reasonable speed. Push the button again to stop the movie.

    Close:

        This removes the Mars moon display, and the additional information window if present, 
from the screen. 

6.3.2.3  View menu

    Top view:

        Selects whether to also display another window, looking down on the Mars system from 
above the N celestial pole. This window will tend to remain aligned above the main view 
when either is resized. Moons are displayed only if they are in sun light.

    Sky background:

        Selects whether to also show objects within the current field of view that are in the 
XEphem database memory or available from the Field Star facility. The size of the object 
is determined by the limiting magnitude as specified by the scale at the right. Objects are 
drawn using the same symbols as used by the Sky view. While this option is on, XEphem 
will continue to retrieve field stars as required.

    Bright moons:

        If this option is in effect, then the diameter of all moons will be increased by 3 pixels. This 
option also insures that even those moons which are dimmer than the limiting magnitude, 
as specified by the scale to the right, will be drawn with a circle of diameter 3 pixels.

    Tags:

        Search whether to show the Roman numeral designation beneath each moon and a 1 
arc-minute scale calibration line.

    Flip T/B:
    Flip L/R:

        These allow the scene to be flipped vertically and horizontally, respectively. 
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6.3.2.4  More info dialog

This button brings up a separate window which contains quantitative information about Mars’s 
moons. All values may be used in plotting, listing and solving.

The E and S columns are 1 if the moon is visible from the Earth and Sun, respectively.

The locations of the moons are given in two coordinate systems. The first three columns are the 
displacements of the moons in Mars radii with respect to the celestial plane. The next two 
columns give the RA and Dec location of the moons in the current epoch (as specified on the 
Main window). 
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7  Jupiter view

This is a view of Jupiter and its Galilean moons at the indicated date and time. In addition, 
background sky objects may also be displayed.

The scale at the left controls relative magnification.

The scale at the right controls the dimmest magnitude which will be displayed. Jupiter is always 
displayed. The values range from 20 at the top and 0 at the bottom. Objects dimmer than the 
value specified are not shown.

Equatorial directions are indicated at the top and right edges.

Moons are displayed only if they are geometrically visible from Earth. Use the top view to see 
whether they are also in sun light.

The default longitude of the GRS is set to 61 degrees, where it was in late May of 1997. This may 
be changed interactively in the More Info window.  
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7.1  Mouse functions

The mouse may be used to identify any object in the Jupiter view. Position the cursor near the 
object of interest and select the right mouse button. A popup menu will appear with the objects 
name, current location and magnitude.

7.2  Control menu
    Print ...

This selection allows printing the current Jupiter view or saving it to a file.

    Field Stars...

        This selection activates the Field Star setup window. For more information about this 
facility, see the Help for the Field Star window itself )§13.4  ).

    Telescope command:

        This option causes the location of Jupiter to be sent to a fifo. The intent is for the fifo to 
be connected to a telescope control process.

        This mechanism is the same as that provided by the Telescope facility within the Sky 
view. Please refer to its help for more details in § 10.6  .

    Movie Demo:

        This option will set up the time step controls in the Main window for a 15 minute step size 
and start a loop which dramatically displays the motions of the moons as they orbit 
Jupiter. This selection automatically disables the View->Sky Background selection to 
insure reasonable speed. Push the button again to stop the movie.

    Close:

        This removes the Jupiter display, and the additional information window if present, from 
the screen. 

7.3  View menu

    Top view:

        Selects whether to display another window located over the pole that is on top in the front 
view. This window will try to remain aligned above the main view when either is resized. 
Moons are displayed only if they are in sun light.

    Sky background:

        Selects whether to also show objects within the current field of view that are in the 
XEphem database memory or available from the Field Star facility. The size of the object 
is determined by the limiting magnitude as specified by the scale at the right. Objects are 
drawn using the same symbols as used by the Sky view. While this option is on, XEphem 
will continue to retrieve field stars as required.

    Bright moons:
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        If this option is in effect, then the diameter of all moons will be increased by 3 pixels. This 
option also insures that even those moons which are dimmer than the limiting magnitude, 
as specified by the scale to the right, will be drawn with a circle of diameter 3 pixels.

    Tags:

        Search whether to show the Roman numeral designation beneath each moon and a 1 
arc-minute scale calibration line.

    Flip T/B:
    Flip L/R:

        These allow the scene to be flipped vertically and horizontally, respectively.

7.3.1  More info dialog

This button brings up a separate window which contains quantitative information about Jupiter’s 
moons and central meridian longitude. All values may be used in plotting, listing and solving.

The E and S columns are 1 if the moon is visible from the Earth and Sun, respectively.

The locations of the moons are given in two coordinate systems. The first three columns are the 
displacements of the moons in Jupiter radii with respect to the celestial plane. The next two 
columns give the RA and Dec location of the moons in the current equinox (as specified on the 
Main window).

Value of the System II longitude of the Great Red Spot is displayed. The value may be changed 
according to current information. Pressing Enter will update the Jupiter display with the new 
value.
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8  Saturn view

This is a schematic view of Saturn, its rings and moons at the indicated date and time. In addition, 
background sky objects may also be displayed.

The scale at the left controls relative magnification.

The scale at the right controls the dimmest magnitude which will be displayed. Saturn and its 
rings are always displayed. The values range from 20 at the top and 0 at the bottom. Objects 
dimmer than the value specified are not shown.

Nominal celestial directions are indicated at the top and right edges.

Moons are displayed only if they are geometrically visible. Use the top view to see whether they 
are also in sun light.  
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8.1  Mouse functions

The mouse may be used to identify any object in the Saturn view. Position the cursor near the 
object of interest and select the right mouse button. A popup menu will appear with the objects 
name, current location and magnitude.

8.2  Control menu

    Print ...

This selection allows printing the current Jupiter view or saving it to a file.

    Field Stars...

        This selection activates the Field Star setup window. For more information about this 
facility, see the Help for the Field Star window itself (§13.4  ).

    Telescope command:

        This option causes the location of Saturn to be sent to a fifo. The intent is for the fifo to be 
connected to a telescope control process.

        This mechanism is the same as that provided by the Telescope facility within the Sky 
view. Please refer to its help for more details in §10.6  .

    Movie Demo:

        This option will set up the time step controls in the Main window for a 15 minute step size 
and start a loop which dramatically displays the motions of the moons as they orbit 
Saturn. This selection automatically disables the View->Sky Background selection to 
insure reasonable speed. Push the button again to stop the movie.

    Close:

        This removes the Saturn display, and the additional information window if present, from 
the screen. 
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8.3  View menu

    Top view:

        Selects whether to also display another window, looking down on the Saturnian system 
from above the celestial N pole. This window will tend to remain aligned above the main 
view when either is resized. Moons are displayed only if they are in sun light.

    Sky background:

        Selects whether to also show objects within the current field of view that are in the 
XEphem database memory or available from the Field Star facility. The size of the object 
is determined by the limiting magnitude as specified by the scale at the right. Objects are 
drawn using the same symbols as used by the Sky view. While this option is on, XEphem 
will continue to retrieve field stars as required.

    Bright moons:

       If this option is in effect, then the diameter of all moons will be increased by 3 pixels. This 
option also insures that even those moons which are dimmer than the limiting magnitude, 
as specified by the scale to the right, will be drawn with a circle of diameter 3 pixels.

    Tags:

        Selects whether to show the Roman numeral designation beneath each moon and a 1 
arc-minute scale calibration line.

    Flip T/B:
    Flip L/R:

        These allow the scene to be flipped vertically and horizontally, respectively. 

8.3.1  More info dialog

This button brings up a separate window which contains quantitative information about Saturn’s 
moons and its rings. All values may be used in plotting, listing and solving.

The E and S columns are 1 if the moon is visible from the Earth and Sun, respectively.
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The ring tilt is displayed as the angle above or below the line of sight to Saturn from the Sun and 
the Earth. A positive value means the front of the rings are tilted southward.

The locations of the moons are given in two coordinate systems. The first three columns are the 
displacements of the moons in Saturn radii with respect to the celestial plane. The next two 
columns give the RA and Dec location of the moons in the current equinox (as specified on the 
Main window). 
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9  Uranus view

This is a schematic view of Uranus and its moons at the indicated date and time. In addition, 
background sky objects may also be displayed. 

The scale at the left controls relative magnification. 

The scale at the right controls the dimmest magnitude which will be displayed. Uranus is always 
displayed. The values range from 20 at the top and 0 at the bottom. Objects dimmer than the 
value specified are not shown.  

Nominal celestial directions are indicated at the top and right edges. 

Moons are displayed only if they are geometrically visible. Use the top view to see whether they 
are also in sun light.
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9.1  Mouse functions

The mouse may be used to identify any object in the Uranus view. Position the cursor near the 
object of interest and select the right mouse button. A popup menu will appear with the objects 
name, current location and magnitude. 

9.2  Control menu

    Print ...

This selection allows printing the current Jupiter view or saving it to a file.

    Field Stars...

        This selection activates the Field Star setup window. For more information about this 
facility, see the Help for the Field Star window itself (§13.4  ).

    Telescope command:

        This option causes the location of Uranus to be sent to a fifo. The intent is for the fifo to 
be connected to a telescope control process.

        This mechanism is the same as that provided by the Telescope facility within the Sky 
view. Please refer to its help for more details in §10.6  .

    Movie Demo:

        This option will set up the Main window time step controls for a 15 minute step size and 
start a loop which dramatically displays the motions of the moons as they orbit Uranus. 
This selection automatically disables the View->Sky Background selection to insure 
reasonable speed. Push the button again to stop the movie.

    Close:

        This removes the Uranus display, and the additional information window if present, from 
the screen. 

9.3  View menu

    Top view:

        Selects whether to also display another window, looking down on the Uranus system 
from above the N celestial pole. This window will tend to remain aligned above the main 
view when either is resized. Moons are displayed only if they are in sun light.

    Sky background:

       Selects whether to also show objects within the current field of view that are in the 
XEphem database memory or available from the Field Star facility. The size of the object 
is determined by the limiting magnitude as specified by the scale at the right. Objects are 
drawn using the same symbols as used by the Sky view. While this option is on, XEphem 
will continue to retrieve field stars as required.
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    Bright moons:

        If this option is in effect, then the diameter of all moons will be increased by 3 pixels. This 
option also insures that even those moons which are dimmer than the limiting magnitude, 
as specified by the scale to the right, will be drawn with a circle of diameter 3 pixels.

    Tags:

        Search whether to show the Roman numeral designation beneath each moon and a 1 
arc-minute scale calibration line.

    Flip T/B:
    Flip L/R:

        These allow the scene to be flipped vertically and horizontally, respectively. 

9.3.1  More info dialog

This button brings up a separate dialog which contains quantitative information about Uranus’s 
moons. All values may be used in plotting, listing and solving. 

The E and S columns are 1 if the moon is visible from the Earth and Sun, respectively. 

The locations of the moons are given in two coordinate systems. The first three columns are the 
displacements of the moons in Uranus radii with respect to the celestial plane. The next two 
columns give the RA and Dec location of the moons in the current equinox (as specified on the 
Main menu).
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10  Sky view

This window presents a schematic representation of the sky showing database objects and useful 
auxiliary information. A FITS file image can also be displayed simultaneously.

The dominant center area displays each object that meets the brightness and type filter selection 
criteria. A menu bar across the top offers access to all functions. Fast access to certain functions 
are available from the surrounding toolbars.

The mouse buttons can be used inside the display area for additional functionality specific to the 
exact location of the cursor when clicked.

Complete details on each control are found in the specific Help choices.

Note that while looping with Pause set to 0 the Sky View is not updated (although all quantitative 
information is always updated internally each step). This is to permit creating plots and using 
other XEphem features that use many time increments to run much more quickly if the Sky View 
is unmanaged or with Pause set to 0. 
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10.1  Toolbars

The toolbars are divided into three broad categories.

Down the left are choices that effect How the scene is portrayed, such as coordinate system, 
flipping and magnitude limits. 

Across the top the choices effect What is displayed, such as coordinate grids, local horizon, and 
the classes of celestial objects.

All of the buttons in the Left and Top toolbars are just convenient shortcuts to functions that can 
also be accessed from the Options and Filter windows available in the Sky View Control menu. 
Please read the help for more information about these features.

The button in the upper left corner rather applies to both What and How:

However, the toolbar down the right side is a little different. These buttons share a broad common 
theme of affecting, inspecting and deriving Where objects are located. Some also effect how the 
mouse operates. Because of their relatively complex nature, these toolbar buttons are best 



Display cursor coordinates in corners as mouse roams over display

Zoom in to region of interest (only when ROI is defined)

Zoom back to previous ROI (only when zoomed in at least one level)

Use mouse to draw Region of Interest

Mouse connected to magnifying glass (images only)

Mouse climbs to brightest pixel automatically (images only)

Mouse draws cross sectional slice (images only)

Mouse computes 2D Gaussian fit (images only)

Sky View

Version 3.5.2 Page 10-3

described in their respective context so please see Help -> on Mouse and Image -> Processing 
tools for more information.

10.2  Mouse functions

The mouse serves many purposes in the Sky View. Exactly what it does at any one time depends 
on whether it is located over an object and on the states of some of the toolbar buttons.

Idle:

Generally nothing happens when the mouse is over the Sky View and no buttons are being 
pressed. However, if the Roaming report toolbar button is On (upper right), basic data describing 
the position of the cursor are displayed in the upper corners whenever the cursor is over the Sky, 
even when no buttons are pressed. These data include:

        Upper left corner:

      RA, Dec and Hour angle equatorial coordinates;

      the great-circle distance between the current position and the point at which the left 
button was last depressed;

        constellation name;

raw image pixel coordinates, if displaying FITS image.
N.B. FITS coords are XEphem + 1

        Upper right corner:

       Alt, Az and Zenith distance horizon coordinates;

        the volume and page number in the Uranometria, Uranometria 2000 and Millennium star 
catalogs.

NOTE 1: The coordinates are derived directly from the screen location and know nothing of the 
displayed objects. Thus, they neglect parallax (i.e., assume everything is at infinity).

NOTE 2: If the Telescope Marker is active and a telescope control process is reporting telescope 
position information, then when the cursor is outside the Sky View the data in the corners refer to 
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the telescope marker position, not the cursor position. This information is not displayed if any 
keyboard keys or mouse buttons are pressed. 

Left button:

If the Roaming report toolbar button is On and the left mouse button is pressed, then the 
information in the upper left and right corners change into delta information, that is, the changes 
in the various coordinates with respect to the position where the left button was last pressed.

If the ROI toolbar button is On, pressing and dragging the left mouse button draws a Region of 
Interest box. This ROI can serve two roles. One is a way to zoom. Click on the ROI toolbar button 
then click in the Sky View with the left mouse button and begin to draw a box surrounding a 
region of interest. When the button is released, the ROI becomes fixed into position. To perform 
the zoom, press "Zoom In" in the tool bar (the round magnifying glass with a + within). The 
current size, position, and ROI are saved and the Sky View is changed to expand the new area. 
The "Zoom Back" tool bar button (glass with a - within) then becomes available to restore the 
display to its previous size and position. The Zoom In and Zoom Back buttons work as a pair for 
arbitrary levels of undo and redo.

This Zooming is implemented by actually sliding the scales around the edges of the Sky View just 
as if you had done it manually. Thus, the selected area may be rotated after the zoom due to a 
change in perspective in the map projection. This is a feature.
    
The other use for the ROI is available only when an image is being display. Basic statistics are 
computed for the pixels that lie within the ROI box and are displayed in the Images -> Processing 
tools window. See it’s help for details.

Also only while an image is displayed, the left mouse button may be used to position a Magnifying 
glass; graph the pixels along an arbitrary cross sectional slice through the image; and compute 
and display high quality photometric and astrometric information about the star nearest the cursor 
based on 2D Gaussian fitting. All of these are describe more fully in the Help -> on Images 
section.

Middle button:

While the middle button is depressed, the cursor is changed to a fleur pattern. Moving the mouse 
left and right is like moving the scale at the bottom; moving it up and down is like moving the 
scale at the right. This provides a simple method to pan the display. This feature is not yet 
available while displaying an image.

If the "Live dragging" option is turned on (see Control -> Options), the panning occurs 
immediately. If this is painfully slow on your system then turn this off so the screen is only 
redrawn one time when the button is released.

Right button:

If the right button is clicked over the Sky View, then a popup menu will appear. If the button is 
clicked and released, the menu will stay up and can be used like any other menu. Or the button 
may be pressed and held while you slide the cursor to the desired button and let go. Try both and 
use whichever procedure you prefer.
    
The popup contains information and controls germane to the exact position of the cursor when 
the button was clicked. The entries in the popup menu vary depending on whether the cursor was 
near an object or over empty sky. 
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If the cursor is near a object, data is shown which are exactly the same as that which is available 
in the Data Table window; see its Help for more information. If a trailed object is selected, the 
data will be as it was at the time for that position. If the cursor was not near an object, basic 
information based on the location of the cursor itself is shown.

The popup also offers several control operations, as follows. At any one time, only the ones 
relevent to the current situation and toolbar choices will appear.  
 
        Center:

This will change the Sky View pointing direction to place the given object or location at 
the center of the field of view.

        Center + Zoom ->

     This will change the display orientation to place the given object (or location) at the center 
of the field of view and, at the same time, zoom in or out the amount selected in the 
pullright cascade menu.

        Place eyepiece:

      This will cause an eyepiece symbol to be drawn centered under the mouse location. The 
eyepiece shape and size is defined in the Eyepiece Setup window, available via 
Control->Eyepieces (§10.3.7  ).

        Delete eyepiece:

This will delete the closest eyepiece covering this mouse location, if any. The search 
algorithm uses the smaller of the two dimensions of the eyepiece so it may be necessary 
to get close to the center depending on the shape.

        New Photom ref:

This only appears if an image is being displayed, the 2D Gaussian image analysis tool is 
up, and the cursor was clicked near a database object. If all this is so, then said object is 
used as the new reference for photometric comparisons, and the magnitude of the object 
from the database is set as the reference for subsequent use. 

        Telescope GoTo

This will cause the coordinates of the cursor to be sent to a fifo, which is typically 
connected to a telescope control process. The command is not issued if the coordinates 
are below the horizon. This button is only present if the connected process is running. 
See Help -> on Telescope for more information.  

        AAVSO:

    This will search the AAVSO database for the nearest objects and place them in the list of 
the AAVSO tool. See the Help for the AAVSO Tool for more information on downloading 
the light curve (§12.6  ).
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        Assign ->
            to ObjX
            to ObjY
            to ObjZ
            

This cascade allows you to assign the given object to become ObjX, Y or Z, as desired 
(see §13.3  ). This will also cause all other views which are currently making use of this 
object to be updated and the object will be added to and selected by the Data table. Also, 
since this makes the object one of the User-Defined objects it will now appear directly in 
the Sky View->Locate pulldown menu.

        Show in Data Table:

    This option is only offered when the object chosen under the cursor is a planet, the Sun 
or the Moon. Selecting this option forces the object to be enabled in the Data Table.

        Persistent Label ->
            on Left
            on Right

          This cascade will toggle whether a label is drawn on the left or right side of the current 
object. The label will consist of the name and/or the magnitude, depending on which 
options are selected in the SkyView->Options Labeling section. If neither are selected, 
the label will consist of the name.

           Persistent labels are always on, that is, they are not subject to magnitude limits, options, 
or object type filtering.

         Note this option is maintained separately for trailed objects and for the untrailed objects; 
that is, you have independent control over labeling for a trailed object and its currently 
displayed object since the latter also always appears in the trailed list. This can be 
somewhat confusing for trails which begin "Now" since, in effect, the first item is drawn 
twice (once just because it is an object like any other, and again as a member of the set 
of trail history points).

        Track:

   This will toggle object tracking for this object. If a trail object is chosen, the tracking will 
apply to the current position of the object.  See the discussion for the "Tracking" toggle 
button for more details (§10.3  ).

        Trail:

  This toggle is only present if the selected object has a trail defined. If it has a trail, the 
toggle state indicates whether the trail is being displayed. Note that turning off a trail does 
not actually discard the trail until the next Update occurs from the Main window.

        Create Trail (or Change Trail) ...

This pushbutton will bring up a window from which a trail may be defined, computed and 
displayed. The button is labeled "Change Trail" if the selected object already has a 
defined trail. Only one trail per object is supported.

10.3  Control menu
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    Options...

This brings up a window with several choices effecting the way the scene is drawn. It has 
its own Help. 

    Filter...

This allows selecting the types and magnitude ranges of objects to display. This window 
has its own Help.

    Print...

This allows printing the current Sky view or saving it to a file. If an image is currently 
being displayed, it will also be part of the print image. It has its own Help.

    List...

This brings up a window that allows saving the objects currently displayed in the Sky 
View to a file. It has its own Help.  

    Horizon...

This activates the Horizon setup window. To display the Horizon profile, turn on the 
toggle under Option. For more information about this facility, see the Help from the 
Horizon window (§10.3.5  ).

    Field Stars...

This activates the Field Star setup window. To display Field Stars, turn on the toggle 
under Options. For more information about this facility, see the Help from the Field Star 
window itself (13.4  ).

    Eyepieces...

 This brings up a window which allows you to specify the shape, size and style of the next 
eyepiece to be created. It has its own help. Whether eyepieces are shown at all is 
controlled by the Control->Options->Eyepieces option (§10.3.7  ).

    Coordinates...

This brings up a simple dialog which allows you to type in (or copy/paste) and convert 
among several common coordinate systems used in astronomy. A position defined in any 
of the coordinate systems can also be mark on the Sky View, which will be repositioned 
automatically if the position is not in the current field of view.

    Tracking:

Tracking here refers to "object tracking" and means that the pointing direction of the 
display will automatically be changed each time an Update occurs from the Main window 
such that the tracked object will remain centered on the display. The object to be tracked 
is selected by using the "Track" option in its popup menu, as described earlier.

When this toggle button is sensitive and pushed-in it means that tracking is active for one 
object. The tracked object will be marked with an "X" on the display after each Update. If 
this toggle button is selected while it is sensitive, it turns tracking off. This is a convenient 
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alternate method to turn off object tracking without having to find the exact object being 
tracked and use its popup Track control.

When this toggle button is insensitive and popped-out, it means that object tracking is not 
active; it does nothing when selected while insensitive.

    Close:

        This causes the Sky view and all supporting windows to go away.

10.3.1  Options...
This is a description of the controls in the Sky Options window.

Note that some of these options are also available via the tool bars across the top and down the 
side of the Sky View. The top tool bar offers shortcuts to "What" is being displayed such as grid 
overlay, annotation, galaxies; the one down the left controls "How" it is displayed, such as 
brightness, display mode, flipping. To learn what each icon in the tool bars does, use 
Help->Context from the Main window and move the cursor over each icon to cause it to display its 
help tip bubble.
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Display mode

    Alt-Az:
    RA-Dec:

        This radio box selects whether the display coordinate system is Altitude-Azimuth or Right 
Ascension-Declination.

        NOTE: While in Alt/Az mode the display is always topocentric; while in RA/Dec mode the 
display coordinate system depends on the Equatorial preference and Equinox settings in 
the Main window.

    Sphere:
    Cylinder:

        This radio box selects whether the display is projected onto a sphere on a cylinder. The 
advantage of the sphere is that it mimics the real sky. The advantage of the cylinder is it 
shows the entire universe at once. 

Grid Control

        This group of controls allows you to specify the details of an overlay coordinate grid. Grid 
itself toggles the grid on or off.

       If Auto is on, then the size of the grid steps will be determined automatically and shown 
in the text fields beneath; if it is off, then step sizes are determined from the values in the 
text fields. Typing into either field then pressing Enter will also turn off Auto and 
immediately display the grid with the new step size.

       Alt-Az and RA-Dec selects in which coordinate system the grid will be drawn.

        Label selects whether the grid will be labeled.

View Options

    Just dots:

        This toggle effects how stars are shown.

        When the toggle is pushed in, all stars are displayed simply as dots of various sizes.

        When the toggle is released, each type of star is displayed with a unique schematic 
symbol. These symbols may be reviewed from the Filter window.

        In either case, the diameter of the symbol shown is the larger of the object’s actual size at 
the current window scale (if a size is specified in the database entry for the object) or a 
size that is proportional to the difference between the object’s magnitude and the current 
faintest magnitude setting.

        This means that, at suitably small fields of view, the Sun and Moon are shown to scale.  
This is ideal for watching solar eclipses or occultations. For example, watch the solar 
eclipse over Hawaii by setting the date to July 11, 1991, time to 17:00 UTC, location to 
Latitude 19:50 Longitude 155:28, and starting a loop with a Step of 1:00 and Pause 1. Be 
sure to use the Alt-Az display mode to get topocentric positions or set the Main 
Preferences for Equatorial to Topocentric. It is also very handy to set to Track either the 
Sun or the Moon (whichever you wish to be centered during the movie).
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    Flip Left/Right:
    Flip Top/Bottom:

        These toggle whether the display is shown with a flip in the left/right or the top/bottom 
directions, respectively.

    Equatorial plane:

        This toggle selects whether a red 3:6 dashed line is shown along the Earth’s equator 
projected onto the celestial sphere.

        
    Ecliptic plane:

        This toggle selects whether a red 2:2 dotted line is shown along the ecliptic. The ecliptic 
is the plane of the Earth’s orbit or, as seen from Earth, the path of the Sun and the 
approximate path of the planets across the sky. The anti-solar point is marked with a 
small open circle. The edges of umbra/penumbra of Earth are marked with open circles. 
If Preferences->Equatorial is set to Topocentric, the umbra/penumbra are projected at the 
current distance of the Moon and corrected for parallax; if set to Geocentric they are 
projected at infinity.

    Galactic plane:

This toggle selects whether a red 1:4 dotted line is shown along the galactic equator and 
small labeled +’s are placed at the North and South galactic poles.

    Eyepieces:

        This toggle selects whether eyepieces are drawn on the Sky view, if and when any are 
placed. Eyepieces are placed on the Sky view by using the Place eyepiece control in the 
popup menu activated by the right mouse button. The shape and style of eyepieces is 
defined in the Control->Eyepieces window (§10.3.7  ). Eyepieces are only drawn if they fit 
entirely within the Sky View. This selection is automatically activated when an eyepiece is 
placed.

    Magnitude key:

        This toggles whether to display a chart in the lower left corner showing the 
correspondence between dot size and star magnitude. The scale is automatically turned 
off each time an image is first displayed.

    Auto magnitude:

        When this toggle is active, the faintest magnitudes and dot step size will automatically be 
set to something reasonable based on the field of view. This option is automatically 
turned on whenever the FOV changes for any reason, unless it was turned off manually.

    Field Stars:

        This toggles whether field stars are automatically loaded and displayed if the position, 
field of view, limiting magnitude or time changes significantly.

        This selection turns itself off if any difficulties ever arise in retrieving field stars.

        See Control -> Field Stars -> Help for more info about field stars (§13.4  ).
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    Live dragging:

        This toggle button selects whether the graphics are redrawn in real time as the various 
scale controls are being slid, or whether the graphics are not redrawn until the mouse is 
released. The decision depends on the speed of the computer, display and data 
bandwidth. If the system is fast enough, turning this on can produce dramatic results.

    Horizon map:

        This controls whether to overlay the local horizon profile on the Sky View and, when in 
Cylindrical + Alt-Az mode, whether objects below the horizon are drawn. The profile is 
drawn at azimuth steps of 1 degree.

        See Options -> Horizon -> Help for more information (§10.3.5  ).

Constellation

    Boundaries:

        This toggle controls whether constellation boundaries are shown.

    Figures:

        This toggle controls whether constellation figures are shown.

    Full Names:

        This toggle controls whether full constellation names are shown. The names will be 
centered within the extent of the constellation figure. This control and Abbreviations can 
not be both on at once.

    Abbreviations:

        This toggle controls whether abbreviated constellation names are shown. The names will 
be centered within the extent of the constellation figure. This control and Full Names can 
not be both on at once. 

Labeling

        This portion controls labeling options. The three sliders select how many of the brightest 
objects to label in each of three categories. The label itself may consist of the Name or 
Magnitude or both, depending on which of the two buttons are depressed adjacent to 
each scale. If Names and Magnitudes are both enabled then the magnitudes are shown 
to the right of the name surrounded by parentheses. Magnitudes are shown to the 
nearest 1/10 with the decimal point removed.

        Other labeling facts:

   Trailed entries do not contribute towards the brightest count.

   The Persistent Label option for individual objects is never disabled.

    Greek characters are used in Bayer names when YBS.edb is loaded (§13.1  ).
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10.3.2  Filter... 

This window lists all classes of objects supported by XEphem. Using the Filter window, one may 
select which classes of objects are displayed on the Sky view window.

For reference, the Filter window also contains the schematic symbol for each type of object, and 
its code when used in a database file. The symbol displayed for each class of object is that which 
will be used to represent the object in the Sky view, unless "Just dots" is selected.

Three scales near the bottom of the Filter window control the faintest magnitude limit to be 
displayed for Stars, Solar system and Deep sky objects. Note that trails and persistent labels are 
not subject to the faint magnitude limits.

The fourth scale in the lower left selects the number of magnitudes binned in each dot size.

Several push buttons appear across the bottom of the Filter window which have the obvious 
effects: Selecting Apply updates the sky display according to the desired selection. Selecting Ok 
does the same thing but also closes the Filter window. All turns on all types. Toggle toggles each 
filter type.

10.3.3  Print...

This selection allows printing the current Sky view or saving it to a file. If an image is currently 
being displayed, it will also be part of the print image. It has its own Help (§14  ). 
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10.3.4  List... 

This window lists, sorts and allows saving the objects currently displayed in the Sky View to a file.

Basing the list on the Sky View means the selection criteria uses the power of the Options and 
Filters controls as well as the region of the sky as defined by the center and field of view. If you 
wish to include all objects without regard to position, use the Cylindrical project mode, set 
RA-Dec, FOV 180, Dec 0 and resize the Sky View window to show the entire universe.

At the top, the format of the file created may be specified in either of two formats.

The .edb format saves the objects in the XEphem catalog format.  This is handy for using 
the XEphem filtering options to create custom catalogs.

The text format is a columnar listing. The columns that are printed are the same as those 
currently selected in the Data Table, printed to the precision specified in the Preferences. 
A convenient button is provided to bring up the Date Table setup window. Note that a 
column need not be printed to be used for sorting, although it would seem unusual to do 
so.

The center section lists several fields that may used for sorting the list. Pick each field in the order 
you wish to sort the list. If you wish to make a change to the order, you may Undo one at a time 
back to the beginning or Clear the entire sequence and begin again.

The bottom section is a text field which (will) show the results of the sort. This text field is fully 
editable, so you may delete specific objects, add comments and so on as desired. N.B. If you 
have chosen the .edb format, no checks are made that your edits have made the format illegal.
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Pressing the right mouse button over the text field will bring up a popup menu, if a valid object 
name is found at the beginning of the line under the cursor. This popup has buttons to Delete the 
object on the current line from the list and Mark the object on the Sky View.

Across the bottom are several controls:

    Save

        This writes the text field exactly as it now appears to the file named at the right of the 
format checked at the top.

        N.B. No check is made that the format and the extension agree.

    Sort

  This rebuilds the list according to the current settings. Use this after changing something 
in the Sky View, or after changing the format or sort settings here.

    Close

       Closes this window.

    Help

        Shows this help. 

10.3.5  Horizon...

XEphem allows you to choose between two ways to display your local horizon.

One way, the simplest, is to define one altitude that will be used at all azimuths. To use this 
method, type the desired altitude in the field provided, then press Enter or toggle the button On.

The other is to create a file containing a table of the altitude and azimuth around your entire 
horizon. To use this method, type the name of the file containing the table in the text field 
provided, then press Enter or toggle the button On. The Browse button will bring up a File 
Selection Dialog for convenient interactive selection of available files if desired. This is handy if 
you find yourself setting XEphem to one of several different Sites and you have a horizon table 
prepared for each.  

The Horizon profile file format (suffix .hzn) and its use by XEphem are defined as follows:
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    Each line should contain exactly two numbers separated by spaces. The first 
number is the azimuth, expressed as degrees East of North. The second number 
is degrees above horizontal. Lines of any other form are ignored.

    The azimuth ranges from 0 up to 360 degrees. Any values outside this range 
have 360 added or subtracted until they fall in this range.

    The lines need not be sorted by Azimuth, although they will be sorted when used; 
thus the horizon map can never cross itself.

    If the file does not include the full range of Azimuths, the end points will be 
connected automatically.

    It is ok to specify just one point (at any Azimuth). This will result in a flat horizon 
all the way around at the specified Altitude. (This is functionally equivalent to 
using the Fixed Displacement method).

    Values in between those in the file are computed by linearly interpolating the two 
nearest surrounding points.

For example:

    0   10

    20  15

    50  25

    100 20

    180 25

    182 45

    185 10

    300 15

10.3.6  Field Stars...

This selection activates the Field Star setup dialog. For more information about this facility, see 
the Help for the Field Star dialog itself (13.4  ).
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10.3.7  Eyepieces...

This window allows you to specify the shape, size and style of the next eyepiece marker to be 
placed in the Sky View. These markers are useful to show the view through your eyepiece, 
simulate the view of a CCD camera, or as simple annotation markers for any desired purpose. 
Symbology on the map will show through the eyepieces, even when they are specified as solid. 

Note that this window controls the style of the next eyepiece to be created. To actually create an 
eyepiece, place the mouse over the Sky view where you want the center to be located and press 
the right button. A popup menu will appear. Slide down the menu and release over "Place 
eyepiece". See below for how to delete eyepieces.

Across the top are two sliders which set the width and height of the next eyepiece. These are 
shown in units of degrees:minutes. Below them is a toggle that will lock the two sliders so they 
move together. This is to make it easy to create eyepiece shapes that are perfectly round or 
square.

As a special convenience, there is a toggle which will create three open circles spaced to match 
the view through the venerable Telrad unit power finder. The circles are 0.5, 2 and 4 degrees in 
diameter. As long as this special toggle is pushed in, the other controls are made insensitive to 
avoid  interfering with the preset values for the Telrad.

Next below are pairs of toggle buttons to select the Shape and Style of the next eyepiece. 
Elliptical and Rectangular refer to circles and squares. Solid and Outline refer to whether the 
shape will be filled in or just drawn as a border.

In the central portion of the Eyepiece window is a calculator that can be used to compute the sky 
angle of an optical system in two ways. The first method uses the net focal length of the entire 
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optical system and a linear size on the focal plane. The technique is handy for CCD users who 
want to find the sky angle subtended by each pixel. Another good use of this form is for 
photographers using film to find the amount of sky that will fit on their film. To cover this wide 
range of applications, the measures may be specified in any of several common units by adding 
the appropriate suffix. Default units are shown in parentheses.

The second method uses the apparent field of view while looking into an eyepiece and divides 
this by the magnification, which in turn is found from the ratio of focal lengths for the primary 
mirror and the eyepiece. Typical eyepieces provide about 45 degrees apparent fields of view, and 
some premium ones can go to 60 degrees or more.

After using either method, the resulting sky angle can be assigned to the width or height scale for 
the next eyepiece by using the Set W and H buttons to the right.

The bottom portion of the Eyepieces window allows you to save your most often used size, shape 
and style combinations. When these values are set as desired, press Add and they will be added 
as a new entry to the list. A simple name is chosen automatically but of course you can change 
this to be more meaningful to you. Each eyepiece may be deleted or put to use by using the 
buttons on the left.

To delete an eyepiece off the Sky View, place the cursor near it, press and hold the right mouse 
button, slide down and release on Delete eyepiece. After at least one eyepiece has been placed 
in the Sky View, a button at the bottom of this window will become available to erase all 
eyepieces from the Sky View. This is permanent. If you just want to temporarily turn all Eyepieces 
off and on use the Eyepieces option in the Control -> Options window.

Across the bottom are buttons to Close the window and get more information. Closing the window 
has no effect on existing eyepieces.

10.3.8  Coordinates...

This is a handy means to bring up the Main Tools -> Coordinate converter. Please see its own 
help for full details (§12.8  ).

10.3.9  Tracking

Please see the description for this button in the discussion for the Sky View Control menu (§10.3  
).

10.3.10  Close

This causes the Sky view and all supporting dialogs to go away.
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10.4  Images Menu

This menu controls Sky View’s image display capabilities.

10.4.1  Load and Save

This window allows you to display a FITS file in the Sky View window. You may display local files 
or download the Digital Sky Survey directly from the Internet. The image is resized to match the 
size of the Sky View window.                                                                      

Once an image is displayed, all graphical features of the Sky View are available, such as grids 
and labeling objects loaded in the XEphem database. Most of these features require that WCS 
headers be present in the image. XEphem can help create these using the Images -> WCS 
Solver tool.

This window contains several sections. Each is described below. Also notice the tiny square box 
just to the lower right of the FITS Header box. This is a pane control with which you may adjust 
the proportion of window real estate used by the FITS box. Of course, you can also increase the 
total size of the window as well. 

Get

This button heads up the section for downloading images from the Net. You may choose DSS 
generations 1 and 2, and either Red or Blue filters for the latter.
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The DSS is maintained by the Space Telescope Science Institute, STScI, in the United States or 
the European Southern Observatory, ESO, research facility in Germany. The image data from 
either site is identical, so choosing which to use depends only on availability and whichever is 
faster for you. The size and position of the image are that of the current Sky View settings, but the 
size limited to 30 arc minutes by agreement with each institution.

Before attempting a download, use the File -> Network setup window off the Main menubar to 
configure your Internet connection.

Pressing Get will begin the download. A progress meter will display remaining time. A Stop 
window is provided if you care to abandon the effort. The header of the http server response 
message is in the Main File->Log window; check there if an error occurs. 

FITS Header:

This section consists mainly of a scrolled text area which shows each field in the FITS header.

If the header contains any of the fields EPOCH, JD or DATE-OBS then the date of the 
observation is displayed above the header. A button will also come alive which allows setting the 
main XEphem time and date to this value. This is handy when checking for asteroids, comets or 
using the proper motion catalogs with an image.

In order to be displayed, the header in a FITS file must contain at least the mandatory fields 
SIMPLE, BITPIX, NAXIS, NAXIS1, NAXIS2 and END. Only files with BITPIX 16 and NAXIS 2 are 
supported. Both DSS PLATE headers and the traditional World Coordinate System fields CTYPE, 
CROTA, CRPIX, CDELT and CRVAL, 1 and 2 are supported. BSCALE and BZERO are not 
support at this time.

Caveats:

XEphem treats the 16 bit pixels as unsigned values from 0 through 65535, unlike the standard 
which specifies they be treated as signed with values from -32768 through 32767. XEphem 
assigns the coordinate [0,0] to be the center of the first pixel in the file, unlike the standard which 
specifies this position be at coordinate [1,1]. 

File watch:

This feature allows XEphem to automatically display FITS files that were created by another 
program. All that is required is to arrange for that program to write the path to the new file to the 
file named in the text field provided here. When Watch is turned on, XEphem will try to open this 
file on a regular basis and read the first line. If successful, the file is displayed and, as a simple 
handshake to the originating program, XEphem removes this communication file.

With this feature and the popularity of various networked file systems (NFS, Samba, etc) it is 
quite reasonable to display images with XEphem that were captured on an entirely different 
computer. Or even on the same computer to use camera control software entirely unrelated to 
XEphem.

A further note to implementors: XEphem also supports this file being a fifo. In this case, XEphem 
will open the fifo and block trying to read a path name up to the first newline. There is no 
handshake in this case.  The fifo approach is actually a bit more efficient than the file approach 
because no polling is required. 

Save as:
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The image currently displayed, if any, may be saved to disk as a FITS file. The file name is 
specified in the text field provided. If "Auto name" is enabled, a filename is automatically created 
derived from the RA and Dec of the center of the image. An attempt is made to preserve any 
existing directory and filename extensions, such that the filename is constructed between the 
right-most ’/’ and the right-most ’.’ characters, if possible.  

When an image is saved, its current contrast settings are added to the FITS headers. If these 
fields are present when the file is opened these settings will automatically be put back into effect. 
See the Help for Images -> Processing tools for details.

Open:

This section is the way to open a local disk file for display. Use the File Selection Box at the 
bottom to choose the desired file. Browse your file system using the Directory and File lists, then 
double-click on the desired file. Or the file name may be typed (or pasted) into the Selection text 
field after which you click Open.

You can browse to any directory on your system (for which you have suitable permission of 
course) but there are two convenience buttons on the right that are particularly handy. One jumps 
straight to the system-wide Shared XEphem directory, and the other jumps to your per-user 
Private directory.

The Filter text field can contain the path and a wild card pattern to match the names of FITS files 
on your system. The default pattern is suitable for most case; it filters for any file extension that 
begins with f and contains a t in any subsequent position. When a new Filter is entered, click the 
Filter button at the bottom to apply the pattern to the directory currently chosen.

10.4.2  Processing tools...

The Sky Image Tools window offers several functions with which 
to analyze the FITS file showing in the Sky View. There are a few 
sample FITS files included with which to practice using the tools.

The window is divided into several separate sections, each of 
which can be opened and closed as desired. Please see the Help 
for each section for specific information on each. 

Always present at the top of the window is a block of basic 
information about the image. This includes:

    file name;
    width and height;
    value and location of brightest pixel;
    value of dimmest pixel;
    mean, median and standard deviation of all pixels.

Two Important Differences between XEphem and FITS:

     1. XEphem treats the 16 bit image pixels as unsigned values from 0 through 65535, unlike 
the FITS standard which specifies they be treated as signed with values from -32768 
through 32767.

    

     2.  XEphem image coordinates are one less than the FITS standard. FITS defines the 
center of the first pixel in the file to be at [1,1] while XEphem defines it to be at [0,0]. 
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10.4.2.1  Brightness and Contrast

This section controls the mapping between image 
pixels and screen colors. It does not modify image 
pixels in any way.
 
This section may be opened using the button 
in the left Sky View toolbar that looks like a 
circle filled with black on the right half.

The top nine buttons offer shortcuts to set or adjust 
the image appearance according to predefined 
algorithms.

Reverse: toggles between assigning brightness in 
direct or inverse proportion to image pixel values.

Narrow, Wide and Full correspond to high, medium 
and low contrast settings. These are implemented 
using increasingly broader assignments of 

brightness about the mean pixel value in the image. Narrow assigns full black and white to the 
mean ± 1/3 Std Dev. Wide assigns black to mean - 1*StdDev and white to mean + 2*StdDev. Full 
assigns black to the smallest pixel and white to the largest pixel in the entire image.

Sharper and Duller change contrast by changing the slope of the pixel-to-brightness map to be 
steeper or flatter.

Brighter and Darker change the brightness by shifting the center of the pixel-to-brightness map to 
higher or lower pixel values.

Nominal ignores the statistical distribution of pixel values and sets the map entirely on the basis 
of the minimum and maximum pixel.

Below the buttons are text fields in which one may type (or paste) the exact pixel value to be 
assigned to black and white. They always show the current settings. A new value takes effect 
when Enter is pressed.

Below that is a scale to adjust Gamma. The mapping from pixels to display colors is a power 
function similar to the Gamma factor for CRT compensation. Values of gamma less than 1 
emphasize dark pixels, gamma values greater than 1 emphasize bright pixels.

The graph contains two overlaid plots. The horizontal axis for each plot is the same: the full range 
of pixel values within the image, with lowest on the left. The orange line is a histogram of the 
number of pixels with each value. The yellow line indicates the brightness at which each pixel 
value will be displayed on the screen. You may control the black and white limits of the mapping 
function from the graph by dragging the red arrows at the top of the diagram. You may control 
gamma by sliding the scale ust above the graph.

When XEphem saves an image, it adds three fields to the FITS header to save the current 
contrast settings. When it loads an image, if these fields are present they are used to restore the 
same display contrast. If these fields are not present, the Wide setting is used. These fields are:

XELOGLUT: the pixel value assigned to black
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XEHIGLUT: the pixel value assigned to white
XEGAMMA:  the value of Gamma.

10.4.2.2  Cross Section Slice

Opening this section lets you use the mouse to drag a line across 
the image and display the pixels along that line. The graph is 
labeled vertically in pixel value, horizontally as pixel distance from 
the starting point. The line begins where the left mouse button is 
first depressed.

This section may also be opened using the button in the right 
Sky View toolbar that looks like a slice of bread.

10.4.2.3   Magnifying Glass

This section gives control over and 
shows information about the pixels 
in the magnifying glass.
    
Click and hold the left mouse button as you roam over the image 
and you will see an expanded view of the pixels. The Size and 
Magnifying power of the glass can be set as desired using the two 
rows of toggle buttons. Note the numbers on these buttons are in 
units of screen pixels, not image pixels. So for example if you 
zoom in on an area the magnifying glass will expand it 
correspondingly further.

While roaming you might want to turn on the Jump to Max 
button on the right hand toolbar. It is the one with the bright 
dot in the center to which a meandering arrow finally points. When 
this button is on, XEphem will begin at the pixel under the real 
cursor and walk the gradient to the brightest connected pixel. All 
processing proceeds as though this brightest pixel is where the 
cursor really pointed.

Statistics about the image pixels under the glass are shown in the 
table. All values are in pixels, all locations are in image 
coordinates. Fractional image coordinates occur because the 
image is resized to fit the window which results in rational values 
for the scale factors. If you zoom in enough to clearly see 
individual image pixels, you can see that the coordinate system for 
image pixels puts the integral position in the center. The statistics 

in the table include:

Size of the area under the glass;
Value and location of the center;
Value and location of the largest pixel under the glass;
Value of the minimum pixel;
Mean value of all glass pixels;
Median value of all glass pixels;
One Standard Deviation of the pixel values about the mean.
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Below the statistics box you can optionally open windows that plot the row or column through the 
center of the glass. The horizontal axis of each graph is in image pixels, the vertical is in image 
pixel values.

This section may also be opened using the button in the right Sky View toolbar that looks 
like a box containing a few stars much larger than the others. However, since the glass is 
useful in its own right, the toolbar button only opens this section if the Image Tools window is 
already up. Similarly, closing this section does not also turn off the toolbar button.

10.4.2.4  Region of interest

This section lets you use the mouse to draw a rectangle over the 
image and get statistics about the pixels within this region. (The 
area is the same one that can also be used to specify a region in 
which to zoom in upon.)

This section may also be opened by the right toolbar button 
that looks like the curson has just drawn a box around a 

galaxy.

The following statistics about the image pixels in the ROI are 
shown in the table:

Length of the diagonal;
Width and height of the region;
Value and location of the cursor as you draw the ROI;
Value and location of the largest pixel in the ROI;
Value of the minimum pixel;
Mean value of all glass pixels;
Median value of all glass pixels;
One Standard Deviation of the pixel values about the mean.

10.4.2.5  2D Gaussian Measurements

This section is based on results of modeling stars with a 2 
dimensional Gaussian. The model finds the coefficients in the 
following function of pixel coordinates x and y that minimizes the 
squared error with each pixel in an area:

    g(x,y) = B + A*exp(-0.5*(sqr((x-mx)/sx) + sqr((y-my)/sy)))

  where
    mx is the row coordinate from some reference position,
    my is the same for a column,
    sx is the standard deviation of the pixel values along a row,
    sy is the same for a column,
    A is the peak height of function ( = g(xm,ym) - g(inf,inf)),
    B is the mean of the row and column pixels.

[mx,my] is then taken to be the location of the star, the volume as proportional to A*sx*sy as a 
measure of its magnitude, and B a measure of the mean noise level of the surrounding pixels.
    
In practice, we find this method converges quickly and yields positional results accurate to .2 pixel 
or so. Magnitudes and their error estimates depend strongly on whether the image was ever 
compressed, proper image cleanup, nonlinearity of ADU counts with brightness, and other 
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factors. When these factors are properly addressed, magnitude ratios seem to be good to .02 
mag or so.

Back to the GUI... the text box shows the results of this fitting process on the image pixels that 
are centered on the cursor and lie within the area defined by the magnifying glass settings 
(whether or not the glass is actually turned on). The numbers report the following:

Relative magnitude difference and error estimate between the current star and the 
reference star;

Position of the star, in image coordinates and in RA/Dec if WCS header fields are 
present;

Full-width-half-max of the star in each dimension in pixels and in arc seconds if the image 
scale is known from header fields CDELT1 and CDELT2;

The pixel value representative of the noise level base in the area (B in the above 
equation);

The pixel value of the peak of the Gaussian fit (A+B in the equation).
    
If there is a number in the Reference Mag text field, it is simply added to the magnitude reported. 
The idea is to set this to the magnitude of a star (known by independent means) and use that star 
as the reference for subsequent comparison. Since the reference is now calibrated, magnitudes 
reported will be "absolute" not just relative. Except under special situations, the reference star will 
not be applicable to other images, although XEphem does not prevent you from doing this.

The reference star can be established in a few ways. One way is automatic in the sense that if 
there is no current reference, the first star that is measured is also automatically given the role as 
reference for subsequent comparisons. After any star has been measured, it can be made the 
reference by clicking on New. Clicking Mark will draw a small circle in the image around the 
current reference star.

Another way to set the reference is to use a catalog star. This is only possible, of course, if the 
header includes WCS coordinates. Right-click on the catalog star and choose the entry "New 
Photom ref". This will perform the Gaussian fit on the pixels at that stars location in the image, 
and assign the Reference Magnitude to the catalog value.

This section of the Sky image tools window can be opened by clicking on the button in the 
right toolbar that looks like a Gaussian graph (or perhaps a large nose).

While measuring stars you might want to turn on the Jump to Max button on the right hand 
toolbar. It is the one with the bright dot in the center to which a meandering arrow finally points. 
When this button is on, XEphem will begin at the pixel under the real cursor and walk the gradient 
to the brightest connected pixel. All processing proceeds as though this brightest pixel is where 
the cursor really pointed.

10.4.3  WCS Solver

This window controls a pattern matching algorithm that attempts to register the star-like artifacts 
in a FITS image with the entries in any or all of the XEphem Field Star catalogs, currently 
including the GSC, USNO, PPM and Tycho star catalogs. The choice of catalogs is controlled by 
the Control -> Field stars window.
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    Rows 1-5: setting seed values.

The first five rows seed the search with approximate coordinates for the center of the 
image, the scale of the image pixels in each direction, and a possible rotation. The center 
must be known to within about one half the smaller of the image width and height. The 
scale must be known to within about 10%. The rotation seed need not be accurate at all, 
but better estimates will result in vastly faster solution times. Indeed, better values for any 
field will improve the solution speed and also reduce the chances of a false solution.

Each of the fields may be typed or pasted into the fields down the left. But often FITS 
files will include fields which contain information suitable for this purpose. In the column 
down the right you may enter the names of such fields. Clicking the "Use field" button in a 
row will read the value from the header field named on the right and install it into the field 
on the left of the same row, possibly after some reformatting and change of units. 
Certainly not all forms are supported so please take care to check for proper units and 
formatting yourself. The default fields supplied are fairly common and are known to work 
if you are lucky enough to have them in your images.

    Row 6: scanning the image for star-like artifacts.

The next row contains two parameters which control the algorithm that scans an image to 
extract what seem to be reasonable candidates for stars, that presumably will also be in a 
Field star catalog.

Burned out: This parameter sets the largest pixel value (in the range 0 .. 65535) a star 
may contain. Groups of pixels being considered as a candidate star by the algorithm will 
immediately reject the entire group if even one pixel is higher than this. The idea here is 
that if a star is so bright as to be even a little burned out, its centroided position is likely to 
be worse than not using it at all. If you feel otherwise, set this to 65535 and no groups will 
be rejected (at least for this reason).

S/N ratio: This parameter sets the minimum signal-to-noise ratio of a candidate star. The 
algorithm breaks an image into several smaller regions and computes several statistics of 
all the pixels in that region. In order for a group of pixels to be considered a star, its 
brightest pixel must be at least the median plus this parameter multiplied by the standard 
deviation computed from the statistics of the region in which it is located. Basically, the 
larger this number, the more distinct the star must be.

    Row 7: Setting realistic search goals.

The bottom row contains two parameters that effect the goal of the search algorithm. 

Max pix acc: This parameter tells the search algorithm not to expect position information 
for the star-like artifacts extracted from an image to be any better than this fraction of a 
pixel.       

Min pix acc: This is the worst pixel distance acceptable between each image star and its 
closest catalog star.    
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    Close

Closes this window.

    Go

Commences the search for a solution using the image currently in the Sky View and the 
parameters in the various fields above.

If a solution is found, each star used in the solution will be circled and statistics about the 
quality of the solution will be presented. The WCS fields that characterize the solution are 
written into the FITS header. If you like the solution, Save the image and this search will 
not be needed again.

    Mark stars

Clicking this button will draw a small circle around each group of pixels in the image the 
algorithm considers to be a star. Use this to choose good values for Burned out and S/N 
ratio.

    Help

Show this text.

10.5  Locate menu

This selection will pop up a list of the basic objects and the currently defined user objects, if any. 
Selecting an entry will place a cross-hair over the object. If the object is not within the field of view 
the Sky View will be moved so the object is centered. If Alt-Az mode is currently active and the 
object is below the horizontal the view will not be changed and a message will suggest the mode 
first be changed to RA-Dec.

To aim the Sky View at any other object in the XEphem database, please use Main -> Data -> 
Search. 

10.6  Telescope menu

The Telescope menu in Sky View allows you to control any GOTO-type telescope that is 
compatible with the venerable Meade LX200.

Clicking on the top item in this menu will bring up a window for configuring and controlling the 
telescope connection. Please see its own help for full details (§10.6  ).

Once XEphem is operating the telescope correctly, it is commanded to a target by positioning the 
cursor at the desired location in the Sky View, press and holding the right mouse button, and 
sliding down and releasing on Telescope GoTo.

Each time this action is performed the target name (or RA-Dec coordinates, if sent to an empty 
sky location) is added to this Telescpoe menu. To command the telescope to the same target 
again, just slide down and release on its entry. The list will grow until erased using the Erase 
history button.

10.6.1  Telescope configuration

This window is for configuring an LX200 connected to a 
serial port of the computer running XEphem. There are 
just a few fields to be filled out.
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Control process:

This field names the driver program that does the real work. The name lx200xed is the 
one for the LX200 command set. This should not be changed unless a new driver has 
been supplied.

Serial device:

This is the name by which your operating system designates the RS232 serial port 
connected to the telescope. The default will be close for a typical installation. See the 
chapter in the manual for more information about specific operating systems.

Show Sky View marker

Once the telescope is working under XEphem’s control, a circle-X marker will be drawn 
on the Sky View to indicate its current position. XEphem keeps this marker within the Sky 
View field of view at all times, and will reposition the Sky View if necessary to achieve 
this. On occasion this behavior can be annoying, such as when you wish to use the Sky 
View for something not immediately related to the operation of the telescope. In this case, 
turn the marker off with this button, and back on later as desired.

Enable Telescope GoTo

This button controls whether the various controls throughout XEphem that command a 
telescope to move are in fact active. These controls appear in the popup menu in the Sky 
View, and in the various planetary closeup windows. If you prefer these controls are 
disabled, click this button off.

Another reason for this button is for those users of XEphem who have built their own 
telescopes with only encoders and no motors. With a suitable driver, XEphem can then 
show the location of the telescope in the Sky View, even though it can not command 
motions.

Use no-hardware test mode

If this button is On when the telescope driver is started running then the driver is really 
started but it does not actually connect to the telescope. In this mode, the driver puts a 
marker on the Sky View at 0H RA 0 Dec. If you then place the cursor at some other 
location in the Sky View, right-click and release on Telescope GoTo, the marker will 
move to this new location. It is as though you are connected to a very fast telescope. This 
mode verifies that all the software is running correctly to operate the telescope and is a 
good troubleshooting step when first making your connections. Or for those who are 
easily entertained, it can also be fun to pretend you have a GoTo telescope.

Running

This button turns the driver (named in the first line) on and off. When it is click On, it 
starts the driver, perhaps in no-hardware mode if that option is selected above.

Close

This closes this window. Closing the window has no effect on telescope operation.
Help

Shows this text.

Contact us at xephem@clearskyinstitute.com if you would like details on how to write a driver for 
a different telescope. If you have the details on your telescope command protocol, the driver will 
be easy to write.    
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10.7  History menu

This is the Sky View History control window. Most of the Sky View settings may be saved and 
restored as entries in the History list. This is handy for saving your favorite views for easy display.

The top pushbutton in the History pulldown menu brings up this window to Edit the list. Additional 
pushbuttons in the pulldown menu allow any one history entry to be applied immediately.

The control window shows the current set of History entries, one per line. Each line has the 
following format:

    Apply will engage the given entry, in the same way as choosing it from the pulldown 
menu.

    Up and Down allow the entries to be rearranged as desired. Remember to Save (see 
below) to keep the changes permanently for next time.

    Delete will remove the given entry.

    Replace acts as a combination Delete and Add (see below).

    The next section shows the basic display modes, the center coordinates and field of view.

    The field on the right allows you to enter a short descriptive label for the entry.

Buttons across the bottom allow for additional control of the History list:

    Add will capture the current Sky View settings and create a new History entry. A default 
label will be created but you should probably change it to something more descriptive if 
you plan to Save the list.

   Save will write all of the current History entries to a file. The file name is 
"xephem_skyhist" and will be created in the per-user directory.

    Load will read an existing file of History entries that has been previously Saved and 
make them the current set. First the per-user directory is searched then "auxil/" off the 
shared directory.

    Close closes the History window.

    Help displays this information.
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10.8  Trails

The location of any object on the Sky view may be computed at regular intervals and displayed by 
setting up a sky trail. Use the Sky View Trails Setup dialog to select the interval, number of steps, 
formatting details and which steps you would like annotated (§15  ). The trail setup dialog is 
accessed from the popup which appears when the third mouse button is activated when the 
cursor is near an object. Any number of objects may have trails. 

The trail is created by computing the location of the object at several intervals.  Each new location 
will be drawn with a tick mark and connected with a line to its previous location. The trails remain 
correct if the display coordinate system is changed. Trails may be turned on or off without loss of 
trail information.  Trail information is discarded if a trail is turned off when a new Main menu 
Update is performed.  If any point on a trail is selected using the third mouse button the 
information displayed is as per the object at that time.  The times displayed next to trailed objects 
are always in UTC. Trail information is not subject to the constraints in the Control->Filter dialog, 
i.e., trailed objects are always shown.

Note that in Alt-Az mode, if an object goes below the horizon the line segments and tick marks of 
the trail are displayed but they are not pickable and names are not drawn. Also, while each trailed 
location is accurately marked on the display, because of diurnal motion these trails are not useful 
for comparison with the background of fixed stars. Use the RA-Dec mode for that. This is so 
important (and easily overlooked) that you will see a reminder notice to this effect the first (and 
only) time you create and display a trail in Alt-Az mode.

Finally, be sure to recompute any trails if you change any of the preferences or circumstances in 
the Main menu.

10.9  Scale controls

    FOV:

        The vertical scale on the left side sets the vertical field of view of the display. The 
horizontal field of view is determined by the width of the window at the same scale. The 
FOV can be varied in 5 minute increments from 0:05 through 180 degrees. The buttons 
below present a quick way to set the scale to exactly 90 degrees and to resize the 
window (by changing the width) to 1:1 and 2:1 W:H aspect ratios.

    Alt / Dec:

        The vertical scale on the right side sets either the center altitude or declination, 
depending on the display mode. The value can be varied from -90 to +90 in increments of 
5 minutes. The buttons below presents a quick way to center the scale at exactly 45, 0 or 
-45 degrees.

    Az / RA:

       The horizontal scale across the bottom sets either the center azimuth or RA, depending 
on the display mode. In Alt-Az mode this sets azimuth and can be varied from 0 to 359:55 
degrees in steps of 5 minutes. In RA-Dec mode this sets Right Ascension and can be 
varied from 0 to 23:59:40 hours, in steps of 20 seconds. 
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11  Solar System view

This is a graphical representation of the solar system. The Sun is always at the center of the 
screen, marked with a small circle.

11.1  Mouse controls
Any object may be identified by pointing near it and clicking the right mouse button. This will bring 
down a temporary popup menu with additional information until the button is released. RA and 
Dec are displayed as of the time the dot was computed. The RA, Dec and Mag given for the 
Earth is that of the Sun.

Several controls may also be present on the popup menu, as follows.

    Persistent Label:

        This toggles whether the label for the object is displayed regardless of whether the 
View->Labels option is activated.

    Assign ->
        To ObjX
        To ObjY
        To ObjZ

        This cascade allows you to assign the given object to become ObjX, Y or Z, as desired 
(§13.3  ). This will also cause all other views which are currently making use of this object 
to be updated and the object will be added to and selected by the Data table.

        Since this makes the object one of the User-Defined objects it will now appear directly in 
the Solar System->Objects pulldown menu.

    Show in Data Table:

        This option is only offered when the object chosen under the cursor is a planet, the Sun 
or the Earth. Selecting this option forces the object to be enabled in the Data Table(§3  ). 
Both the Sun and the Earth actually enable the Sun in the Data Table. 
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11.2  Control menu

    Print...

This selection allows printing the current Solar System view or saving it to a file.

    Create Trails...

This button will bring up a window to set up making a trail (§15  ) for each planet and 
user-defined object as they travel from their current positions. Each trail time is drawn 
connected together with a solid line with each point indicated with a small dot. The time 
stamps shown with the trails, if any, are always in UTC. For the trail to be visible, the 
Trails option must be activated.

Only one set of trails is supported at a time. Creating new trails will delete the old ones. 
The trails will also be discarded if a user defined object is changed or an Update occurs 
from the Main window.

Only the basic planets and user-defined objects, if defined, are trailed. The other solar 
system objects, if any, are always shown in their current positions.

See the Help from the trail setup window itself for more details on how it operates.

    Movie Demo:

This push button will set the Main window Step to 5 days and start looping with a very 
large number of steps. Press the button again or use Stop control in the Main window to 
stop the movie.

    Live Dragging:

This toggle button selects whether the graphics are redrawn in real time as the various 
scale controls are being slid, or whether the graphics are not redrawn until the mouse is 
released. The decision depends on the speed of the computer, display and data 
bandwidth. If the system is fast enough, turning this on can produce dramatic depth 
queues for complex solar system views; also try it in Stereo.

    Stereo pair:

This toggle button is used to bring up another image of the solar system from a slightly 
displaced vantage point. Adjusting your gaze to fuse the two images together will reveal a 
3D image. This effect is most pronounced if fairly lengthy trails are created and legs are 
enabled. This effect was designed primarily to help visualize the orbits of comets.

At the bottom of the stereo display is a scale to control the amount of parallax to 
introduce. The parallax is only introduced in the plane of the ecliptic.  This works well for 
low latitudes but has the odd effect of just moving everything as a whole when viewing 
from near the poles. If you prefer focusing your eyes in front of the screen, move the 
parallax control somewhat to the left; if you prefer to relax your eyes and focus at infinity 
then move the parallax control to the right.



Solar System View

Version 3.5.2 Page 11-3

    Close:

This push button will close both the main Solar system view and the Stereo view. If the 
Solar System view is closed while the Stereo window is on, it will reappear when the 
Solar System window is reactivated. 

11.3  View menu

    Trails:

This toggles whether trails, if currently defined, are displayed for the basic planet objects 
and the three user-defined objects (if any). The trails may be turned on and off as desired 
without loss but the trails are permanently discarded at the next Update from the Main 
window.

    Ecliptic:

This toggle button controls the display of a set of circles in the ecliptic plane, spaced at 
regular intervals. The interval between each circle is displayed at the upper left of the 
view.

    Labels:

This option causes each object’s name to appear.

    Basic Legs:

This toggle button controls whether a line is drawn from each planet and any ObjXYZ 
user objects to the ecliptic. This aids in visualizing the 3D location of the objects.

    DB Legs:

This toggle button controls whether a line is drawn from each Database object (other than 
planets and user ObjXYZ objects) to the ecliptic. This aids in visualizing the 3D location 
of the objects. 

11.4  Objects menu

The planets and the user-defined objects ObjX, Y and Z, if they are solar system objects, may be 
individually turned on and off, without loss of any trail data associated with them, by using the 
toggle buttons in this "Objects" pulldown menu.

    All Basic:

This pushbutton is a shortcut to turn on all the basic planets and user defined objects 
which are in the solar system.

    Just S+E+ObjXYZ:

This pushbutton is a shortcut to turn on only the Sun, Earth and any user-defined objects 
which are solar system objects. It does not effect whether the other database objects at 
large are displayed.

For that, use the next control ...
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    All DB too:

This toggles whether /all/ solar system objects in the data base are also displayed. This is 
great when the asteroids database has been loaded.

In expectation of increased drawing time with all these objects, when this option is on the 
scales switch so they only cause an update when they are released at their new net 
position.

Note: these objects are never trailed. If you want to include one of these objects in a trail, 
first assign it to ObjX, Y or Z.

Note: Trail data is discarded at the time of the next Update from the Main window, regardless of 
whether the object is displayed at that time or not. 

11.5  Scales

The three scales at the edges control the position of the observer. The vertical scale on the left 
controls the distance from the sun -- you are closer as the scale is slid further up. The horizontal 
scale under the view controls the heliocentric longitude -- think of it as a rotation about the central 
axis. The value of the scale is the heliocentric longitude towards you. The vertical scale on the 
right controls the heliocentric latitude -- your angle above the ecliptic plane. 

Changes to the scales take effect as you drag, unless the View->All Objects option is on in which 
case the change does not take effect until you release the scale. 
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12  Tools

As interesting and entertaining as the visual displays are in XEphem, perhaps its greatest value is 
its quantitative features. The algorithms used for the planets are directly traceable to the JPL 
DE200 numerical integration and will match the Astronomical Almanac to full displayed precision. 
The natural satellites models were supplied by the French Bureau of Longitudes and are accurate 
to 0.5 arcsecond between the years 1996 and 2020 (2Q98) . Topocentric apparent place is 
computed by starting with astrometric mean place (including Solar deflection) and applying 
corrections for precession, nutation, aberration, relativistic deflection, parallax, and refraction (the 
latter two depend on accurate values for latitude, longitude, elevation and atmospheric pressure 
and temperature). Comet and asteroid ephemerides do not include perturbations but timely orbital 
elements are readily available for downloading via the Internet.

All of this accuracy can be tapped directly, as described in the next several sections. Many of 
these features take advantage of one common trait: all data fields throughout XEphem may be 
turned into Pushbuttons which allow them to be easily registered for use by these features. This 
eliminates the need to make manual notes or perform data copy-paste, and allows the data to be 
available programmatically at various date and time settings.

12.1  Plot values

This window controls the plot generation and display functionality of XEphem. You may select 
most numeric information displayed by XEphem, in pairs, to form x/y coordinates of a plot. You 
may select up to ten such pairs. You then select a file to contain the plot information. XEphem 
adds one line of information to the file for each x/y pair each time iteration step. XEphem can also 
plot any such file on the screen.

Selecting data to plot: 

Select the "Select fields" toggle button to make each field in the other menus that are 
eligible for plotting appear as a pushbutton. Select each such button as desired to form 
the x or y component of a plot. As you make the selections, they are listed in the menu. 
You may also associate a one-character tag with each line. These tags will be included in 
the plot display for identification later. Once all the field choices have been made you 
may return all the menus to their normal operational appearance by reselecting the same 
toggle button.

 
Specifying the plot file name:

Type the name of the file to be used to contain the plot information in the text field 
provided. When XEphem first needs to write to the file, it will first check for the existence 
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of the file and, if it already exists, ask whether you wish to append to the file or overwrite 
it.

 
A leading ‘~/’ in the filename will get expanded to the value of your HOME environment 
variable. 

Specifying a plot file title:

Enter a short title for the plot information in the text are provided.  When XEphem first 
writes to a plot file, it will place the contents of the title text area, if it is not empty, into the 
file as a comment. All lines within a plot file that do not begin with an alphanumeric 
character are considered comments and are ignored. If the first line of a file is a 
comment, XEphem will use it as the title for the plot when it displays the plot. 

Generating the plot entries:
 

Once the fields have been specified and the plot file named and titled, you may select the 
"Plot to file" toggle button when ready. Now each time XEphem goes through one 
iteration the values you have selected and their tags will be written to the plot file. Note 
that when plotting is activated, XEphem does not update the screen until the "N Steps" 
count goes to 1. This greatly speeds the creation of plot files by avoiding screen updates. 
If you wish to watch each iteration, set "N Steps" to 1 and select the "Update" button 
manually for each iteration. Once all the desired data has been entered into the plot file, 
toggle the plot button back off to flush all data and close the file. 

The windows that contain each of the fields used in the plot need not be visible while the 
plot is being generated. 

Viewing plot files:
 

Existing plot files may be viewed by entering their name into the text field provided and 
selecting the "Show plot file" pushbutton. As many different plot files may be viewed 
simultaneously as desired. Each plot has separate controls for flipping the X and Y axes 
and for turning on and off a reference coordinate grid.

The XEphem distribution kit includes a sample plot file of the analemma.
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12.2  List values

This window controls the list generation functionality of XEphem.  The fields you select define 
columns of a table written to a file as XEphem runs. These columns look exactly like their 
corresponding fields on the XEphem windows and so are more familiar and readable than the 
entries in plot files. They are designed to be used in further text processing operations or printed 
as-is. Two spaces are placed between each column.

Selecting data to list:

    Select the "Select fields" toggle button to make each field in the other windows that are 
eligible for listing appear as a pushbutton. Select each such button as desired to form 
each column of the listing. As you make the selections, they are listed in the table. Once 
all the column choices have been made you may return all the windows to their normal 
operational appearance by reselecting the same toggle button.

Specifying the listing file:

    Type the name of the file to be used to contain the listing in the text field provided. When 
XEphem first needs to write to the file, it will first check for the existence of the file and, if 
it exists, ask whether you wish to append to the file or overwrite it.

    A leading ‘~’ in the filename will get expanded to the value of your HOME environment 
variable.

    You may also elect to print the file in LaTeX table format by pressing the given button 
before beginning to list to the file.

Choosing to include column headings:

    When this option is selected, column headings are written to the output file each time the 
file is opened.

Specifying a listing file title:

   All lines within a listing file that do not begin with an alphanumeric character are 
considered comments and are ignored.  When XEphem first writes to a listing file, it will 
place the contents of the title text area, if it is not empty, into the file as a comment for 
your convenience.

Generating the listing entries:
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    Once the fields have been specified and the listing file named and titled, if desired, select 
the "Create list file" toggle button. Now each time XEphem goes through one iteration the 
values you have selected will be written to the file. Note that when listing is activated, 
XEphem does not update the screen until the "N Steps" count goes to 1. This greatly 
speeds the creation of listing files by avoiding screen updates. If you wish to watch each 
iteration, set "N Steps" to 1 and select the "Update" button manually for each iteration. 
Once all the desired data have been entered into the listing file, toggle the list button back 
off to flush all data and close the file.

    
Menus that contain each of the fields used in the listing need not be visible for the fields to be 
listable. 

12.3  Solve equation

This window controls the automatic equation solving facility. You define an arithmetic or boolean 
function, using most of the fields XEphem displays, then XEphem will automatically evaluate the 
function and adjust the time on each iteration to solve for the goal.

To set up a function to solve, follow these steps:

   Enter a function,
   Compile it,
   Select a goal,
   Set the desired accuracy,
   Enable solving,
   Start the solving process.

Each of these steps is described below.

Entering the function:

    The function may be any arithmetic expression, in C-language syntax.  All of C’s 
comparison, logical and arithmetic operators are supported as well as several common 
arithmetic functions. Here is the complete list:

+ - * / && || > >= == != < <=

abs floor sin cos tan asin acos atan

degrad raddeg pi log log10 exp sqrt pow atan2

    The function is entered into the text line provided. It may utilize most of the fields from the 
other XEphem windows. Press the "Enable field buttons" button to make each available 
field a button. Where ever a field is desired in the function, position the text insertion 
cursor at the desired position and select the field; its name will be inserted into the 
function text. When you are finished defining the function, turn off the field button 
appearance by selecting the "Enable..." button again.  Once you get to know the names 
of the fields you may also enter them manually, if you prefer.

Compiling the function:

    Once the function has been entered as desired, it must be compiled by selecting the 
"Compile" button (or by pressing the Return or Enter key on your keyboard).  If there are 
any errors, a diagnostic message will appear just below the function. Once a function has 
been successfully compiled, the message will read No compile errors. If the function is 
modified, a message will remind you that it has not been compiled. Each time a function 
is successfully compiled, XEphem updates all fields and evaluates the function. As 
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explained below, this can be used as a sort of "astronomical calculator" even when not 
actually solving anything.

Selecting a goal:

    You may choose from any of three evaluation algorithms, as selected by the trio of radio 
buttons. "Find extreme" will solve for a maxima or minima of the function. "Find 0" will 
solve for a time when the function evaluates to zero.  "Binary" will keep incrementing time 
by "Step" (in the Main window) until the state of the function changes, then do a binary 
search to find the exact time when the function changes state. Binary search interprets a 
function that evaluates to zero to be in one state and all other values to be the opposite 
state. Generally, binary functions are comprised of logical operators at their outermost 
expression levels.

Specifying the desired accuracy:

Searching will automatically stop when the time changes by less than the the accuracy 
value. Note that this method of detecting convergence is not based on the value of the 
search function itself. To change the desired accuracy press the pushbutton showing the 
current accuracy next to the "Accuracy" label and enter a new value in the window.

Enabling the solver:

Once the function is defined and it compiles without errors, you may enable searching for 
a solution by selecting the button at the top labeled Solving is Active. Then, each time 
"Update" is selected on the Main window the solution advances by one time step until 
either "N Steps" iterations have occurred or until "Step" becomes less than Accuracy. The 
initial time and step size are set from the Main window, and are adjusted automatically as 
the solution proceeds. Note that by setting "N Steps" to 1 and repeatedly selecting 
Update you can effectively single-step the process. Solving will automatically turn off 
when convergence is detected, the function is edited or you may turn it off manually at 
any time by toggling the button labeled "Solving is Active" back off.

Additional notes on using the equation solver:

    When selecting fields for plotting or listing a button appears labeled "Use for plotting". 
You may select this button to use the evaluated function as an item in the plot or listing 
feature. Note that the function may be used in plotting and listing whether or not actually 
solving is enabled.

The windows which contain the fields used in the function being solved need not be 
visible while solving is in progress.

The Close button removes the Solving window from the screen; it does not effect actual 
solver operation in any way.

A successfully compiled function is evaluated each time XEphem updates. Whenever the 
function is compiled it is also evaluated using freshly updated values. In this way, the 
Solve window can actually be used as an arbitrary "astronomical calculator" at any time, 
whether or not solving is actually active.

Hint:

Solving periodic functions can lead to solutions far from the intended range. You will get 
best results if you can start the search near the expected answer and with a small step 
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size that bounds the solution. You can use the plotting feature to study a function and get 
an idea of the solution, then use the solver feature to zero in.
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12.4  Find close pairs

This window allows you to scan the list of objects currently in memory for all pairs which are 
separated by less than a given angular distance.

First set up the desired maximum separation, in degrees, and faintest magnitude. Note that larger 
separations result in larger lists and hence longer sorting times. Also set other options via the 
Options menu. Separations will be topocentric or geocentric depending on the Equatorial 
preference in the Main menubar. Then start the scan via the Update button in the Control menu.

When the scan completes, all pairs meeting the criteria will appear in the scrolled list. The 
columns in the list are as follows:

 Magnitude_1 Name_1     Magnitude_2 Name_2       Separation

The entries are sorted in increasing order of separation. The total number of pairs and current 
conditions are reported above the list and the time when the scan was performed is indicated in 
the time stamp label below the list. The scan does not include field stars. 

12.4.1  Control menu

    Update

This performs one scan. The XEphem cursor will change to the Watch shape until the 
scan is complete. The results are listed in the scrolled list when complete.

    Sky Point

This will place a cross-hair over the first object of the selected pair on the Sky View, 
re-aiming if it is currently not in the field. Either select the pair in the list then press this 
button, or double-click on the pair in the list. (These commands do nothing if the Sky 
View is not currently up.)

    List to file...
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        This selection allows writing the current collection of close objects to a file.

        A window is presented which allows you to enter a file name. If the file does not exist, the 
file is written as soon as you select Ok. If the file already exists, you are first asked 
whether you wish to append to the file or overwrite existing contents.

        The format of the file begins with a header line that captures the conditions in effect when 
the set of close objects was built. Following the header, there is one line per pair with 
exactly the same information as appears in the window list.

    Close

        This closes the Close Objects window. The list is not modified in any way while it is 
closed.

12.4.2  Options menu

     Auto update

When this option is active, a scan for close objects is performed automatically each time 
an Update is commanded from the Main window. The prior list is discarded each time. 
The list is never updated when the window is not open.

    Auto list

When this option is active, the results of each scan are automatically appended to the file 
specified in the "List to file" window. This works whether the scan was performed 
explicitly via the Control -> Update command here or implicitly via an Update from the 
Main window and the "Auto update" option is active.

    Omit fixed pairs

When this option is active, then pairs of Fixed objects are not listed.
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12.5  Night at a Glance

This window displays the current day, with local midnight in the center. Across the bottom is a 
scale marking local dates and time and UTC time, at each even hour. The current XEphem time 
is marked with a thin vertical line.

The background gray shading shows when the Sun is up, down and periods of twilight. The 
twilight period matches the Sun Dip setting in the main XEphem window.

Overlayed on the gray background is one thick horizontal line for each basic object and any of the 
user objects ObjX,Y,Z that are defined. The lines show when the object is above the horizon, as 
defined in the Data View->Control->Setup horizon parameter.

Clicking with the right mouse button near an object’s line will pop up its rise, transit and set 
information. This is with respect to the day in which the moment occurs corresponding to the 
mouse click location. A button is also included in the popup to set the main XEphem time to this 
moment. If the mouse is clicked far from any object, then just the time is presented.

The lines and text colors are set based on type of object, or can all be set to one color using the 
Control->One color toggle.

The window may be printed using the Control->Print menu option (§14  ).

An interesting exercise is to set up a time loop with a Step size of a few days and watch how the 
rise and set times of objects and the amount and timing of night time are effected throughout the 
year. 
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12.6  AAVSO light curves

This window provides easy access to the database of variable star light curves maintained by the 
American Association of Variable Star Observers, AAVSO. Many thanks to AAVSO for their 
support of XEphem.

First make sure your Internet connection is functioning. The connection may be made directly, or 
via a Proxy or SOCKS server. These may be configured in the File->Network setup window 
(§2.1.1  ).

To display a light curve:

    1. Enter the AAVSO Name or Designation in the fields in the upper left. For example, OMI 
CET for Mira. If both are entered, the Designation has priority.

    2. Enter a range of dates for the data to be retrieved. These may be given as a Julian Date 
or in the current Date format as set in the Main Preference menu. The Starting date may 
also be given as "default" which is about 2 years of data; the Ending date may also be 
given as "latest" which means the newest data available from AAVSO.

    3. Press Enter or the Get Curve button at the bottom.

To print the current light curve, press Print.

The Sky View may also be used to specify an object as follows:
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    1. Position the cursor near the desired sky location in the Sky View.

    2. Press and hold down the right mouse button.

    3. Slide down the popup menu to AAVSO and release.

    4. The 5 stars in the AAVSO that are nearest to the cursor position are shown in the list in 
the upper right sorted by ascending order of distance.

    5. Click on one entry in the list to move it to the Name and Designation fields on the left and 
proceed as above to display a light curve. Or if the date ranges are already set as 
desired, double-click the entry in the list and the curve will be fetched immediately.

The database AAVSO.edb is specially tailored to match the official names of stars maintained in 
the databases at AAVSO. Using this database will facilitate the selection and retrieval of AAVSO 
light curves. Databases can be changed from the Data -> Load/Delete menu in the Main window. 

12.7  SETI@home

This window can read and interpret the various log files which accompany the SETI@home client, 
version 2 and 3. For full details about this remarkable project, see 
http://setiathome.ssl.berkeley.edu.

Enter into the text field at the top the path to the directory in which the setiathome client is 
running.

The controls operate as follows:

    Refresh

Reread the log files in the SETI@home directory specified about and produce a new 
report. An error is reported if any of the required files can not be read.

    Sky Point:
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This will center the Sky View at the position of the work unit currently being processed. It 
also assigns the location of the work unit to user-definable object OBJZ; doing so will add 
it to the Locate pulldown menu of the Sky View and add it to the View->Data table for 
easy reference.

    Sky Mark:

This will mark the position of the work unit currently being processed on the Sky View, 
but only if it is already within the Sky View field of view. The Sky View is never re-aimed 
with this command. This always also assigns the location of the work unit to 
user-definable object Obj Z (§13.3  ); doing so will add it to the Locate pulldown menu of 
the Sky View and add it to the View->Data table for easy reference (§3  ).

    Auto refresh

When this toggle is active, a Refresh is performed automatically every 10 seconds. This 
toggle is turned off when the window is closed.

The large text box contains some report details. Most entries are taken directly from the 
setiathome status files. The Refreshed: entry is the time and date at which the display info was 
produced; its time zone is as per Preferences->Time zone (2.5  ).

At the bottom are controls to Close the window and see this Help information.

12.8  Coordinate Converter

This window performs simple conversions among several common astronomical coordinate 
systems. Simply type (or paste) into any text field and the others will update immediately.

All fields are in units of Degrees except RA is in Hours. Fields may be entered in either 
sexagesimal or decimal format. For example, either 10:30:00 or 10.5.

Altitude and Azimuth are with respect to the time and location set in the Main window. These will 
change to correspond to the RA and Dec values if an Update is performed.

The Equinox for the RA and Dec values is the one shown in the Main window.

The controls across the bottom perform as follows:

    Close

        Closes this window.

    Sky point

        Marks the coordinates shown on the Sky View map, recentering if
        necessary to place it in the field of view.
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    Get sky

        Loads each field from the current center position of the Sky View.

    Canonize

        Reformats each field in a consistent manner for easier viewing.

    Help

        Display this text.
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13  Data

XEphem works with objects in memory. The controls in this section provide facilities to manage 
this set.

13.1  Load and Delete

This window allows you to load, delete and inspect the collection of objects that are currently in 
memory. These objects form what is referred to as the XEphem database.

The top section of the window displays a count of each major type of object and the total number 
in the database. The counts do not include the planets, Sun, Moon or the user-defined objects 
ObjX, Y and Z.

The center section lists the catalogs which are currently loaded and the number of objects they 
contributed. The objects loaded from a catalog may be deleted using the button to the left of the 
count. This list may be saved at any time so this set of catalogs is automated loaded when 
XEphem starts. To do so, go to Preferences->Save and Save the XEphem.DBInitialFiles 
resource under the Data Base category.

The lower section allows you to browse the directory structure on your system for database files 
in XEphem format and load them into memory. See the README in the base distribution for a 
brief description of each catalog. The Filter field sets the directory and file name pattern to qualify 
being included in the list of Files. Any directory may be searched but handy buttons at the bottom 
right allow setting the directory to the values of the Shared and Private directories. The Filter 
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button in the lower center forces the directory given in the Filter field to be rescanned for all files 
which match the filter pattern therein. Double-click on a directory to show the files which match 
the pattern.

A database file is loaded into memory by selecting the file name in the list at right then pressing 
Load at the bottom of the window, or by double-clicking its name in the list. Both .edb and .tle 
formatted files are supported. If the file is already loaded, it will first be deleted. If the file contains 
exactly one entry, the object may also be automatically assigned to a user-defined object; see 
Help->on Control for more details.

Or rather than browsing, any file name may be simply explicitly typed in the Selection field and 
loaded by typing Enter or pressing Load.

The sash in the center of the window controls the proportion of space allocated to the Catalogs 
and Browse sections as desired.

XEphem may also load objects from another process via a fifo. Please refer to the separate 
description of this facility in Help->on Control, §13.1.1  . 

13.1.1  Control menu

    Delete all

Deletes all file and their objects from memory. The files on disk are not effected.

    Open DB Fifo

Listen for database objects arriving via a fifo from another process. XEphem attempts to 
reopen the fifo each time the button is pressed.

The file name of this fifo is fifos/xephem_db_fifo off the shared directory.

All relevant displays are automatically updated when data arrives via this fifo. The format 
of the fifo data is exactly the same as for any XEphem database file. Due to the way the 
fifo data is read and processed, it is important that each line be terminated with a 
newline; incomplete last lines can result in loss of information.

    No Dups

If this toggle is on then when a new database file is loaded, objects from other catalogs 
whose name already exists in memory will be silently skipped. This option does /not/ 
check for duplicates among the user defined objects, ObjX/Y/Z, nor entries within the new 
file itself.

    Load Obj when 1

If this toggle is on then when a new database file is loaded and it defines exactly one 
object, it will also be assigned to one of the user defined objects, ObjX, Y or Z. The one 
affected is the first which is either undefined, whose name matches the new object, or 
ObjZ. This feature is also available for files loaded when XEphem first starts.

    Close

Closes the Data Base window.
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13.1.2  .edb File format
Follows is the description of the format of an XEphem database file. The file name extension is 
.edb.

General Information:

    Each object occupies one line in the file. Lines are separated into Fields using commas 
(,). Some fields are further subdivided into Subfields with vertical bars (|). Lines beginning 
with anything other than a-z, A-Z or 0-9 are ignored and may be used for comments. The 
order of objects in a file does not matter.

    Where they appear, all date fields may be in either of two forms:

      1) month/day/year, where day may contain a fractional portion. examples: 
1/1/1993 and 1/1.234/1993

        NOTE: the format of dates in database files is always M/D/Y, regardless of the 
current XEphem Date format Preference setting.

      2) year as a real-number, such as 1993.123.

Field Definitions:

The first two fields are always Name and Type. Remaining fields depend on Type.

The Name field is the object’s name. Any number of characters may be present but only 
the first 13 are retained as significant.

The Type field consists of a single letter designating the form of the object’s motion and 
must be one from the following set:

  f: fixed (no proper motion) e: heliocentric elliptical orbit h: heliocentric hyperbolic orbit p: 
heliocentric parabolic orbit E: geocentric elliptical orbit, i.e., Earth satellite

If Type is "f" (fixed), an object class code may follow in the next subfield:

      A: Cluster of galaxies
      B: Star, binary
      C: Cluster, globular
      D: Star, double
      F: Nebula, diffuse
      G: Galaxy, spiral
      H: Galaxy, spherical
      J: Radio
     K: Nebula, dark
      L: Pulsar
      M: Star, multiple
     N: Nebula, bright
     O: Cluster, open
      P: Nebula, planetary
     Q: Quasar
      R: Supernova remnant
      S: Star
      T: Stellar object



Data

Page  13-4 Version 3.5.2

      U: Cluster, with nebulosity
      V: Star, variable

      if class is one of T, B, D, S or V, the spectral class and possibly the numerical subclass 
designation may follow as 1 or 2 characters in the next subfield.

      if class is G or H, the size field (described next) may include minor axis and position 
angle as subfields.

  The remaining fields for Type f are as follows:

       RA, hours
       Declination, degrees
       magnitude
       reference epoch, optional, assumed to be 2000 if absent
       size = angular size, arc seconds, optional.

           For elliptical objects such as galaxies, this field may be divided into 3 subfields if desired: 
the size of the major axis, the size of the minor axis (both in arc seconds), and the 
position angle, in degrees E of N.

These 3 subfields can also apply to double stars, where the first subfield is the separation 
in arc seconds, the second subfield is set to 0, and the third field is the position angle.

If the Type is "e" (elliptical heliocentric, eccentricity < 1) the remaining
fields are defined as follows:

       i = inclination, degrees
       O = longitude of ascending node, degrees
       o = argument of perihelion, degrees
       a = mean distance (aka semi-major axis), AU
       n = mean daily motion, degrees per day (computed from a**3/2 if omitted)
       e = eccentricity,
       M = mean anomaly (i.e., degrees from perihelion),
       E = epoch date (i.e., time of M),
       D = the equinox year (i.e., time of i/O/o).
       g,k or H,G = two fields which define the magnitude model; select which by preceding the

first field with a "g" or an "H" (2 parameters)

If the Type is "h" (hyperbolic heliocentric, eccentricity > 1) the remaining
fields are defined as follows:

       T = epoch of perihelion
       i = inclination, degrees
       O = longitude of ascending node, degrees
       o = argument of perihelion, degrees
       e = eccentricity,
       q = perihelion distance, AU
       D = the equinox year (i.e., time of i/O/o).
       g,k = two fields which specify the magnitude model
       s = angular size at 1 AU, arc seconds, optional
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If the Type is "p" (parabolic heliocentric, eccentricity == 1) the remaining
fields are defined as follows:

       T = epoch of perihelion
       i = inclination, degrees
       o = argument of perihelion, degrees
       q = perihelion distance, AU
       O = longitude of ascending node, degrees
       D = the equinox year (i.e., time of i/O/o).
       g,k = magnitude two fields which specify the model
       s = angular size at 1 AU, arc seconds, optional

If the Type is "E" (Earth satellite) the remaining fields are defined as
follows:

      Epoch
      inclination, degrees
      RA of ascending node, degrees
      eccentricity, must be < 1
      argument of perigee, degrees
      mean anomaly, degrees
      mean motion, revolutions/day
      orbit decay rate, revolutions/day^2
      integral reference orbit number at Epoch
      drag coefficient, 1/(earth radii); optional

      The venerable Two-Line-Element (TLE) format is also automatically detected and 
supported. For a complete discussion of TLE format see 
http://www.celestrak.com. 

13.1.3  Notes

XEphem does not use the facility controlled by this window for so-called Field Star catalogs. See 
the Help for Data->Field Stars for more information on managing these special catalogs.

XEphem ships with a few perl scripts which might be helpful for converting databases in other 
formats into XEphem format. These scripts are in the tools/ directory of the XEphem source 
distribution tree.

13.2  Download Internet files

This window provides an easy 
means to download any file 
which contains objects defined in 
either XEphem’s .edb format or 
the NORAD 2-Line Element 
(TLE) format commonly used for 
Earth satellite. While 
downloading a file, any set of 
lines found to match either 
format are extracted and saved 
to a file named the same as the 
last component of the URL 
except for changing the 
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extension to .edb if necessary. In this way, XEphem automatically detects either format and 
derives a sensible file name.

Several particularly useful sites as of this build are already entered. The first three are Dr. TS 
Kelso’s Earth satellite lists. The other four are the Minor Planet Center’s lists of hot comets and 
unusual asteroids.

During the download, a search pattern may be entered to look for an object with a name 
containing the pattern. Click on the Search option and enter the desired pattern. The comparison 
ignores case and blanks.  If a match is found, the entry is shown in the text block. If more than 
one match, the first is shown. Regardless of whether any match the entire file is saved.

Whenever a valid object specification in either format is in the test box, it may be assigned to 
User Defined Object X, Y or Z by clicking the appropriate button. The specification may be 
entered by hand or copy/paste; it need not have come from a downloaded file. 

Special Asteroid files:

Special files created by the Minor Planet Center and Lowell Observatory may also be 
downloaded. Each organization maintains extensive lists of all known asteroids and produces on 
a regular basis Keplarian orbital elements precessed to the current date. Both are of excellent 
quality, but Lowell’s list is some 20% longer.

When the "Get" button is clicked, XEphem downloads the appropriate file, uncompresses it, 
reformats it to .edb format and splits the results into two files for convenience. One file will contain 
all asteroids which can ever become brighter than magnitude 13, and the other (with a "_dim" 
suffix) contains all the rest. The search pattern facility does not apply to these files.

All files are created in the user’s Private XEphem directory.

Special thanks to these organizations for their service.

13.3  Search, Obj X, Y, Z

This window allows you to select, inspect and modify 
any object currently in memory. It also allows you to 
control the user defined objects, ObjX, ObjY and 
ObjZ.

XEphem supports three user-defined objects, 
denoted ObjX, Y and Z. These may be fixed objects; 
objects in elliptical, hyperbolic or parabolic 
heliocentric orbits; or objects in geocentric elliptical 
orbits. The ObjX/Y window allows you to define these 
objects.

XEphem maintains a working copy of these objects 
for use with the ObjX/Y/Z window that is separate 
from the real ObjX and ObjY and ObjZ. The ObjX/Y/Z 
window always works on these working copies. The 
working copies and the real ObjX/Y/Z only interact 
when using the Ok, Apply and Reset control, as 
described shortly.
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This window is always displaying information from one of these working copies as indicated by 
the small radio box in the top center of the window. The radio box may also be used to change 
whether ObjX, Y or Z is being displayed and manipulated. We will refer to the one selected as the 
"current working object."

The radio box in the upper left displays the basic type of the current working object. This can be 
changed by selecting another of the collection of toggle buttons.

In the left and center of the window is an area that lists each field for the current working object 
and its present value. The list is adjusted to correspond to the fields that are associated with the 
type of the current working object. These fields may be changed by selecting the button that 
contains their value. This will bring up a small text entry window. A new entry may be typed into 
the window box and applied by typing Enter or selecting the Ok button. The value may be left 
unchanged by selecting Cancel.

Along the right edge of the window is a list of each object currently loaded into the XEphem 
database. (See the Help for the "Database Load and Delete" window for more information on 
manipulating this data base, §13.1  ).) If there are more than 20 items then a scroll bar may be 
used to browse through the list. The entries are sorted in numeric and alphabetic order, ignoring 
case, for easy browsing.  If one of these objects is picked, then it is copied to the current working 
object.  You may then edit the values for this working object, if desired, without effecting the 
original.

Below the list of names is a text field with which you may select an object by name. Enter a string 
and type Enter or press the Search: pushbutton. All objects in memory will be searched for one 
with a name that contains the string. Whitespace and case are ignored. To anchor the string to be 
at the beginning of the object’s name precede the string with a caret (^). If a match is found, the 
list is scrolled so the object is at the top and the object is copied to the current working object. To 
select again with the same string, type Enter or press the Search: pushbutton again. XEphem 
beeps if no matches are found.

When the current working object is as you want it, select Apply to copy it into the real ObjX (or 
ObjY or Z) used throughout the other functions of XEphem. Ok will do the same thing and also 
close the window.

Other controls include:

    Reset

        load the current working object with a copy of the real ObjX (or ObjY or Z).

    Sky Point

        mark the current working object on the Sky View with a cross-hair, re-aiming if it is not 
currently in the field. The object is marked even if the object does not match the Sky View 
filter or is outside the magnitude range. The only time the object will /not/ be marked is if 
the display mode is set to Alt-Az mode and the current working object is below the 
horizon.

    Sky Mark

        will draw a cross-hair on the Sky View window at the location of the current working 
object but only if it is already within the Sky View field of view. The Sky View window is 
never re-aimed with this command.
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    Set Tel

        will cause the coordinates of the current object to be sent to the
xephem_loc_fifo fifo, which is typically connected to a telescope
control process. The command is not issued if the object is currently
below the horizon. See the discussion at Sky_View->Help->on Telescope
for more information (§10.6  ).

13.3.1  Fixed objects

Fixed objects are characterized by five parameters: 

    RA,
    Dec,
    magnitude,
    the reference epoch for the coordinates and
    angular size in arc seconds, optional

Note: 

In order to conserve memory usage, XEphem stores the astrometric RA and Dec for a 
fixed object only once with each object. These values are always precessed *in place* to 
the current display equinox. Thus, you will find that the RA and Dec displayed for a given 
object may change if the equinox is changed on the main menu and the object 
information is redisplayed here on the ObjX/Y menu.

13.3.2  Elliptical objects

Elliptical objects are characterized by 12 parameters: the parameters that define a heliocentric 
elliptic orbit and the coefficients for either of two magnitude models.  These elements are the 
same ones often listed in the Astronomical Almanac.  The elements are, in order: 

    i = inclination, degrees
    O = longitude of ascending node, degrees
    o = argument of perihelion, degrees
    a = mean distance (aka semi-major axis), AU
    n = mean daily motion, degrees per day
    e = eccentricity
    M = mean anomaly (i.e., degrees from perihelion)
    E = epoch date (i.e., time of M)
    D = the equinox year (i.e., time of i/O/o)
    g,k or H,G  = two fields to specify either of two magnitude models; see
        below
    s = angular size at 1 AU, arc seconds, optional
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You might have other parameters available that can be converted into these. The following 
relationships might be useful: 

    P = sqrt(a*a*a)
    p = O + o
    n = 0.9856076686/P
    T = E - M/n
    q = a*(1-e)
    AU = 149,597,870 km = 92,955,621 U.S. statute miles
 where
    P = the orbital period, years;
    p = longitude of perihelion, degrees
    T = epoch of perihelion (add multiples of P for desired range)
    q = perihelion distance, AU

Note that if you know T you can then set E = T and M = 0. 

XEphem supports two different magnitude models for elliptical objects. One, denoted here as g,k, 
is generally used for comets in elliptical objects. The other, denoted H/G, is generally used for 
asteroids in the Astronomical Almanac. 

The g,k magnitude model requires two parameters to be specified. One, the absolute magnitude, 
g, is the visual magnitude of the object if it were one AU from both the sun and the earth.  The 
other, the luminosity index, k, characterizes the brightness change of the object as a function of 
its distance from the sun. This is generally zero, or very small, for inactive objects like asteroids.  
The model may be expressed as: 

    m = g + 5*log10(D) + 2.5*k*log10(r)
 where:
    m = resulting visual magnitude;
    g = absolute visual magnitude;
    D = comet-earth distance, in AU;
    k = luminosity index; and
    r = comet-sun distance.

Note that this model does not take into account the phase angle of sunlight. 

When using this model for elliptical objects, the first of the two magnitude fields must be preceded 
by a letter "g". This applies in both the .edb database file and the corresponding menu elliptical 
object definition prompt; otherwise the default magnitude model for elliptical objects is the H/G 
model. 

The H/G model also requires two parameters. The first, H, is the magnitude of the object when 
one AU from the sun and the earth. The other, G, attempts to model the reflection characteristics 
of a passive surface, such as an asteroid. The model may be expressed with the following code 
fragment: 

    beta = acos((rp*rp + rho*rho - rsn*rsn)/ (2*rp*rho));
    psi_t = exp(log(tan(beta/2.0))*0.63);
    Psi_1 = exp(-3.33*psi_t);
    psi_t = exp(log(tan(beta/2.0))*1.22);
    Psi_2 = exp(-1.87*psi_t);
    m = H + 5.0*log10(rp*rho) - 2.5*log10((1-G)*Psi_1 + G*Psi_2);
 where:
    m   = resulting visual magnitude
    rp  = distance from sun to object
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    rho = distance from earth to object
    rsn = distance from sun to earth

Note that this model does not take into account the phase angle of sunlight. 

The H/G model is the default magnitude model for elliptical objects but it can also be explicitly 
indicated when the first of the two magnitude fields is preceded by a letter "H". This works in both 
the .edb database file and the corresponding menu elliptical object definition prompt.

13.3.3  Hyperbolic objects

Hyperbolic objects are characterized by 10 parameters: the parameters that define a heliocentric 
hyperbolic orbit and the magnitude model coefficients. These orbital parameters are, in order:

    T = epoch of perihelion
    i = inclination, degrees
    O = longitude of ascending node, degrees
    o = argument of perihelion, degrees
    e = eccentricity,
    q = perihelion distance, AU
    D = the equinox year (i.e., time of i/O/o).
    g,k = two fields for the magnitude model
    s = angular size at 1 AU, arc seconds, optional

As with elliptical elements, other parameters might be available.  The relationships are generally 
the same, except for: 

    q = a*(e-1)

The g,k magnitude model requires two parameters to be specified. One, the absolute magnitude, 
g, is the visual magnitude of the object if it were one AU from both the sun and the earth.  The 
other, the luminosity index, k, characterizes the brightness change of the object as a function of 
its distance from the sun. This is generally zero, or very small, for inactive objects like asteroids.  
The model may be expressed as: 

    m = g + 5*log10(D) + 2.5*k*log10(r)
 where:
    m = resulting visual magnitude;
    g = absolute visual magnitude;
    D = comet-earth distance, in AU;
    k = luminosity index; and
    r = comet-sun distance.

Note that this model does not take into account the phase angle of sunlight.

13.3.4  Parabolic objects

Parabolic objects are characterized by 9 parameters: the parameters that define a heliocentric 
parabolic orbit and the magnitude model coefficients. These orbital parameters are, in order: 

    T = epoch of perihelion
    i = inclination, degrees
    o = argument of perihelion, degrees
    q = perihelion distance, AU
    O = longitude of ascending node, degrees
    D = the equinox year (i.e., time of i/O/o).
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    g,k = two fields for the magnitude model
    s = angular size at 1 AU, arc seconds, optional

The g,k magnitude model requires two parameters to be specified. One, the absolute magnitude, 
g, is the visual magnitude of the object if it were one AU from both the sun and the earth.  The 
other, the luminosity index, k, characterizes the brightness change of the object as a function of 
its distance from the sun. This is generally zero, or very small, for inactive objects like asteroids.  
The model may be expressed as:

    m = g + 5*log10(D) + 2.5*k*log10(r)
 where:
    m = resulting visual magnitude;
    g = absolute visual magnitude;
    D = comet-earth distance, in AU;
    k = luminosity index; and
    r = comet-sun distance.

Note that this model does not take into account the phase angle of sunlight.

13.3.5  Earth satellites

Objects in Earth orbit are characterized by 9 parameters: the parameters that define a geocentric 
elliptical orbit. These orbital parameters are, in order: 

   Epoch of the measured values
   inclination, degrees
   RA of ascending node, degrees
   eccentricity, must be < 1
   argument of perigee, degrees
   mean anomaly, degrees
   mean motion, revolutions/day
   orbit decay rate, revolutions/day^2
   integral reference orbit number at Epoch

XEphem treats all earth satellites as if they had a visual magnitude of 2.0. 

13.4  Field Stars
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This window allows you to control which field star sources you wish to use. The window is 
accessible from the Main window as well as from the Control menus of most graphical views.

XEphem uses the term "field star" to refer to the huge numbers of faint stars visible in any real 
world view of the sky. Field stars are generally far more numerous than could be reasonably 
accommodated in the XEphem *.edb database format. For this reason they are stored and made 
available in their own special compact forms for utmost efficiency. The downside to this approach 
is that field stars are not included in the totals presented by the Data->Load window nor are they 
available for searching or inspection using the Data->Search window. This results in little loss of 
generality, however, since (once found!) they may be assigned to the user defined objects (ObjX, 
Y or Z) by using the popup menu in the Sky view and thus be further investigated via the Data 
table window (§3  ).

The controls in the Field Stars setup window are grouped into categories, depending on the basic 
source of the stars.

Hubble Guide Star Catalog:

This is the seminal work created by the Space Telescope Science Institute to support the Hubble 
Space telescope. It contains from 13 million unique stars, or about 300 stars per square degree of 
sky. It may be accessed with XEphem in the following ways:

    ASP CDROM Directory:

        This choice enables reading field stars from the Hubble Guide Star Catalog available on 
two CDROMs published by the Astronomical Society of the Pacific.

        Mount a CDROM somewhere onto your filesystem, type the name of the mount directory 
in the text field provided then turn this option on and press Apply. Note that XEphem 
assumes your CDROM driver removes the trailing ";1" from all filenames.

    Local Cache Directory:

        This choice enables reading GSC field stars from your local disk. If this option is on along 
with the CDROM option, then as requests are satisfied from the CDROM a compact form 
of the same data will be written to files below the directory named in this option. Then the 
next time the same field stars are needed, and this option is on, they will be obtained 
from the local disk files rather than the CDROM. In fact, the CDROM is not needed or 
used if the local disk contains all the stars for any given access. The entire 2 CDROM set 
loads onto disk in this format in some 180 MB.

        The default path of the directory which holds the disk version is "catalogs/gsc" off the 
shared directory.

        Note: There is also a utility in the tools/gsc directory, gscload, with which you may 
preload an entire ASP CDROM segment at once if desired.

        (These files are already included in the commercial version of XEphem.)

    Internet to xephemdbd:

        This choice is to use the Internet to access an XEphem GSC server. See the XEphem 
home page for the current list of GSC server hosts.
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        To use this source, select this option and type the URL to the remote xephemdbd.pl in 
the text field provided.

    Internet to ESO:

        This choice accesses the GSC catalog service maintained by the European Southern 
Observatory. This choice emulates a web browser query and uses the Proxy or SOCKS 
facilities (described below) which should make it accessible to user behind firewalls.

        The CDROM or the cache options may not be used at the same time as the network 
options.

        Note that the ESO GSC server (apparently) arbitrarily and (certainly) silently restricts the 
total number of stars it will return, so larger and/or deeper fields may not contain all stars.

        You may also access this service directly from your Web browser at 
http://archive.eso.org/cgi-bin/gsc.

USNO A or SA catalogs:

This choice of field stars supports the SA or even the A series of astrometric catalogs produced in 
recent years by the US Naval Observatory. The SA2.0 for example, includes some 54 million 
stars, spatially sampled so there is about 1,300 stars per square degree of sky. Note that such a 
uniform distribution does not "look" much like the real sky, but it is great for its intended use as an 
astrometric mesh for comet hunters or such.

    Root directory:

        To order these catalogs, see http://psyche.usno.navy.mil/pmm.

        If you have such a catalog, simply enter the name of its base directory and toggle this 
switch on. The default assumes a symbolic link, "catalogs/usno" off the shared directory.

        The suggested citation for SA1.0 follows:

            Monet, D., Bird, A., Canzian, B., Harris, H., Reid, N., Rhodes,
            A., Sell, S., Ables, H., Dahn, C., Guetter, H., Henden, A.,
            Leggett, S., Levison, H., Luginbuhl, C., Martini, J., Monet, A.,
            Pier, J., Riepe, B., Stone, R., Vrba, F., Walker, R. 1996,
            USNO-SA1.0, (U.S. Naval Observatory, Washington DC).

 This catalog has been included with permission of USNO as long as we mention the 
follow stipulations

        It may not be the latest version, check with http://ad.usno.navy.mil.

        If you paid for XEphem, you paid for the software, not this catalog. The catalog is 
available free from the USNO.

        Inclusion of the SA2.0 catalog does not imply an endorsement of XEphem by 
USNO; nor did I have privileged access to the catalog; nor does the US 
Government affirm or guarantee that XEphem works properly in any way. 

Proper Motion catalogs:
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These catalogs include information regarding proper motion. The position of the star is moved to 
its location according to the current XEphem time when the stars are loaded. In order to see a 
movement, change the time, and watch carefully.

Two such catalogs are currently available ready for XEphem. You may only use one at a time, by 
choosing the corresponding toggle.

    PPM catalog:

        This is the Positions and Proper Motion catalog of S. Roeser and U. Bastian, 
Astronomisches Rechen-Institut, Heidelberg, published in 1990. The PPM includes 
468,586 stars rather evenly distributed throughout both hemispheres. This averages out 
to more than 10 stars per square degree. The set includes the original North and South 
editions plus the extended supplement. The set includes more than 99% of the stars in 
the original SAO catalog and some 70% of the Henry Draper Catalogue (HD).   While the 
SAO catalog is more or less complete to V=9, with stars as faint as V=10, the PPM 
catalog is fairly complete to V=9.5, and goes somewhat deeper than V=10.

    Hipparcos and Tycho-2:

        This catalog is a combination of the Hipparcos and the Tycho-2 astrometric catalogs 
published by the European Space Agency. These are now considered the best proper 
motion catalog in available.

        This catalog contains all Hipparcos stars for which astrometric and magnitude values are 
assigned, and all additional non-redundant entries from the Tycho-2 catalog except 
multiple-component entries. There is a total of some 2.5 million stars, or about 60 stars 
per square degree.

    One example of a star with high proper motion is Groombridge 1830 (HD 103095), in 
Ursa Major, near 11h53m 37d44m. For a nice discussion see Burnham’s Celestial 
Handbook, Volume III, page 1978. By comparing its position in either PM catalog with the 
same entry from the GSC one can deduce this particular GSC field was evidently taken in 
early 1983. 

Skip likely duplicates:

        All of the above may be used together with the regular database facility of XEphem. If this 
option is on, XEphem eliminates what appears to be redundant entries for the same star 
from the various catalogs. Two stars are considered the same if their positions match 
within 4 arcseconds and their magnitudes differ by less than 3. (The generous magnitude 
tolerance is because the GSC and the PPM use varying filters). When deciding on the 
final selection for such duplicate entries the highest priority is the local database, then the 
HD or SAO entry, then the PPM entry, then Hipparcos, then Tycho and finally the GSC 
entry.

When you have made the desired entries, pressing Apply will attempt to check each filename, 
directory and Internet choice, as appropriate. The cursor will be a Watch while the tests are in 
progress. If something does not seem correct, a warning window will appear and the option will 
be turned back off. If everything seems to be operating correctly, you are in business. The Ok 
button does the same thing but then also closes the window if they all succeed. If at any time 
during normal operation something goes wrong during the acquisition of any Field Stars or FITS 
files from any View, the responsible option in that view is also turned off automatically.
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All field star sources will silently enforce limits on the total number of stars they yield for any 
query. As of this writing, local queries are limited to 15 degrees; network queries impose their 
own limits; FITS and DSS images are limited to sizes of 20 arcminutes or smaller.
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14  Print

This window lets you print the current view or save it to a file. In either case the format used is 
Postscript.

If you enter a string in the text field labeled Title, the string will be printed centered across the top 
of the page.

The top two toggle buttons allow you to choose whether color commands will be included in the 
Postscript generated.

If you choose to Save to a file, turn on that toggle button and type the desired file name in the text 
box to the right of the toggle button. The file name will be relative to the directory from which 
XEphem was executed or you may precede the file name with "~/" to refer to your home directory.

If you choose to print directly to the printer, turn on that toggle button and type a command which 
will print a Postscript file on your system. The command should expect the name of a file to print 
as its first and only argument. A temporary file will automatically be created for this command and 
deleted when printing is completed.

When ready, press Ok. To avoid printing, press Cancel.

If your current viewing fonts are not available for printing, error recovery will depend upon your 
local print system.



Page  14-2 Version 3.5.2



Trails

Version 3.5.2 Page 15-1

15  Trails

This window allows you to define a set of time values spaced at regular intervals beginning at the 
current XEphem time and define which and in what manner values will be annotated with a time 
stamp. 

This is a general purpose facility used in several places throughout XEphem, generally for the 
purpose of establishing a trail of object motion. This description will be of a general nature. For 
the specific information on how a given XEphem view uses these time values, please refer to the 
Help information associated with that view. 

Seven parameters must be specified:

Orientation: 

This choice determines Where the stamps appear in relation to their corresponding tick 
mark. 

The radio box in the upper left corner provides several strategies for placing the time 
stamps near each tick mark. The first several options should be obvious. The last two, 
"Path-left" and "Path-right", cause the time stamps to be placed to the left or right side of 
the trail path, as one would perceive these directions when traversed in forward order. In 
no case are the time stamps ever drawn to require you to turn your head more than 90 
degrees left or right. 

Interval:

This is the time interval between each step. 
Choose from among the several handy intervals in the upper central radio box, or choose 
Custom and enter any desired interval in the space provided. It is okay to specify more 
than 24 hours to achieve intervals of several days. It is also okay to specify negative 
values to run time backwards. 
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Label:

This choice determines which intervals will to be label with a time stamp. 
Choose from among several options in the upper right radio box, or choose None if no 
labeling is desired. 

Format: 

This choice determines how to display each time-stamp.
 

The lower left radio box offers either Hour:Minute format or the current date Preference 
(as set in the Preferences->Date formats option in the Main menubar). 

Font:

This choice sets the size of the annotation text font.
 

The bottom central radio box allows you to choose from several character sizes for the 
time stamps. 

Start:

This choice specifies how the first time value is derived from the current XEphem time. 

The lower right radio box offers several methods of determining the beginning of the first 
time interval. "Whole min" rounds the current XEphem time forward to the next whole 
minute, if necessary; "Whole day" rounds to the next whole day. "Whole interval" rounds 
to the next whole multiple of whatever time interval is set (as specified in the Intervals 
choices). "Now" means to begin with the current XEphem time without any initial 
changes.

The idea here is generally to match the time values of each time mark with the precision 
implied by the format, but to allow other options as necessary. 

Number of tick marks:

This is specified by setting the scale near the bottom of the dialog to the desired number. 

Once the choices are set up as desired, Ok will create the trail and the dialog will disappear. 
Apply will create the trail but the dialog will remain up for further use. Close just dismisses the 
dialog without creating a trail. Help brings up this message. 

Even with all this flexibility pleasingly annotated trails are not trivial to generate. It is hoped that a 
little experimentation can yield acceptable results in most cases. 

Note that this general trail facility does not provide close coupling with the view being supported. 
For example, some views do not support setting a trail for an object which has changed while the 
Trail Setup is up. Also, views may vary in their support of having trails defined while they are not 
visible. Each view may establish its own initial default values but changes usually remain in effect 
for subsequent instances of Trail Setup dialogs from the same view. Some views permit more 
than one Trail Setup to be active at one time. In short, the operational boundary conditions vary 
by view.
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16  Meade LX200 Support
This chapter describes how to operate a Meade LX200 (or compatable) telescope from XEphem. 
The discussion here applies to all platforms. See the Installation chapter for any issues on a 
particular platform. Also refer to the Telescope Configuration window for configuration details 
(§10.6  ).

16.1  Disclaimer
Before going any further we must make some things perfectly clear. We believe the information 
provided here and the functionality provided by our software will perform in a satisfactory manner. 
However:

CLEAR SKY INSTITUTE INC IS NOT RESPONSIBLE FOR ANY DAMAGE CAUSED 
TO YOUR EQUIPMENT UNDER ANY CIRCUMSTANCES WHATSOEVER.

USE AT YOUR OWN RISK.

We also wish to make it clear that this work was performed independently of and is not endorsed 
by Meade Instruments Corporation. Their "only" contribution was to build a great amateur robotic 
telescope and provide for its computer control.

16.2  Cable
For handy reference, below is a diagram showing the basic wiring of the cable between the 
LX200 RS232 port and a female DB9 connector suitable for connecting to COM1 on most PCs. 
Note that although the the LX200 accepts a 6 pin connector, the outter two leads are not used, so 
a common telephone-style 4-pin connector may be used.

For more information, try the following web sites:

http://www2.crl.go.jp/ka/tnp/meade/cable.html

http://www.mapug.com/AstroDesigns/MAPUG/Battery2.htm#anchor2189857

16.3  Routine operation

With the LX200 powered and connected, lx200xed running, and the Marker turned on in the Sky 
View, you should see the telescope target symbol at the same RA and Dec reported by the 
LX200 hand paddle display. The Sky View will automatically reposition itself as necessary in 
order to keep the marker visible. If the cursor is outside the Sky View, the coordinates of the 
marker are shown in the upper corners.
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To move the telescope, put the cursor over a sky location to which you would like to point the 
telescope and press the right mouse button. A popup will appear. Without letting go, slide down to 
Set telescope and release. This should send a command to the LX200 to move to that location 
and commence tracking. You can watch it move on the Sky View as the marker is updated.

That’s about all there is to it. Just point and go. Or if you just want to move your LX200 by hand or 
with its own control paddle you can just watch where it is pointing on the Sky View.
If you want to aim the Sky View somewhere other than at the telescope, turn off the Marker in the 
Telescope menu first or else it will keep bouncing back to keep the Marker in the field; then turn it 
back on later when you again want to see where the telescope is pointing. In anticipation of not 
wanting this locking-on behavior, the Telescope Marker is automatically turned off if you use the 
Locate menu, use the Center or one of the Zoom buttons in the popup menu, or use one of the 
Sky Point controls found elsewhere in XEphem (such as the Data->Search window, §13.3  ). 
During all this Marker on and off business, there is no need to kill and restart lx200xed; it will just 
stand by for XEphem to reconnect.

Note: The computer and the LX200 keep separate notions of time and Earth location. The 
software makes no attempt to change these on either side. The closer you make these in sync, 
the more similar XEphem and the LX200 paddle will report information. We have found that if the 
SIDE and LOCAL values on the paddle match the Sidereal time and Lat/Long, the time and date 
agree, refraction is turned off in XEphem (by setting an air pressure of 0), XEphem Epoch is set 
to 2000, and XEphem is set to update its time about every 2 seconds or so, then the LX200 and 
XEphem will agree in all reported values to full display precision. There will always be one 
difference however: XEphem uses North as 0 degrees Azimuth, whereas the LX200 uses South; 
thus they will always differ by 180 degrees.
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17  Notes

1) The program uses a horizontal plane tangent to the Earth Elev feet above sea level as the 
horizon for all altitude calculations, rise/set events, etc. Due to Earth’s curvature, this is not the 
same as the angle up from the local horizon unless the observer is directly on the ground. The 
effect can be found from:

     sin(a)**2 = (h**2 + 2Rh) / (R+h)**2
 where:
     R = radius of earth
     h = height above ground (same units as R)
     a = increase in altitude

The effect is remarkably significant. For example, it is more than two arc minutes at a height of 5 
feet.

2) Libastro is based on VSOP87. For Mercury, Venus and Mars the accuracy of this model rises 
to 1" at the ends of the year range 2000 +/- 4000. For Jupiter and Saturn, the 1" range is 2000 +/- 
2000. For Uranus and Neptune, it is 2000 +/- 6000. For the Moon, 1" accuracy is for the range 
-1369 to +2950.

Other heliocentric objects are well within one arc minute at the time of the epoch of their 
elements; this steadily worsens with time since XEphem does not apply perturbations.

Using a GPS position locator and transit, I have independently verified Sun and Moon limb rise 
and set times are accurate to within one minute and azimuths are with about 0.1 degree.

3) The Sun-Moon distance is the solution for the third side of a planar triangle whose two other 
sides are the Earth-Moon distance and Earth-Sun distance separated by the angle of elongation.

4) The visual magnitudes for the planets take into account the phase of the illumination; the 
magnitudes for other solar system objects do not.

5) The following is the current TODO list of ideas for XEphem. Thanks to all who have made 
suggestions. Please let me know your priorities or suggest more.

 + write a tool to find g/k from a set of predicted magnitudes.
 + add undo for plot and listing selections.
 + display occultation path between *any* two objects in the Earth view
 + show correct Moon and Planet phases and orientation in Sky View.
 + add sidereal day and month trail intervals.
 + just label month and year tickmarks in trails when they change
 + comet tail pointer
 + meteor showers, (dedalus)
 + Iridium flares
 + allow using a tracked object as the reference for a trail
 + arbitrary solar system perspective
 + option for rise/set info to be Today or Next.
 + add "Plot JD as years" to plot display
 + add H:M:S trails Format option
 + way to keep list close pairs while looping
 + way to keep skyview listing ongoing while looping
 + add general text and graphics annotation for all views, with save.
 + use better earth shape model (at least an oblate spheroid)
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 + add separate Sol view with real-time Net sunspot and coord grids.
 + add T->F and F->T to Binary, min/max to Extreme and stop when T/F or <0/>0
 + Jupiter satellite shadows
 + use user-defined horizon for rise/set calculations
 + some means to automatically print while looping (PS multi-page format?)
 + interactive way to create user-defined horizon, with labeling.
 + way to repeat the Solver for more solutions, as in "solver in a loop"
 + support Sloan and GSCII when complete.
 + change to an XML database format, then add real doubles, variables, etc
 + set an ROI in sky view and click an object to ask "when will it be in box"
 + more hot-keys
 + more flexible time stepping

Known Bugs:
 - Pref->Zone should apply everywhere.
 - Pref->Zone does not update dates of FM/NM if they happen to squirm.
 - constellation figures could stand some improvement.
 - length of night wrong when savings time causes dusk after midnight
 - center constellation names based on boundaries rather than on figures
 - solar trails don’t account for long-term (10’s of years) precession
 - changing font shrinks sky and Earth views unless their view has changed once
 - plot’s View settings are not Saveable.
 - trails are not always clipped properly against a user-defined horizon
 - alt/az grid at dec +/-90 (and v.v.) is crazy
 - use Crenshaw’s method for more stable minimax solver algorithm



Credits

Version 3.5.2 Page 18-1

18  Credits
First and foremost, many thanks to my wife, Kathy, for her unwavering trust,
acceptance and support; aka, Love. 

Beyond that, the following are in no particular order but all are greatly
appreciated:

Thanks to Fridger Schrempp, fridger.schrempp@desy.de, for his long term
encouragement of the project, and particularly for many suggestions to
improve ease of use.

Thanks to Aaron Price, aaronp@mira.aavso.org, for his work and enthusiasm to
support accessing AAVSO data directly from within XEphem.

Earth satellite orbit propagation is based on the NORAD SGP4/SDP4 code, as
converted from FORTRAN to C by Magnus Backstrom, b@eta.chalmers.se. See
"Spacetrack Report Number 3: Models for Propagation of NORAD Element Sets"
at http://www.celestrak.com/NORAD/documentation/spacetrk.pdf.

Improvements to Delta T code, help and wording contributed by Neal McBurnett,
nealmcb@bell-labs.com.

Any parts of the USNO SA2.0 catalog that are included with XEphem
distributions are done so with the following understandings:

    It may not be the latest version, check with http://ad.usno.navy.mil.

    If you paid for XEphem, you paid for the software, not this catalog. The
    catalog is available free from the USNO.

    Inclusion of the SA2.0 catalog does not imply an endorsement of XEphem
    by USNO; nor did I have privileged access to the catalog; nor does the
    US Government affirm or guarantee that XEphem works properly in any way.

Thanks to Atsuo Ohki, ohki@gssm.otsuka.tsukuba.ac.jp, for numerous fixes
and features.

Thanks to Robert Lane, roblane@alum.mit.edu, for Uranonmetria 2000 work.

The near real-time weather map in the Earth view is provided by the Space
Science and Engineering Center at the University of Wisconsin. See their
web site at http://www.ssec.wisc.edu/ssec.html.

The XEphem logo was contributed by Jonathan Adams, jfadams@mail.arc.nasa.gov.
The galaxy background image is from Galaxy Photography, www.galaxyphoto.com.

For the years 1999-2010 the natural satellite ephemerides for Mars, Jupiter,
Saturn and Uranus are based on developments in mixed functions computed and
contributed at Bureau Des Longitudes, http://www.bdl.fr, by J.-E. Arlot, Ch.
Ruatti and W. Thuillot. Many thanks! The authors state these are generally
good to 1/2 arcsecond accuracy. In my test against JPL DE405 I would say this
is true about 50% of the time, with a worst case of about 4 AS.
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Outside this range, Jupiter’s moons based on information in "Astronomical
Formulae for Calculators" by Jean Meeus. Richmond, Va., U.S.A.,
Willmann-Bell, (c) 1982. Saturn’s moons based on code and ideas supplied by
Dan Bruton, Texas A&M, astro@sfasu.edu. For all dates, ring tilts based on
"RINGS OF SATURN" program by Olson, et al, Sky & Telescope, May 1995, page
95. C code as converted from BASIC by pmartz@dsd.es.com (Paul Martz).

Thanks to Monty Brandenberg, mcbinc@world.std.com, for his assistance
and solution to the unaligned access messages on Digital UNIX.

Thanks to Christophe Magneville, cmv@hep.saclay.cea.fr, for finding an array
subscript and a numeric overflow problem in libastro.

Thanks to Jean-Etienne.LAMIAUD@tcc.thomson-csf.com for a fix to prevent
gif color tables from hogging more than their share of X colormap entries
and many corrections to xephem.sit.

Thanks to Stuart Levy, slevy@ncsa.uiuc.edu, for his work converting the Tycho
ESA mission database adc.gsfc.nasa.gov:/pub/adc/archives/catalogs/1/1239 into
xe format.

Many formulas and tables are based, with permission, on material found in:
"Astronomy with your Personal Computer" by Dr. Peter Duffett-Smith,
Cambridge University Press, (c) 1985.

The high precision planet positions were implemented for XEphem by Michael
Sternberg <sternberg@physik.tu-chemnitz.de> based on the papers

    "Planetary Theories in rectangular and spherical variables:  VSOP87
    solution" by Bretagnon P., Francou G., in Astron. Astrophys. 202,
    309 (1988), ftp://ftp.bdl.fr/pub/ephem/planets/vsop87/, and

    "Representation of planetary ephemerides by frequency analysis.
    Application to the five outer planets" by Chapront J., Astron.
    Astrophys. Suppl. Ser. 109, 181 (1995), ftp://adc.gsfc.nasa.gov/\
    pub/adc/archives/journal_tables/A+AS/109/181.

    See the comments in chap25.h and vsop87.h for accuracy estimates.

The high precision Moon code was also implemented for XEphem by Mr. Sternberg
based on code supplied by Stephen L. Moshier <moshier@world.std.com> at
ftp://ftp.std.com/pub/astronomy/selenog.zip. Mr. Sternberg also incorporated
the algorithm for deltaT, based on code also provided by Mr. Moshier. See the
comments in deltat.c for full references. My greatest thanks to Messrs.
Sternberg and Moshier for their generous and kind assistance in making XEphem
a program of first-class accuracy.

The improved lunar libration trig series fit to JPL DE403 was provided by
Stephen L. Moshier, <moshier@world.std.com>.

Many thanks to Michael Naumann, Michael.Naumann@eso.org, and Miguel Albrecht,
malbrech@eso.org, at ESO and Tim Kimball, archive@stsci.edu, at STScI for their
help and support accessing the DSS at their institutions. And thanks to ESO
and STScI in general for offering this service at all.

Thanks to Seiichi Yoshida, seiichi@muraoka.info.waseda.ac.jp, for a subtle
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fix to the constellation code in 3.1.

The sample spacecraft elements were furnished by Ron Baalke,
baalke@jpl.nasa.gov.  

Thanks to Vance Haemmerle, vance@toyvax.Tucson.AZ.US, for his updated and
appended lists of spacecraft elements, and work on improvements to the
solar system plotting of long-period trail sequences.

Thanks to Jeroen Valkonet (jeroenv@cvi.ns.nl) for planting the seed which 
grew into the new bitmap clipmask approach of drawing the stars.

Thanks to Jim Bell, jimbo@cuspif.tn.cornell.edu, and the team at Mars Watch for
encourage, support and ideas for the first Mars albedo map in XEphem. The
map as of Version 3.3 is from http://maps.jpl.nasa.gov/mars.html.

Thanks to Dimitromanolakis Apostolos <apdim@grecian.net> for his contribution
leading to support for fetching DSS in gzipped form.

Thanks to Miguel Albrecht, malbrech@serv2.hq.eso.org, at ESO for his assistance
and support of their fine Web access facilities to the GSC.

Rotated trail text uses the xvertext package. Here is the copyright:

    xvertext 5.0, Copyright (c) 1993 Alan Richardson (mppa3@uk.ac.sussex.syma)

    Permission to use, copy, modify, and distribute this software and its
    documentation for any purpose and without fee is hereby granted, provided
    that the above copyright notice appear in all copies and that both the
    copyright notice and this permission notice appear in supporting
    documentation.  All work developed as a consequence of the use of
    this program should duly acknowledge such use. No representations are
    made about the suitability of this software for any purpose.  It is
    provided "as is" without express or implied warranty.

IC.edb was submitted by Christos Siopis, siopis@astro.ufl.edu.

Constellation algorithm is from a paper by Nancy G. Roman, "Identification
of a constellation from a position", Publications of the Astronomical
Society of the Pacific, Vol.  99, p.  695-699, July 1987. Further contributions
from Chris Marriott and Ernie Wright. The list of boundaries is derived from
the three files constell.1875.data, constell.1875.hdr and constell.doc at
ftp://explorer.arc.nasa.gov/pub/SPACE/FAQ/.

New version of Gemini constellation by Lutz Maendle, lmaendle@csi.com.

Thanks to Dr. Harald Fischer (fischer@vs-ulm.dasa.de) for the GPS awk routine
and sample position database.

The high-precision precession routine is from 1989 Astronomical Almanac, as
interpreted by Craig Counterman. Mr. Counterman also deserves the credit for
providing the initial encouragement to write an astronomical tool specifically
for X Windows back in 1990, and for significant assistance while developing
the heliocentric models.

The Earth map is derived from data supplied with xearth which included the
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following notice:

   Copyright (C) 1989, 1990, 1993, 1994 Kirk Lauritz Johnson

   Permission to use, copy, modify, distribute, and sell this
   software and its documentation for any purpose is hereby granted
   without fee, provided that the above copyright notice appear in
   all copies and that both that copyright notice and this
   permission notice appear in supporting documentation. The author
   makes no representations about the suitability of this software
   for any purpose. It is provided "as is" without express or
   implied warranty.

   THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
   INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS,
   IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, INDIRECT
   OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM
   LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
   NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
   CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

The pulsar and Radio databases are based on lists supplied by Robert Payne,
rpayne@nrao.edu. Errors in converting to XEphem are mine.

The lunar image is based on one I found surfing at: ftp://seds.lpl.arizona.edu
/pub/images/planets/moon/fullmoon.gif. The calculations for the longitude
of the terminator and the solar altitude are based on the program colong.bas
by David Bruning and Richard Talcott, published in _Astronomy_, October 1995,
page 76.

Thanks to Richard Clark (rclark@lpl.arizona.edu) for an improved version
of anomaly.c.

A great source of comet information is http://encke.jpl.nasa.gov.

Special thanks to Uwe Bonnes, bon@LTE.E-TECHNIK.uni-erlangen.de, and
Ralphe Neill, ran@rdt.monash.edu.au, for their many ideas and support.

Many test cases were gleaned from the pages of Sky and Telescope, (C) Sky
Publishing Corp.

Most of the sample cities in the "xephem.sit" file are from the xsat program,
which included the following notice:

    Copyright 1992 by David A. Curry

    Permission to use, copy, modify, distribute, and sell this software and its
    documentation for any purpose is hereby granted without fee, provided that
    the above copyright notice appear in all copies and that both that copyright
    notice and this permission notice appear in supporting documentation.  The
    author makes no representations about the suitability of this software for
    any purpose.  It is provided "as is" without express or implied warranty.

Most of the sample observatories in the "xephem.sit" file are transcribed,
with permission, from the table beginning on page 28 in the July 1993 issue of
Sky and Telescope. Any errors in transcription are strictly my own.
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Thanks to Lowell Observatory and the Minor Planet Center for maintaining
their huge lists of asteroids. See ftp://ftp.lowell.edu/pub/elgb/astorb.html
and http://cfa-www.harvard.edu/cfa/ps/mpc.html, respectively.
Thanks to the National Space Science Data Center and the Smithsonian
Astrophysical Observatory for the SAO star catalogue.

Thanks to the members of the Saguaro Astronomy Club for the preparation and
free distribution of their deep-sky database. Any errors in conversion to the
.edb format are strictly mine.

Thanks to Chris Beecroft <aldebaransys@home.com> for his encouragement and
technical assistance in adding postscript. The limited results in no way
reflect on his capabilities. Initial encouragement was also received from Frank
M. Siegert <frank@miranda.tue.schwaben.de>. And thanks to everyone who has
asked for printing over the years -- I now admit that I like it too!

Bright stars are based on the 5th Revised edition of the Yale Bright Star
Catalog, 1991, from ftp://adc.gsfc.nasa.gov/pub/adc/archives/catalogs/5/5050.
Common names supplied by Robert Tidd (inp@violet.berkeley.edu) and Alan Paeth
(awpaeth@watcgl.waterloo.edu). Any errors in conversion to the .edb
format are strictly mine.

I wish to thank all the organizations behind the incredible Internet for its
maintenance and free and easy access. I also wish to express my hope that
it retains the spirit of cordial cooperation it fostered in its formative
years.

I learned most of what I know of X Windows and Motif programming from ICS
courses and material found in the various excellent texts from O’Reilly &
Associates, Inc.

Thanks to MIT and the X Consortium for inventing, championing and maintaining
the X Window system, and the various contributing organizations to the Open
Software Foundation for Motif. Their vision of network-aware graphics is
still unmatched.

Similarly, I will be forever indebted to all who contributed to UNIX. My
passion and appreciation for this remarkable operating system matured while I
enjoyed four wonderful years at Kitt Peak National Observatory (now the National
Optical Astronomical Observatory), Tucson, AZ, in the early 80’s. As with X,
UNIX plays a central role in my enjoyment of a career in scientific computing.

It was at KPNO where I met the late Dr. W. Richard Stevens, a fellow champion
of the elegance of the UNIX architecture, life-long friend and mentor.

Special thanks to all the folks over the years who have provided innumerable
ideas, suggestions and bug reports, both for XEphem and its ancestor, ephem. A
major benefit to writing and distributing these programs has been the chance to
make many friends from around the world.

Elwood Downey
ecdowney@ClearSkyInstitute.com
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Plot values    12-1
Popup    5-4
POSIX    2-14
Postscript    1-9, 14-1
power    10-22
PPM    13-14
precession    3-1, 3-4, 12-1
Pressure    2-2
Print    14-1
Printing    1-9
Private    13-1
profile file format    10-14
Proper Motion    13-13
Proxy    2-5

RA    2-7, 3-2
RA of ascending node    13-11
Range    5-4
Reference Mag    10-24
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